curl: bump to 7.57.0 (3 CVEs)
authorHans Dedecker <dedeckeh@gmail.com>
Wed, 29 Nov 2017 21:56:41 +0000 (22:56 +0100)
committerHans Dedecker <dedeckeh@gmail.com>
Thu, 30 Nov 2017 08:44:17 +0000 (09:44 +0100)
CVE-2017-8816: NTLM buffer overflow via integer overflow
CVE-2017-8817: FTP wildcard out of bounds read
CVE-2017-8818: SSL out of buffer access

For other bugfixes and changes in 7.57.0 see https://curl.haxx.se/changes.html

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/network/utils/curl/Makefile
package/network/utils/curl/patches/200-no_docs_tests.patch

index 55cf39fedcf0a0e1f4d1f405442f33e97e4d3787..17fcf704de6b99c30df65058ca1875865654b187 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.56.1
+PKG_VERSION:=7.57.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
        http://curl.mirror.anstey.ca/ \
        http://curl.askapache.com/download/ \
        https://curl.haxx.se/download/
-PKG_HASH:=2594670367875e7d87b0f129b5e4690150780884d90244ba0fe3e74a778b5f90
+PKG_HASH:=c92fe31a348eae079121b73884065e600c533493eb50f1f6cee9c48a3f454826
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
index 9ef4819d414ebb165d869f69e35beb26256ba928..a2a6851252b0e86e7496addd70ebfc27a734ab55 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.am
 +++ b/Makefile.am
-@@ -155,7 +155,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
+@@ -156,7 +156,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
  bin_SCRIPTS = curl-config
  
  SUBDIRS = lib src
@@ -9,7 +9,7 @@
  
  pkgconfigdir = $(libdir)/pkgconfig
  pkgconfig_DATA = libcurl.pc
-@@ -275,8 +275,8 @@ cygwinbin:
+@@ -267,8 +267,8 @@ cygwinbin:
  # We extend the standard install with a custom hook:
  install-data-hook:
        cd include && $(MAKE) install