ramips: add support for Sanlinking D240
authorKristian Evensen <kristian.evensen@gmail.com>
Sat, 4 Feb 2017 20:28:52 +0000 (21:28 +0100)
committerMathias Kresin <dev@kresin.me>
Sun, 5 Feb 2017 21:23:28 +0000 (22:23 +0100)
The Sanlinking Technologies D240
(http://www.sanlinking.com/en/29-dual-4g-wifi-router.html) is basically the same
device as the ZBT WE826, so adding support for it in LEDE is straight forward.
The differences is that the D240 has two mini-PCIe slots (instead of one), blue
LEDs and supports PoE.

Specification:
* CPU: MT7620A
* 1x 10/100Mbps POE (802.3af/802.3at) Ethernet, 4x 10/100Mbps.
* 16 MB Flash.
* 128 MB RAM.
* 1x USB 2.0 port.
* 2x mini-PCIe slots.
* 2x SIM slots.
* 1x 2.4Ghz WIFI.
* 1x button.

Wifi, USB, switch and both mini-PCIe slots are working. I have not been able to
test the SD card reader.

The device comes pre-installed with an older version of OpenWRT, including Luci.
In order to install LEDE, you need to follow the existing procedure for updating
OpenWRT/LEDE using Luci. I.e., you need to access the UI and update the firmware
using the sysupgrade-image. Remember to select that you do not want to keep
existing settings. The default router address is 192.168.10.1 and
username/password admin/root (at least on my devices).

If you brick the device, the procedure for recovery is the same as for the
WE826. Please see the wiki page for that device for instructions.

Signed-off-by: Kristian Evensen <kristian.evensen@gmail.com>
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/D240.dts [new file with mode: 0644]
target/linux/ramips/image/mt7620.mk

index 545d6a4a6dcf93b088283e3bde7bf31923bf8584..4e6eeb26ba474cf319e5a5ada98179c624c879df 100755 (executable)
@@ -109,6 +109,10 @@ d105)
        ucidef_set_led_default "power" "POWER" "$board:red:power" "1"
        set_usb_led "$board:green:usb"
        ;;
+d240)
+       set_wifi_led "$board:blue:wifi"
+       set_usb_led "$board:blue:usb"
+       ;;
 db-wrt01)
        ucidef_set_led_default "power" "power" "$board:orange:power" "1"
        ;;
index c001dfe85a4dd1ca64fec6cd67d87e3a510bed18..3ef04e6d254e70e3c298c63fc8f4b512a414ec20 100755 (executable)
@@ -73,6 +73,7 @@ ramips_setup_interfaces()
        3g-6200n|\
        ac1200pro|\
        ai-br100|\
+       d240|\
        db-wrt01|\
        dir-300-b7|\
        dir-320-b1|\
index 5fb221380e7dad0096f87e96242cdba814de2dc3..744ff3c2e60b9af4b5ebe55869a5a228e26ddb72 100644 (file)
@@ -108,6 +108,7 @@ get_status_led() {
        w502u)
                status_led="$board:blue:wps"
                ;;
+       d240|\
        dap-1350|\
        na930|\
        pbr-m1|\
index d9918cceb5e817979debff9002e2b5c1ab7cd098..307253190150cf1d8ee839560befd52577397a84 100755 (executable)
@@ -112,6 +112,9 @@ ramips_board_detect() {
        *"D105")
                name="d105"
                ;;
+       *"D240")
+               name="d240"
+               ;;
        *"DAP-1350")
                name="dap-1350"
                ;;
index d83e5c1dd28bc885f81ea912afa15a2314a85e3e..acdfdaf84e154145e15933e8cdc0fab0bc3317ff 100755 (executable)
@@ -35,6 +35,7 @@ platform_check_image() {
        cf-wr800n|\
        cs-qr10|\
        d105|\
+       d240|\
        dap-1350|\
        db-wrt01|\
        dcs-930|\
diff --git a/target/linux/ramips/dts/D240.dts b/target/linux/ramips/dts/D240.dts
new file mode 100644 (file)
index 0000000..3da96f2
--- /dev/null
@@ -0,0 +1,157 @@
+/*
+ *  BSD LICENSE
+ *
+ *  Copyright(c) 2017 Kristian Evensen <kristian.evensen@gmail.com>.
+ *  All rights reserved.
+ *
+ *  Redistribution and use in source and binary forms, with or without
+ *  modification, are permitted provided that the following conditions
+ *  are met:
+ *
+ *    * Redistributions of source code must retain the above copyright
+ *      notice, this list of conditions and the following disclaimer.
+ *    * Redistributions in binary form must reproduce the above copyright
+ *      notice, this list of conditions and the following disclaimer in
+ *      the documentation and/or other materials provided with the
+ *      distribution.
+ *    * Neither the name of Broadcom Corporation nor the names of its
+ *      contributors may be used to endorse or promote products derived
+ *      from this software without specific prior written permission.
+ *
+ *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+ *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+ *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+ *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+ *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+ *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+ *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+/dts-v1/;
+
+#include "mt7620a.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "d240", "ralink,mt7620a-soc";
+       model = "Sanlinking Technologies D240";
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               power {
+                       label = "d240:blue:power";
+                       gpios = <&gpio1 14 GPIO_ACTIVE_HIGH>;
+               };
+
+               usb {
+                       label = "d240:blue:usb";
+                       gpios = <&gpio1 15 GPIO_ACTIVE_HIGH>;
+               };
+
+               air {
+                       label = "d240:blue:wifi";
+                       gpios = <&gpio3 0 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 1 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+};
+
+&gpio1 {
+       status = "okay";
+};
+
+&gpio3 {
+       status = "okay";
+};
+
+&spi0 {
+       status = "okay";
+
+       en25q128@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+
+               partition@30000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+
+               factory: partition@40000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+
+               partition@50000 {
+                       label = "firmware";
+                       reg = <0x50000 0xfb0000>;
+               };
+       };
+};
+
+&sdhci {
+       status = "okay";
+};
+
+&ehci {
+       status = "okay";
+};
+
+&ohci {
+       status = "okay";
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0x4>;
+       ralink,port-map = "wllll";
+};
+
+&wmac {
+       ralink,mtd-eeprom = <&factory 0>;
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               default {
+                       ralink,group = "i2c", "uartf", "wled", "spi refclk", "pa";
+                       ralink,function = "gpio";
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
index 446bd9981e28bec21f62416fcca05b85d8ec8f2a..29006845ced676cde5572118ab964af6cbbb675e 100644 (file)
@@ -465,3 +465,11 @@ define Device/kng_rc
        zyimage -d 8997 -v "ZyXEL Keenetic Viva"
 endef
 TARGET_DEVICES += kng_rc
+
+define Device/d240
+  DTS := D240
+  IMAGE_SIZE := $(ralink_default_fw_size_16M)
+  DEVICE_TITLE := Sanlinking Technologies D240
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-mt76 kmod-sdhci-mt7620
+endef
+TARGET_DEVICES += d240