ramips: Introduce CONFIG_MIPS_APPENDED_RAW_DTB to F5D8235 V1 (rt288x)
authorTobias Wolf <github-NTEO@vplace.de>
Wed, 21 Dec 2016 12:56:16 +0000 (13:56 +0100)
committerJo-Philipp Wich <jo@mein.io>
Wed, 1 Feb 2017 23:13:49 +0000 (00:13 +0100)
This activates the CONFIG_MIPS_APPENDED_RAW_DTB kernel configuration and
configures the F5D8235 V1 target to use append-dtb for kernel creation
instead of OWRTDTB.

Signed-off-by: Tobias Wolf <github-NTEO@vplace.de>
[Jo-Philipp Wich: rewrap commit message]
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
target/linux/ramips/image/Makefile
target/linux/ramips/image/rt288x.mk
target/linux/ramips/rt288x/config-4.4

index f34eba79cd16b65c32d92a82b77db6830bee39d7..7196a4664f19046b7e32d53be35fec110b1069e4 100644 (file)
@@ -36,6 +36,7 @@ define Device/Default
   PROFILES = Default $$(DTS)
   KERNEL_DEPENDS = $$(wildcard ../dts/$$(DTS).dts)
   KERNEL := $(KERNEL_DTB) | uImage lzma
+  DEVICE_DTS_DIR := ../dts
   IMAGES := sysupgrade.bin
   IMAGE_SIZE := $(ralink_default_fw_size_8M)
   SUPPORTED_DEVICES = $(1)
index 53fc99abda624cd85b788fa9cc957c8e37c0784e..fbe50a282440a11939c6957653aaa812c186f7bf 100644 (file)
@@ -28,11 +28,13 @@ endef
 TARGET_DEVICES += ar725w
 
 define Device/f5d8235-v1
-  DTS := F5D8235_V1
   IMAGE_SIZE := 7744k
   DEVICE_TITLE := Belkin F5D8235 V1
   DEVICE_PACKAGES := kmod-switch-rtl8366s kmod-usb-core kmod-usb-ohci \
     kmod-usb-ohci-pci kmod-usb2 kmod-usb2-pci kmod-usb-ledtrig-usbport
+  DEVICE_DTS := F5D8235_V1
+  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
+  KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
 endef
 TARGET_DEVICES += f5d8235-v1
 
index 5f29322874d6a213d1b0ecdbd2e72ba11c918206..bff04da39a206de1faaf9c3adc242acece994646 100644 (file)
@@ -119,8 +119,8 @@ CONFIG_MIPS_CMDLINE_FROM_DTB=y
 CONFIG_MIPS_L1_CACHE_SHIFT=4
 CONFIG_MIPS_L1_CACHE_SHIFT_4=y
 # CONFIG_MIPS_MACHINE is not set
-CONFIG_MIPS_NO_APPENDED_DTB=y
-# CONFIG_MIPS_RAW_APPENDED_DTB is not set
+# CONFIG_MIPS_NO_APPENDED_DTB is not set
+CONFIG_MIPS_RAW_APPENDED_DTB=y
 CONFIG_MIPS_SPRAM=y
 CONFIG_MODULES_USE_ELF_REL=y
 # CONFIG_MTD_CFI_INTELEXT is not set