mac80211: use KERNEL_MAKEOPTS
authorFelix Fietkau <nbd@nbd.name>
Thu, 16 Mar 2017 09:13:14 +0000 (10:13 +0100)
committerFelix Fietkau <nbd@nbd.name>
Wed, 7 Jun 2017 16:31:10 +0000 (18:31 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/mac80211/Makefile
package/kernel/mac80211/patches/012-kernel_build_check.patch [new file with mode: 0644]

index 71aae893608eb48303ca556b110c377d3c345718..1ac390d337c23cfb33be5f19de3281a4d83263f3 100644 (file)
@@ -1659,8 +1659,7 @@ config-y += RTL8XXXU_UNTESTED
 config-$(CONFIG_LEDS_TRIGGERS) += MAC80211_LEDS B43_LEDS B43LEGACY_LEDS
 
 MAKE_OPTS:= -C "$(PKG_BUILD_DIR)" \
-       CROSS_COMPILE="$(KERNEL_CROSS)" \
-       ARCH="$(LINUX_KARCH)" \
+       $(KERNEL_MAKE_FLAGS) \
        EXTRA_CFLAGS="-I$(PKG_BUILD_DIR)/include $(IREMAP_CFLAGS)" \
        KLIB_BUILD="$(LINUX_DIR)" \
        MODPROBE=true \
@@ -1668,10 +1667,6 @@ MAKE_OPTS:= -C "$(PKG_BUILD_DIR)" \
        KERNEL_SUBLEVEL=$(lastword $(subst ., ,$(KERNEL_PATCHVER))) \
        KBUILD_LDFLAGS_MODULE_PREREQ=
 
-ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
-  MAKE_OPTS += V=1
-endif
-
 define ConfigVars
 $(subst $(space),,$(foreach opt,$(config-$(1)),CPTCFG_$(opt)=$(1)
 ))
diff --git a/package/kernel/mac80211/patches/012-kernel_build_check.patch b/package/kernel/mac80211/patches/012-kernel_build_check.patch
new file mode 100644 (file)
index 0000000..d225ba1
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,7 +2,7 @@
+ # Makefile for the output source package
+ #
+-ifeq ($(KERNELRELEASE),)
++ifeq ($(KERNELVERSION),)
+ MAKEFLAGS += --no-print-directory
+ SHELL := /usr/bin/env bash