build: replace uses of OpenWrt with $(VERSION_DIST)
authorFelix Fietkau <nbd@nbd.name>
Wed, 8 Nov 2017 17:40:37 +0000 (18:40 +0100)
committerFelix Fietkau <nbd@nbd.name>
Mon, 5 Feb 2018 09:15:53 +0000 (10:15 +0100)
This makes the distribution name more configurable.

Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/image-commands.mk
include/image.mk
target/linux/apm821xx/image/Makefile
target/linux/ar71xx/image/generic.mk
target/linux/ar71xx/image/legacy.mk
target/linux/ath25/image/Makefile
target/linux/brcm63xx/image/bcm63xx.mk
target/linux/cns3xxx/image/Makefile
target/linux/lantiq/image/Makefile
target/linux/mcs814x/image/Makefile
target/linux/ramips/image/Makefile

index bcc1256df838ac3c27015dc24c7cdd031bd19514..adef8f2759536495519e3f13ff4e2abfa33aa6cb 100644 (file)
@@ -7,7 +7,7 @@ define Build/uImage
        mkimage -A $(LINUX_KARCH) \
                -O linux -T kernel \
                -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
-               -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION))' -d $@ $@.new
+               -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' -d $@ $@.new
        mv $@.new $@
 endef
 
@@ -60,7 +60,7 @@ endef
 
 define Build/netgear-dni
        $(STAGING_DIR_HOST)/bin/mkdniimg \
-               -B $(NETGEAR_BOARD_ID) -v OpenWrt.$(REVISION) \
+               -B $(NETGEAR_BOARD_ID) -v $(VERSION_DIST).$(REVISION) \
                $(if $(NETGEAR_HW_ID),-H $(NETGEAR_HW_ID)) \
                -r "$(1)" \
                -i $@ -o $@.new
@@ -83,7 +83,7 @@ define Build/append-uImage-fakeroot-hdr
        rm -f $@.fakeroot
        $(STAGING_DIR_HOST)/bin/mkimage \
                -A $(LINUX_KARCH) -O linux -T filesystem -C none \
-               -n '$(call toupper,$(LINUX_KARCH)) OpenWrt fakeroot' \
+               -n '$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) fakeroot' \
                -s \
                $@.fakeroot
        cat $@.fakeroot >> $@
index af01951b494a0da362af8d246946987c213f86c6..723e4f1897cb1280aa70dd0cdb5144c2080f4b9a 100644 (file)
@@ -136,7 +136,7 @@ endef
 
 define Image/BuildKernel/MkuImage
        mkimage -A $(ARCH) -O linux -T kernel -C $(1) -a $(2) -e $(3) \
-               -n '$(call toupper,$(ARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $(4) $(5)
+               -n '$(call toupper,$(ARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION)' -d $(4) $(5)
 endef
 
 define Image/BuildKernel/MkFIT
index c012906eafff35d94d6a28719448f014ee7cff2a..82a857a4d0672377655acab918dbfb1d1d536881 100644 (file)
@@ -118,7 +118,7 @@ define Build/create-uImage-dtb
        # flat_dt target expect FIT image - which WNDR4700's uboot doesn't support
        -$(STAGING_DIR_HOST)/bin/mkimage -A $(LINUX_KARCH) \
                -O linux -T kernel -C none \
-               -n '$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION)' \
+               -n '$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION)' \
                -d $(IMAGE_KERNEL).dtb $@.new
        @mv $@.new $@
 endef
index b2e701c844a201307f9d803fb8abf35d5dcb267f..95265d1c0a7156ab6a9517615af481aeef08fbbf 100644 (file)
@@ -28,7 +28,7 @@ define Build/mkwrggimg
        $(STAGING_DIR_HOST)/bin/mkwrggimg -b \
                -i $@ -o $@.imghdr -d /dev/mtdblock/1 \
                -m $(BOARDNAME) -s $(DAP_SIGNATURE) \
-               -v OpenWrt -B $(REVISION)
+               -v $(VERSION_DIST) -B $(REVISION)
        mv $@.imghdr $@
 endef
 
@@ -46,7 +46,7 @@ define Build/netgear-squashfs
                -A mips -O linux -T filesystem -C none \
                -M $(NETGEAR_KERNEL_MAGIC) \
                -a 0xbf070000 -e 0xbf070000 \
-               -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+               -n 'MIPS $(VERSION_DIST) Linux-$(LINUX_VERSION)' \
                -d $@.squashfs $@
        rm -rf $@.squashfs $@.fs
 endef
@@ -93,7 +93,7 @@ define Build/uImageHiWiFi
        mkimage -A $(LINUX_KARCH) \
                -O linux -T kernel \
                -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
-               -n 'tw150v1 $(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $@ $@.new
+               -n 'tw150v1 $(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION)' -d $@ $@.new
        @mv $@.new $@
 endef
 
index bd8ca2cefee7e5fef076c8232eff768aeae54a94..cbc859dd08d50eed2049b341ddd5332d21dcbf02 100644 (file)
@@ -87,7 +87,7 @@ ifneq ($(SUBTARGET),mikrotik)
 # $(4): output file.
 define MkuImage
        mkimage -A mips -O linux -T kernel -a 0x80060000 -C $(1) $(2) \
-               -e 0x80060000 -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+               -e 0x80060000 -n 'MIPS $(VERSION_DIST) Linux-$(LINUX_VERSION)' \
                -d $(3) $(4)
 endef
 
@@ -484,11 +484,11 @@ define Image/Build/Belkin
        $(eval rootsize=$(call mtdpartsize,rootfs,$(4)))
        $(call Sysupgrade/RKuImage,$(1),$(2),$(kernsize),$(rootsize))
        if [ -e "$(call sysupname,$(1),$(2))" ]; then \
-               edimax_fw_header -m $(5) -v "$(shell echo -n OpenWrt$(REVISION) | cut -c -13)" \
+               edimax_fw_header -m $(5) -v "$(shell echo -n $(VERSION_DIST)$(REVISION) | cut -c -13)" \
                        -n "uImage" \
                        -i $(KDIR_TMP)/vmlinux-$(2).uImage \
                        -o $(KDIR_TMP)/$(2)-uImage; \
-               edimax_fw_header -m $(5) -v "$(shell echo -n OpenWrt$(REVISION) | cut -c -13)" \
+               edimax_fw_header -m $(5) -v "$(shell echo -n $(VERSION_DIST)$(REVISION) | cut -c -13)" \
                        -n "rootfs" \
                        -i $(KDIR)/root.$(1) \
                        -o $(KDIR_TMP)/$(2)-rootfs; \
@@ -661,7 +661,7 @@ define Image/Build/Netgear/buildkernel
        ) > $(KDIR_TMP)/vmlinux-$(2).uImage.squashfs.tmp2
        mkimage -A mips -O linux -T filesystem -C none -M $(5) \
                -a 0xbf070000 -e 0xbf070000 \
-               -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+               -n 'MIPS $(VERSION_DIST) Linux-$(LINUX_VERSION)' \
                -d $(KDIR_TMP)/vmlinux-$(2).uImage.squashfs.tmp2 \
                $(KDIR_TMP)/vmlinux-$(2).uImage.squashfs
 endef
@@ -673,7 +673,7 @@ define Image/Build/Netgear
                for r in $(7) ; do \
                        [ -n "$$r" ] && dashr="-$$r" || dashr= ; \
                        $(STAGING_DIR_HOST)/bin/mkdniimg \
-                               -B $(6) -v OpenWrt.$(REVISION) -r "$$r" $(8) \
+                               -B $(6) -v $(VERSION_DIST).$(REVISION) -r "$$r" $(8) \
                                -i $(call sysupname,$(1),$(2)) \
                                -o $(call imgname,$(1),$(2))-factory$$dashr.img; \
                done; \
@@ -714,7 +714,7 @@ define Image/Build/NetgearNAND/buildkernel
        dd if=/dev/zero of=$(KDIR_TMP)/fakeroot-$(2) bs=131072 count=1
        mkimage -A mips -O linux -T filesystem -C none \
                -a 0xbf070000 -e 0xbf070000 \
-               -n 'MIPS OpenWrt fakeroot' \
+               -n 'MIPS $(VERSION_DIST) fakeroot' \
                -d $(KDIR_TMP)/fakeroot-$(2) \
                -M $(5) \
                $(KDIR_TMP)/fakeroot-$(2).uImage
@@ -745,7 +745,7 @@ define Image/Build/NetgearNAND
                dd if=$(KDIR_TMP)/$(2)-root.ubi \
        ) > $(imageraw)
        $(STAGING_DIR_HOST)/bin/mkdniimg \
-               -B $(6) -v OpenWrt.$(REVISION) -r "$$r" $(8) \
+               -B $(6) -v $(VERSION_DIST).$(REVISION) -r "$$r" $(8) \
                -i $(imageraw) \
                -o $(call imgname,ubi,$(2))-factory.img
 
index 5144ed8a0a9c5b3f53dff50b6e38b8cea34c0f5e..5a20bdb64454459cdc90119b979428a5e6427d15 100644 (file)
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/image.mk
 
 define Build/mkfwimage
        $(STAGING_DIR_HOST)/bin/mkfwimage \
-               -B $(1).OpenWrt.$(REVISION) \
+               -B $(1).$(VERSION_DIST).$(REVISION) \
                -k $(IMAGE_KERNEL) \
                -r $(IMAGE_ROOTFS) \
                -o $@.new && \
index 918dfc798169d969cfd39db3bb8b9dbadab83265..b9ecd5406433cebdb4d0305147aa0578c762fbd1 100644 (file)
@@ -990,7 +990,7 @@ define Device/NEUFBOX4-SER
   DEVICE_DTS := nb4-ser-r0
   CFE_BOARD_ID := 96358VW
   CFE_CHIP_ID := 6358
-  CFE_EXTRAS += --rsa-signature "OpenWrt-$(firstword $(subst -,$(space),$(REVISION)))"
+  CFE_EXTRAS += --rsa-signature "$(VERSION_DIST)-$(firstword $(subst -,$(space),$(REVISION)))"
   DEVICE_PACKAGES := \
     $(B43_PACKAGES) $(USB2_PACKAGES)
 endef
@@ -1002,7 +1002,7 @@ define Device/NEUFBOX4-FXC
   DEVICE_DTS := nb4-fxc-r1
   CFE_BOARD_ID := 96358VW
   CFE_CHIP_ID := 6358
-  CFE_EXTRAS += --rsa-signature "OpenWrt-$(firstword $(subst -,$(space),$(REVISION)))"
+  CFE_EXTRAS += --rsa-signature "$(VERSION_DIST)-$(firstword $(subst -,$(space),$(REVISION)))"
   DEVICE_PACKAGES := \
     $(B43_PACKAGES) $(USB2_PACKAGES)
 endef
@@ -1014,7 +1014,7 @@ define Device/NEUFBOX6
   DEVICE_DTS := nb6-ser-r0
   CFE_BOARD_ID := NB6-SER-r0
   CFE_CHIP_ID := 6362
-  CFE_EXTRAS += --rsa-signature "OpenWrt-$(firstword $(subst -,$(space),$(REVISION)))"
+  CFE_EXTRAS += --rsa-signature "$(VERSION_DIST)-$(firstword $(subst -,$(space),$(REVISION)))"
   DEVICE_PACKAGES := \
     $(B43_PACKAGES) $(USB2_PACKAGES)
 endef
index 99bb7f1a22b411597589401ab676b098500571ad..d095ce11f46516ef5f479ac58570e584cb2ba133 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define Image/Prepare
-       mkimage -A arm -O linux -T kernel -C none -a 0x20008000 -e 0x20008000 -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage $(KDIR)/uImage
+       mkimage -A arm -O linux -T kernel -C none -a 0x20008000 -e 0x20008000 -n '$(VERSION_DIST) Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage $(KDIR)/uImage
 endef
 
 LEGACY_NOR_KERNEL_SIZE = 2048k
@@ -27,7 +27,7 @@ define BuildFirmware/Legacy
 endef
 
 define Image/BuildKernel/Initramfs
-       mkimage -A arm -O linux -T kernel -C none -a 0x20008000 -e 0x20008000 -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage-initramfs $(BIN_DIR)/$(IMG_PREFIX)-initramfs-uImage
+       mkimage -A arm -O linux -T kernel -C none -a 0x20008000 -e 0x20008000 -n '$(VERSION_DIST) Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage-initramfs $(BIN_DIR)/$(IMG_PREFIX)-initramfs-uImage
 endef
 
 define Image/Build
index dcd0c710d10e41be58fdf17152c92f2fbf645b26..2e8eccf5ac6d0da49b2d96ea3505b552ae2f69a7 100644 (file)
@@ -39,7 +39,7 @@ endef
 
 define Build/fullimage
        mkimage -A mips -O linux -C lzma -T filesystem -a 0x00  \
-               -e 0x00 -n 'OpenWrt RootFS' \
+               -e 0x00 -n '$(VERSION_DIST) RootFS' \
                -d $(IMAGE_ROOTFS) $(IMAGE_ROOTFS).new
 
        cat $(IMAGE_KERNEL) $(IMAGE_ROOTFS).new > $@.tmp
index 3afd660c14ffb875c124730cd8f5ceb21b3e2093..ff905b30857ae906815ed4870db5e70d270bb920 100644 (file)
@@ -20,7 +20,7 @@ UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage
 
 define Image/Build/MkuImage
        mkimage -A arm -O linux -T kernel -a $(LOADADDR) -C none -e $(LOADADDR) \
-       -n 'ARM OpenWrt Linux-$(LINUX_VERSION)' -d $(1) $(2);
+       -n 'ARM $(VERSION_DIST) Linux-$(LINUX_VERSION)' -d $(1) $(2);
 endef
 
 define Image/Build/DTB
index ea7ce0bc90278f33904511a1bdb1a7430a17402f..abcff036299bde0d70fcd95609be39efcb5e8a59 100644 (file)
@@ -118,7 +118,7 @@ endef
 # $(2), filename of image data
 # $(3), output filename
 define MkImage
-       $(eval imagename=$(if $(4),$(4),MIPS OpenWrt Linux-$(LINUX_VERSION)))
+       $(eval imagename=$(if $(4),$(4),MIPS $(VERSION_DIST) Linux-$(LINUX_VERSION)))
        -mkimage -A mips -O linux -T kernel -C $(1) -a $(loadaddr-y) -e $(loadaddr-y) \
                -n "$(imagename)" \
                -d $(2) $(3)