ar71xx: add support for Ubiquiti Litebeam M5
authorArne Zachlod <arne@nerdkeller.org>
Fri, 2 Mar 2018 00:16:34 +0000 (01:16 +0100)
committerAlexander Couzens <lynxis@fe80.eu>
Thu, 15 Mar 2018 18:11:39 +0000 (19:11 +0100)
Specification:
- SoC: Atheros AR9342
- Flash: 8 MiB
- RAM: 64 MiB
- UART: 1x UART on PCB - 115200 8N1
- Ethernet: 1 x 100 Mbit with passive PoE (24V/0.2A)

Doesn't work:
* Flash via TFTP with Ubiquiti Uboot

Installation via vendor firmware:
- upload factory image via webinterface

Signed-off-by: Arne Zachlod <arne@nerdkeller.org>
target/linux/ar71xx/base-files/etc/board.d/01_leds
target/linux/ar71xx/base-files/etc/board.d/02_network
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/files/arch/mips/ath79/mach-ubnt-xm.c
target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
target/linux/ar71xx/image/generic-ubnt.mk

index 00954dfaa479df34b444102b554f0e182308bc3f..7a8ed9afe53e84f5bdae477bbd7ec4ef603404a5 100755 (executable)
@@ -408,6 +408,10 @@ hornet-ub-x2)
 lan-turtle)
        ucidef_set_led_netdev "wan" "WAN" "$board:orange:system" "eth1"
        ;;
+lbe-m5)
+       ucidef_set_led_netdev "lan" "LAN" "ubnt:green:lan" "eth0"
+       ucidef_set_led_wlan "wlan" "WLAN" "ubnt:green:wlan" "phy0tpt"
+       ;;
 mc-mac1200r)
        ucidef_set_led_wlan "wlan2g" "WLAN2G" "mercury:green:wlan2g" "phy1tpt"
        ucidef_set_led_wlan "wlan5g" "WLAN5G" "mercury:green:wlan5g" "phy0tpt"
index 8f492cbf02d8d064646df5179f0d0b14867e5757..560112756af4fe4df8997102bee8ffbd17e7ba5c 100755 (executable)
@@ -82,6 +82,7 @@ ar71xx_setup_interfaces()
        fritz300e|\
        gl-usb150|\
        hiveap-121|\
+       lbe-m5|\
        loco-m-xw|\
        mr12|\
        mr16|\
index 6b53ad03c7a682605eab502eef41b302044ab818..6ea4fb085c920d79fce9d934d3ebed0768a22f1f 100644 (file)
@@ -260,6 +260,9 @@ get_status_led() {
        lan-turtle)
                status_led="$board:orange:system"
                ;;
+       lbe-m5)
+               status_led="ubnt:green:sys"
+               ;;
        ls-sr71)
                status_led="ubnt:green:d22"
                ;;
index 01ac29601d0485bbc3e6ac281778c06ee3dfb0ab..a7c2ccb52ebc7fcd9f43ea56980a3684f8f9f715 100755 (executable)
@@ -741,6 +741,9 @@ ar71xx_board_detect() {
        *"Lima"*)
                name="lima"
                ;;
+       *"Litebeam M5"*)
+               name="lbe-m5"
+               ;;
        *"Loco M XW")
                name="loco-m-xw"
                ;;
index 7738db33a7f5ccb5c53e606651a9f79eb741a6c4..2b15dec5bece06db0293e8dfa5b3201b6f6f0084 100755 (executable)
@@ -256,6 +256,7 @@ platform_check_image() {
        hiwifi-hc6361|\
        hornet-ub-x2|\
        jwap230|\
+       lbe-m5|\
        lima|\
        loco-m-xw|\
        mzk-w04nu|\
index 55cf52d19e5cf5ae535a7922d1163736e98827f0..8afb3ad054b898b272e354c80964ea52bdc02967 100644 (file)
@@ -12,6 +12,7 @@
 
 #include <linux/init.h>
 #include <linux/pci.h>
+#include <linux/gpio.h>
 #include <linux/platform_device.h>
 #include <linux/ath9k_platform.h>
 #include <linux/etherdevice.h>
@@ -503,6 +504,60 @@ static void __init ubnt_loco_m_xw_setup(void)
        ath79_register_eth(0);
 }
 
+#define UBNT_LBE_M5_GPIO_LED_LAN               13
+#define UBNT_LBE_M5_GPIO_LED_WLAN              14
+#define UBNT_LBE_M5_GPIO_LED_SYS               16
+
+static struct gpio_led ubnt_lbe_m5_leds_gpio[] __initdata = {
+       {
+               .name           = "ubnt:green:lan",
+               .gpio           = UBNT_LBE_M5_GPIO_LED_LAN,
+               .active_low     = 1,
+       }, {
+               .name           = "ubnt:green:wlan",
+               .gpio           = UBNT_LBE_M5_GPIO_LED_WLAN,
+               .active_low     = 1,
+       }, {
+               .name           = "ubnt:green:sys",
+               .gpio           = UBNT_LBE_M5_GPIO_LED_SYS,
+               .active_low     = 1,
+       },
+};
+
+static void __init ubnt_lbe_m5_setup(void)
+{
+       u8 *eeprom = (u8 *) KSEG1ADDR(0x1fff0000);
+
+       ath79_register_m25p80(NULL);
+
+       ath79_register_wmac(eeprom + UAP_PRO_WMAC_CALDATA_OFFSET, NULL);
+       ap91_pci_init(eeprom + UAP_PRO_PCI_CALDATA_OFFSET, NULL);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(ubnt_lbe_m5_leds_gpio),
+                                ubnt_lbe_m5_leds_gpio);
+       ath79_register_gpio_keys_polled(-1, UBNT_XM_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(ubnt_xm_gpio_keys),
+                                       ubnt_xm_gpio_keys);
+
+       ath79_setup_ar934x_eth_cfg(AR934X_ETH_CFG_MII_GMAC0 |
+                                  AR934X_ETH_CFG_MII_GMAC0_SLAVE);
+       ath79_init_mac(ath79_eth0_data.mac_addr,
+                      eeprom + UAP_PRO_MAC0_OFFSET, 0);
+
+       ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+       ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
+
+       gpio_request_one(0, GPIOF_OUT_INIT_LOW | GPIOF_ACTIVE_LOW |
+                        GPIOF_EXPORT_DIR_FIXED, "SPI nWP");
+
+       mdiobus_register_board_info(ubnt_loco_m_xw_mdio_info,
+                                   ARRAY_SIZE(ubnt_loco_m_xw_mdio_info));
+
+       ath79_register_mdio(0, ~BIT(1));
+       ath79_eth0_data.phy_mask = BIT(1);
+       ath79_register_eth(0);
+}
+
 static void __init ubnt_rocket_m_xw_setup(void)
 {
        u8 *eeprom = (u8 *) KSEG1ADDR(0x1fff0000);
@@ -590,6 +645,9 @@ static void __init ubnt_rocket_m_ti_setup(void)
 MIPS_MACHINE(ATH79_MACH_UBNT_NANO_M_XW, "UBNT-NM-XW", "Ubiquiti Nanostation M XW",
             ubnt_nano_m_xw_setup);
 
+MIPS_MACHINE(ATH79_MACH_UBNT_LBE_M5, "UBNT-LBE-M5", "Ubiquiti Litebeam M5",
+               ubnt_lbe_m5_setup);
+
 MIPS_MACHINE(ATH79_MACH_UBNT_LOCO_M_XW, "UBNT-LOCO-XW", "Ubiquiti Loco M XW",
             ubnt_loco_m_xw_setup);
 
index 46bc49458b976720a0731b56be6420f49fabd93f..de7298f41cdfbd2c189d644d6fad23051e7a6ea3 100644 (file)
@@ -303,6 +303,7 @@ enum ath79_mach_type {
        ATH79_MACH_UBNT_AIRGWP,                 /* Ubiquiti AirGateway Pro */
        ATH79_MACH_UBNT_AIRROUTER,              /* Ubiquiti AirRouter */
        ATH79_MACH_UBNT_BULLET_M,               /* Ubiquiti Bullet M */
+       ATH79_MACH_UBNT_LBE_M5,                 /* Ubiquiti Litebeam M5 */
        ATH79_MACH_UBNT_LOCO_M_XW,              /* Ubiquiti Loco M XW */
        ATH79_MACH_UBNT_LSSR71,                 /* Ubiquiti LS-SR71 */
        ATH79_MACH_UBNT_LSX,                    /* Ubiquiti LSX */
index 66d7c524964e37b8fcab836fcc3170a31bf8a07b..478ac3ea8b10cb71e887596853b18b033e78af02 100644 (file)
@@ -157,6 +157,13 @@ define Device/ubnt-nano-m-xw
 endef
 TARGET_DEVICES += ubnt-nano-m-xw
 
+define Device/ubnt-lbe-m5
+  $(Device/ubnt-xw)
+  DEVICE_TITLE := Ubiquiti Litebeam M5
+  BOARDNAME := UBNT-LBE-M5
+endef
+TARGET_DEVICES += ubnt-lbe-m5
+
 define Device/ubnt-loco-m-xw
   $(Device/ubnt-xw)
   DEVICE_TITLE := Ubiquiti Loco XW