ar71xx: Add support for D-Link DAP-1330 a1
authorNicolò Veronese <nicveronese@gmail.com>
Fri, 16 Jun 2017 12:12:25 +0000 (12:12 +0000)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Thu, 5 Apr 2018 13:28:56 +0000 (15:28 +0200)
D-Link DAP-1330 rev. A1 is a wall-plug N300 Wi-Fi range extender,
based on Qualcomm/Atheros QCA9533 v2.

Short specification:

- 650/393/216 MHz (CPU/DDR/AHB)
- 1x 10/100 Mbps Ethernet
- 64 MB of RAM (DDR1)
- 8 MB of FLASH
- 2T2R 2.4 GHz
- 2x external antennas
- 6x LED (2 are bi-color), 2x button
- 4 pin on pcb (looking from eth port and from left to right tx,rx,gnd,vcc)

Flash instruction: use "factory" image directly in vendor GUI.

This device has a recovery system that assign the ip addr of env
variable "serverip" via dhcp to a pc, and the "ipaddr" value to itself.
The recovery it's triggered by a not bootable firmware,
or pressing the reset button during the bootloader startup (first 30 seconds).
The recovery uses a http page to restore the firmware, and it's checking
the firmware image header, so use the "factory" image to
restore or the original firmware.

You can access vendor firmware over serial using:
- login: root
- password: linuxrocks

Image was tested only in EU version of the device, but should work
also with the same device version sold in other countries.

Signed-off-by: Nicolò Veronese <nicveronese@gmail.com>
12 files changed:
target/linux/ar71xx/base-files/etc/board.d/01_leds
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-4.4
target/linux/ar71xx/config-4.9
target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
target/linux/ar71xx/files/arch/mips/ath79/Makefile
target/linux/ar71xx/files/arch/mips/ath79/mach-dap-1330-a1.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
target/linux/ar71xx/generic/config-default
target/linux/ar71xx/image/generic.mk

index 7a8ed9afe53e84f5bdae477bbd7ec4ef603404a5..2a0af3c4090a526674af9c8274a2f5723590c017 100755 (executable)
@@ -298,6 +298,13 @@ fritz300e)
        ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "$board:green:rssi3" "wlan0" "60" "100"
        ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "$board:green:rssi4" "wlan0" "80" "100"
        ;;
+dap-1330-a1)
+       ucidef_set_rssimon "wlan0" "2000000" "2"
+       ucidef_set_led_rssi "wifi-low" "wifi-low" "d-link:red:wifi" "wlan0" "1" "29"
+       ucidef_set_led_rssi "wifi-medium" "wifi-medium" "d-link:green:wifi" "wlan0" "30" "100"
+       ucidef_set_led_rssi "wifi-high" "wifi-high" "d-link:green:signal1" "wlan0" "50" "100"
+       ucidef_set_led_rssi "wifi-max" "wifi-max" "d-link:green:signal2" "wlan0" "70" "100"
+       ;;
 dap-2695-a1)
        ucidef_set_led_default "power" "POWER" "d-link:green:power" "1"
        ucidef_set_led_default "diag" "DIAG" "d-link:red:power" "0"
index 6ea4fb085c920d79fce9d934d3ebed0768a22f1f..b5d07cddfc1a0c1b530f7648433640ff28ed296e 100644 (file)
@@ -162,6 +162,7 @@ get_status_led() {
        cr5000)
                status_led="pcs:amber:power"
                ;;
+       dap-1330-a1|\
        dgl-5500-a1|\
        dhp-1565-a1|\
        dir-505-a1|\
index a7c2ccb52ebc7fcd9f43ea56980a3684f8f9f715..3586cc99abf2fe3986abb10f958b57dbc01d7b3d 100755 (executable)
@@ -557,6 +557,9 @@ ar71xx_board_detect() {
        *"CR5000")
                name="cr5000"
                ;;
+       *"DAP-1330 Rev. A1")
+               name="dap-1330-a1"
+               ;;
        *"DAP-2695 rev. A1")
                name="dap-2695-a1"
                ;;
index 2b15dec5bece06db0293e8dfa5b3201b6f6f0084..4b71a19a9c96543b4cbca155f257700e48b62ca9 100755 (executable)
@@ -219,6 +219,7 @@ platform_check_image() {
        cpe505n|\
        cpe830|\
        cpe870|\
+       dap-1330-a1|\
        dgl-5500-a1|\
        dhp-1565-a1|\
        dir-505-a1|\
index c55bdab0e8209401d309a1719bba3773833bf9da..e6882c2a676a8fe0c4fa421ff2d6b294e563dea1 100644 (file)
@@ -80,6 +80,7 @@ CONFIG_ATH79=y
 # CONFIG_ATH79_MACH_CPE870 is not set
 # CONFIG_ATH79_MACH_CR3000 is not set
 # CONFIG_ATH79_MACH_CR5000 is not set
+# CONFIG_ATH79_MACH_DAP_1330_A1 is not set
 # CONFIG_ATH79_MACH_DAP_2695_A1 is not set
 # CONFIG_ATH79_MACH_DB120 is not set
 # CONFIG_ATH79_MACH_DGL_5500_A1 is not set
index 026d5bb61735041e72ada526eab009e077576cec..e78b16cd19360a25180958a9f4a99ba2eb60cfe8 100644 (file)
@@ -78,6 +78,7 @@ CONFIG_ATH79=y
 # CONFIG_ATH79_MACH_CPE870 is not set
 # CONFIG_ATH79_MACH_CR3000 is not set
 # CONFIG_ATH79_MACH_CR5000 is not set
+# CONFIG_ATH79_MACH_DAP_1330_A1 is not set
 # CONFIG_ATH79_MACH_DAP_2695_A1 is not set
 # CONFIG_ATH79_MACH_DB120 is not set
 # CONFIG_ATH79_MACH_DGL_5500_A1 is not set
index ec3c329d7a14c999a6e6242b450ebda00dc24e3d..20c5385179f368dc472d6e9bdd54a734e4303ee8 100644 (file)
@@ -2300,6 +2300,15 @@ config ATH79_MACH_QIHOO_C301
        select ATH79_DEV_USB
        select ATH79_NVRAM
 
+config ATH79_MACH_DAP_1330_A1
+       bool "D-Link DAP-1330 rev. A1 support"
+       select SOC_QCA953X
+       select ATH79_DEV_ETH
+       select ATH79_DEV_GPIO_BUTTONS
+       select ATH79_DEV_LEDS_GPIO
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_WMAC
+
 config ATH79_MACH_DAP_2695_A1
        bool "D-Link DAP-2695 rev. A1 support"
        select SOC_QCA955X
index 62d731720602d14b7fb24432bd05dce87269ec3f..d549dd39b7cfdf981ea0af8d8f36274e57d7dd99 100644 (file)
@@ -89,6 +89,7 @@ obj-$(CONFIG_ATH79_MACH_CPE830)                       += mach-ap90q.o
 obj-$(CONFIG_ATH79_MACH_CPE870)                        += mach-cpe870.o
 obj-$(CONFIG_ATH79_MACH_CR3000)                        += mach-cr3000.o
 obj-$(CONFIG_ATH79_MACH_CR5000)                        += mach-cr5000.o
+obj-$(CONFIG_ATH79_MACH_DAP_1330_A1)           += mach-dap-1330-a1.o
 obj-$(CONFIG_ATH79_MACH_DAP_2695_A1)           += mach-dap-2695-a1.o
 obj-$(CONFIG_ATH79_MACH_DB120)                 += mach-db120.o
 obj-$(CONFIG_ATH79_MACH_DGL_5500_A1)           += mach-dgl-5500-a1.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-dap-1330-a1.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-dap-1330-a1.c
new file mode 100644 (file)
index 0000000..9c50bc7
--- /dev/null
@@ -0,0 +1,146 @@
+/*
+ * D-Link DAP-1330
+ *
+ * Copyright (c) 2013-2015 The Linux Foundation. All rights reserved.
+ * Copyright (c) 2017 Nicolò Veronese <nicveronese@gmail.com>
+ * Copyright (c) 2017 Federico Cappon <dududede371@gmail.com>
+ *
+ * Permission to use, copy, modify, and/or distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above
+ * copyright notice and this permission notice appear in all copies.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ *
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+#include "nvram.h"
+
+#include <linux/kernel.h>
+#include <linux/vmalloc.h>
+#include <linux/errno.h>
+#include <linux/init.h>
+#include <linux/string.h>
+
+#define DAP_1330_GPIO_LED_GREEN_POWER  13
+#define DAP_1330_GPIO_LED_RED_POWER    3
+#define DAP_1330_GPIO_LED_GREEN_WIFI   14
+#define DAP_1330_GPIO_LED_RED_WIFI     11
+#define DAP_1330_GPIO_LED_SIGNAL1      15
+#define DAP_1330_GPIO_LED_SIGNAL2      16
+
+#define DAP_1330_GPIO_BTN_WPS          2
+#define DAP_1330_GPIO_BTN_RESET                17
+
+#define DAP_1330_KEYS_POLL_INTERVAL    20      /* msecs */
+#define DAP_1330_KEYS_DEBOUNCE_INTERVAL        (3 * DAP_1330_KEYS_POLL_INTERVAL)
+
+#define DAP1330_MAC_ADDR               0x1f020001
+
+#define DAP1330_WMAC_CALDATA_ADDR      0x1f010000
+#define DAP_1330_WMAC_CALDATA_OFFSET   0x1000
+
+static struct gpio_led dap_1330_leds_gpio[] __initdata = {
+               {
+                               .name           = "d-link:green:power",
+                               .gpio           = DAP_1330_GPIO_LED_GREEN_POWER,
+                               .active_low     = 1,
+               },
+               {
+                               .name           = "d-link:red:power",
+                               .gpio           = DAP_1330_GPIO_LED_RED_POWER,
+                               .active_low     = 1,
+               },
+               {
+                               .name           = "d-link:green:wifi",
+                               .gpio           = DAP_1330_GPIO_LED_GREEN_WIFI,
+                               .active_low     = 1,
+               },
+               {
+                               .name           = "d-link:red:wifi",
+                               .gpio           = DAP_1330_GPIO_LED_RED_WIFI,
+                               .active_low     = 1,
+               },
+               {
+                               .name           = "d-link:green:signal1",
+                               .gpio           = DAP_1330_GPIO_LED_SIGNAL1,
+                               .active_low     = 1,
+               },
+               {
+                               .name           = "d-link:green:signal2",
+                               .gpio           = DAP_1330_GPIO_LED_SIGNAL2,
+                               .active_low     = 1,
+               }
+};
+
+static struct gpio_keys_button dap_1330_gpio_keys[] __initdata = {
+       {
+               .desc           = "WPS button",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .debounce_interval = DAP_1330_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = DAP_1330_GPIO_BTN_WPS,
+               .active_low     = 1,
+       },
+       {
+               .desc           = "Reset button",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = DAP_1330_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = DAP_1330_GPIO_BTN_RESET,
+               .active_low     = 1,
+       }
+};
+
+static void __init dap_1330_setup(void)
+{
+       u8 *art = (u8 *) KSEG1ADDR(DAP1330_WMAC_CALDATA_ADDR);
+       u8 *mac_ptr = (u8 *) KSEG1ADDR(DAP1330_MAC_ADDR);
+       u8 mac[ETH_ALEN];
+
+       ath79_parse_ascii_mac((char *) mac_ptr, mac);
+
+       ath79_register_m25p80(NULL);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(dap_1330_leds_gpio),
+               dap_1330_leds_gpio);
+
+       ath79_register_gpio_keys_polled(-1, DAP_1330_KEYS_POLL_INTERVAL,
+                       ARRAY_SIZE(dap_1330_gpio_keys),
+                       dap_1330_gpio_keys);
+
+       ath79_register_wmac(art + DAP_1330_WMAC_CALDATA_OFFSET, mac);
+
+       ath79_register_mdio(0, 0x0);
+
+       ath79_init_mac(ath79_eth1_data.mac_addr, mac, 0);
+
+       /* LAN ports */
+       ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+       ath79_eth1_data.speed = SPEED_1000;
+       ath79_eth1_data.duplex = DUPLEX_FULL;
+       ath79_switch_data.phy_poll_mask |= BIT(4);
+       ath79_switch_data.phy4_mii_en = 1;
+       ath79_register_eth(1);
+}
+
+MIPS_MACHINE(ATH79_MACH_DAP_1330_A1, "DAP-1330-A1",
+             "D-Link DAP-1330 Rev. A1", dap_1330_setup);
index de7298f41cdfbd2c189d644d6fad23051e7a6ea3..f57ce6aac02057d35f30a4f76f69268e8776604c 100644 (file)
@@ -78,6 +78,7 @@ enum ath79_mach_type {
        ATH79_MACH_CPE870,                      /* YunCore CPE870 */
        ATH79_MACH_CR3000,                      /* PowerCloud CR3000 */
        ATH79_MACH_CR5000,                      /* PowerCloud CR5000 */
+       ATH79_MACH_DAP_1330_A1,                 /* D-Link DAP-1330 rev. A1 */
        ATH79_MACH_DAP_2695_A1,                 /* D-Link DAP-2695 rev. A1 */
        ATH79_MACH_DB120,                       /* Atheros DB120 reference board */
        ATH79_MACH_DGL_5500_A1,                 /* D-link DGL-5500 rev. A1 */
index 184087d38aae9724b9f416954cae6253e61b138f..088824d31ded390694a60a5fa494ee4d4ef144d0 100644 (file)
@@ -55,6 +55,7 @@ CONFIG_ATH79_MACH_CPE830=y
 CONFIG_ATH79_MACH_CPE870=y
 CONFIG_ATH79_MACH_CR3000=y
 CONFIG_ATH79_MACH_CR5000=y
+CONFIG_ATH79_MACH_DAP_1330_A1=y
 CONFIG_ATH79_MACH_DAP_2695_A1=y
 CONFIG_ATH79_MACH_DB120=y
 CONFIG_ATH79_MACH_DGL_5500_A1=y
index 8dd1b4768250e2f5723e83e1fe0c2d96243500de..b009be00c95724c42bb9950e7e4d4d8dae685358 100644 (file)
@@ -32,6 +32,16 @@ define Build/mkwrggimg
        mv $@.imghdr $@
 endef
 
+define Build/mkdapimg2
+       $(STAGING_DIR_HOST)/bin/mkdapimg2 \
+               -i $@ -o $@.new \
+               -s $(DAP_SIGNATURE) \
+               -v $(VERSION_DIST)-$(firstword $(subst -, ,$(REVISION))) \
+               -r Default \
+               $(if $(1),-k $(1))
+       mv $@.new $@
+endef
+
 define Build/netgear-squashfs
        rm -rf $@.fs $@.squashfs
        mkdir -p $@.fs/image
@@ -1129,6 +1139,18 @@ define Device/qihoo-c301
 endef
 TARGET_DEVICES += qihoo-c301
 
+define Device/dap-1330-a1
+  DEVICE_TITLE := D-Link DAP-1330 rev. A1
+  DEVICE_PACKAGES := rssileds
+  BOARDNAME := DAP-1330-A1
+  IMAGES := factory.img sysupgrade.bin
+  IMAGE_SIZE := 7936k
+  IMAGE/factory.img := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | mkdapimg2 917504
+  MTDPARTS := spi0.0:64k(u-boot)ro,64k(art)ro,64k(mp)ro,64k(config)ro,7936k(firmware)
+  DAP_SIGNATURE := HONEYBEE-FIRMWARE-DAP-1330
+endef
+TARGET_DEVICES += dap-1330-a1
+
 define Device/dap-2695-a1
   DEVICE_TITLE := D-Link DAP-2695 rev. A1
   DEVICE_PACKAGES := ath10k-firmware-qca988x kmod-ath10k