imagebuilder: don't rewrite package list output
authorDaniel Golle <daniel@makrotopia.org>
Fri, 16 Jun 2017 23:24:43 +0000 (01:24 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Fri, 16 Jun 2017 23:24:43 +0000 (01:24 +0200)
No longer rewrite opkg list output in package_list function, remove
the awk call in the pipe (which was intended for a single specific
use-case).

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/imagebuilder/files/Makefile

index d2afd0e8448aa8b425ea5816c3e11a4bff9e0461..95f405b8fd375bff28d7778f1ada11c5028feb84 100644 (file)
@@ -140,7 +140,7 @@ package_reload:
 
 package_list: FORCE
        @$(MAKE) -s package_reload
-       @$(OPKG) list --size 2>/dev/null | awk -F" - " '{printf "%s %s %s\n", $$1, $$2, $$3}'
+       @$(OPKG) list --size 2>/dev/null
 
 package_install: FORCE
        @echo