dnsmasq: Pass TARGET_CPPFLAGS to Makefile
authorFlorian Fainelli <f.fainelli@gmail.com>
Sat, 16 Sep 2017 23:27:37 +0000 (16:27 -0700)
committerFlorian Fainelli <f.fainelli@gmail.com>
Sat, 16 Sep 2017 23:38:19 +0000 (16:38 -0700)
With the introduction of the ubus notifications, we would now fail building
dnsmasq with external toolchains that don't automatically search for headers.
Pass TARGET_CPPFLAGS to the Makefile to resolve that.

Fixes: 34a206bc1194 ("dnsmasq: add ubus notifications for new leases")
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
package/network/services/dnsmasq/Makefile

index 57870a53b688c752f809559198ed427813d842a9..331e5fabe3922dd4b87219294c84fe1a91530022 100644 (file)
@@ -138,7 +138,7 @@ endif
 
 MAKE_FLAGS := \
        $(TARGET_CONFIGURE_OPTS) \
-       CFLAGS="$(TARGET_CFLAGS)" \
+       CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
        LDFLAGS="$(TARGET_LDFLAGS)" \
        COPTS="$(COPTS)" \
        PREFIX="/usr"