ar71xx: remove bs-partition ro-flag for UniFi AC
authorDavid Bauer <mail@david-bauer.net>
Tue, 6 Feb 2018 18:44:36 +0000 (19:44 +0100)
committerJohn Crispin <john@phrozen.org>
Sun, 11 Feb 2018 15:16:03 +0000 (16:16 +0100)
This removes the read-only flag from the bs (bootselect) partition
on UniFi AC devices. This allows to correct the indicator from which
partition the device is booting its kernel from.

See also:
 - https://github.com/freifunk-gluon/gluon/issues/1301
 - https://bugs.lede-project.org/index.php?do=details&task_id=662

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ar71xx/image/generic-ubnt.mk

index 2735c7491da600a7f16eeba5c211cc44297307e5..66d7c524964e37b8fcab836fcc3170a31bf8a07b 100644 (file)
@@ -113,7 +113,7 @@ define Device/ubnt-unifiac
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2
   DEVICE_PROFILE := UBNT
   IMAGE_SIZE := 7744k
-  MTDPARTS := spi0.0:384k(u-boot)ro,64k(u-boot-env)ro,7744k(firmware),7744k(ubnt-airos)ro,128k(bs)ro,256k(cfg)ro,64k(EEPROM)ro
+  MTDPARTS := spi0.0:384k(u-boot)ro,64k(u-boot-env)ro,7744k(firmware),7744k(ubnt-airos)ro,128k(bs),256k(cfg)ro,64k(EEPROM)ro
   IMAGES := sysupgrade.bin
   IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
 endef