build: fix dependency of kernel_menuconfig target
authorBaptiste Jonglez <git@bitsofnetworks.org>
Sun, 12 Feb 2017 13:48:35 +0000 (14:48 +0100)
committerFelix Fietkau <nbd@nbd.name>
Sun, 12 Feb 2017 13:53:29 +0000 (14:53 +0100)
When running "make kernel_menuconfig" in a clean tree, it fails with:

    make[1]: *** No rule to make target 'tools/quilt/install'.  Stop.

Replacing the dependency with 'tools/quilt/compile' fixes the issue (quilt
and all its prerequisites will be built, and quilt will be installed in
staging_dir).

Signed-off-by: Baptiste Jonglez <git@bitsofnetworks.org>
include/toplevel.mk

index 24e4ebf823fbb304fd32c67815596803890a367c..a9ea21bbef3eb8f3c794b5086a62a5a978600df2 100644 (file)
@@ -132,7 +132,7 @@ prepare_kernel_conf: .config FORCE
 
 ifeq ($(wildcard staging_dir/host/bin/quilt),)
   prepare_kernel_conf:
-       @+$(SUBMAKE) -r tools/quilt/install
+       @+$(SUBMAKE) -r tools/quilt/compile
 else
   prepare_kernel_conf: ;
 endif