layerscape: fix pfe module autoload issue
authorYangbo Lu <yangbo.lu@nxp.com>
Mon, 6 Nov 2017 09:18:48 +0000 (17:18 +0800)
committerJohn Crispin <john@phrozen.org>
Fri, 10 Nov 2017 22:00:50 +0000 (23:00 +0100)
There was a typo in module.mk for pfe module autoload.
This patch is to fix this and remove useless rc.local
which was for loading pfe module.

Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
target/linux/layerscape/base-files/etc/rc.local [deleted file]
target/linux/layerscape/modules.mk

diff --git a/target/linux/layerscape/base-files/etc/rc.local b/target/linux/layerscape/base-files/etc/rc.local
deleted file mode 100644 (file)
index 297c3a8..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-# Put your custom commands here that should be executed once
-# the system init finished. By default this file does nothing.
-modprobe pfe.ko
-exit 0
index 5fef373ff5920392db374a81bff23a8c22010e1e..7a368a0d2958c92a85501bb5fad7fa26d3e2dbe6 100644 (file)
@@ -11,7 +11,7 @@ define KernelPackage/ppfe
   DEPENDS:=@TARGET_layerscape
   KCONFIG:=CONFIG_FSL_PPFE CONFIG_FSL_PPFE_UTIL_DISABLED
   FILES:=$(LINUX_DIR)/drivers/staging/fsl_ppfe/pfe.ko
-  AUTOLOAD:=$(call AutoLoad,35,ppfe)
+  AUTOLOAD:=$(call AutoLoad,35,pfe)
 endef
 
 define KernelPackage/ppfe/description