kernel: bump 4.14 to 4.14.261
authorPetr Štetiar <ynezz@true.cz>
Thu, 6 Jan 2022 14:31:19 +0000 (15:31 +0100)
committerPetr Štetiar <ynezz@true.cz>
Thu, 6 Jan 2022 14:31:19 +0000 (15:31 +0100)
All patches refreshed automagically without conflicts.

Run tested on ipq40xx/glinet-b1300 and mvebu/turris-omnia.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
22 files changed:
include/kernel-version.mk
target/linux/apm821xx/patches-4.14/801-usb-xhci-add-firmware-loader-for-uPD720201-and-uPD72.patch
target/linux/apm821xx/patches-4.14/802-usb-xhci-force-msi-renesas-xhci.patch
target/linux/brcm2708/patches-4.14/950-0170-lan78xx-Avoid-spurious-kevent-4-error.patch
target/linux/brcm2708/patches-4.14/950-0251-lan78xx-Read-initial-EEE-status-from-DT.patch
target/linux/brcm2708/patches-4.14/950-0252-lan78xx-Change-LEDs-to-include-10Mb-activity.patch
target/linux/brcm2708/patches-4.14/950-0257-lan78xx-Read-LED-states-from-Device-Tree.patch
target/linux/brcm2708/patches-4.14/950-0265-net-lan78xx-Allow-for-VLAN-headers-in-timeout.patch
target/linux/brcm2708/patches-4.14/950-0268-lan78xx-Move-enabling-of-EEE-into-PHY-init-code.patch
target/linux/brcm2708/patches-4.14/950-0269-net-lan78xx-Request-s-w-csum-check-on-VLAN-tagged-pa.patch
target/linux/brcm2708/patches-4.14/950-0270-net-lan78xx-Add-support-for-VLAN-filtering.patch
target/linux/brcm2708/patches-4.14/950-0271-net-lan78xx-Add-support-for-VLAN-tag-stripping.patch
target/linux/brcm2708/patches-4.14/950-0272-net-lan78xx-Reduce-s-w-csum-check-on-VLANs.patch
target/linux/brcm2708/patches-4.14/950-0314-net-lan78xx-Disable-TCP-Segmentation-Offload-TSO.patch
target/linux/brcm2708/patches-4.14/950-0359-net-lan78xx-fix-rx-handling-before-first-packet-is-s.patch
target/linux/brcm2708/patches-4.14/950-0360-lan78xx-Fix-link-status-notifications.patch
target/linux/brcm2708/patches-4.14/950-0443-net-lan78xx-Support-auto-downshift-to-100Mb-s.patch
target/linux/brcm2708/patches-4.14/950-0454-lan78xx-Debounce-link-events-to-minimize-poll-storm.patch
target/linux/brcm2708/patches-4.14/961-lan78xx-enable-LED.patch
target/linux/generic/backport-4.14/291-v4.16-netfilter-core-remove-synchronize_net-call-if-nfqueu.patch
target/linux/generic/backport-4.14/336-v4.15-netfilter-exit_net-cleanup-check-added.patch
target/linux/mediatek/patches-4.14/0191-usb-xhci-allow-imod-interval-to-be-configurable.patch

index 0151a7d14193c009525f147b430dd5c62753358e..8cfa5d4e65c94ade38ef87db0ce6db062d3ccd57 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .259
+LINUX_VERSION-4.14 = .261
 
-LINUX_KERNEL_HASH-4.14.259 = 26e284541ff77bd3af14e40aa690bcf229d0f9b9677704fd9fecb59e108e4368
+LINUX_KERNEL_HASH-4.14.261 = bffaaa4c93ab4ed1de61f804c26c92b82dd80f92793e20194b62497d7b8b4723
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 7efc437fa18e58bbf16e9841ca36a3daf7fce0ab..cea448e8bbb023b815049cbf6aa1e2fd21604359 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
  
  #include "xhci.h"
  #include "xhci-trace.h"
-@@ -282,6 +284,458 @@ static void xhci_pme_acpi_rtd3_enable(st
+@@ -285,6 +287,458 @@ static void xhci_pme_acpi_rtd3_enable(st
  static void xhci_pme_acpi_rtd3_enable(struct pci_dev *dev) { }
  #endif /* CONFIG_ACPI */
  
@@ -503,7 +503,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
  /* called during probe() after chip reset completes */
  static int xhci_pci_setup(struct usb_hcd *hcd)
  {
-@@ -320,6 +774,22 @@ static int xhci_pci_probe(struct pci_dev
+@@ -323,6 +777,22 @@ static int xhci_pci_probe(struct pci_dev
        struct hc_driver *driver;
        struct usb_hcd *hcd;
  
@@ -526,7 +526,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
        driver = (struct hc_driver *)id->driver_data;
  
        /* For some HW implementation, a XHCI reset is just not enough... */
-@@ -381,6 +851,16 @@ static void xhci_pci_remove(struct pci_d
+@@ -384,6 +854,16 @@ static void xhci_pci_remove(struct pci_d
  {
        struct xhci_hcd *xhci;
  
index bfc5fe8507e5ce4d72d6f2bfa344321f1c68c50b..3e0c34a0d9f904d21ac19fb4f80e665d4e64f57f 100644 (file)
@@ -13,7 +13,7 @@ produce a noisy warning.
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -228,7 +228,7 @@ static void xhci_pci_quirks(struct devic
+@@ -231,7 +231,7 @@ static void xhci_pci_quirks(struct devic
                xhci->quirks |= XHCI_TRUST_TX_LENGTH;
        if (pdev->vendor == PCI_VENDOR_ID_RENESAS &&
                        pdev->device == 0x0015)
index 8ad6c069dd602d473e09709877f7cca3157dc496..e9b4d3855d55260cdc9f5c446d1954bf8a1a8a56 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2502,7 +2502,7 @@ static void lan78xx_init_stats(struct la
+@@ -2504,7 +2504,7 @@ static void lan78xx_init_stats(struct la
        dev->stats.rollover_max.eee_tx_lpi_transitions = 0xFFFFFFFF;
        dev->stats.rollover_max.eee_tx_lpi_time = 0xFFFFFFFF;
  
index c10286401aa95f8ee53fc048c6e5e93b6e607660..7b7c04f11c461f994bc875eed1564b9e36780d01 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2518,6 +2518,22 @@ static int lan78xx_open(struct net_devic
+@@ -2520,6 +2520,22 @@ static int lan78xx_open(struct net_devic
  
        netif_dbg(dev, ifup, dev->net, "phy initialised successfully");
  
index ef87555112cca6d9b29ee78b6e9976a8345cdedb..47c20a7f132e59e56f6d53e9aedf98f711ce47f4 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2002,6 +2002,7 @@ static int lan78xx_phy_init(struct lan78
+@@ -2004,6 +2004,7 @@ static int lan78xx_phy_init(struct lan78
  {
        int ret;
        u32 mii_adv;
@@ -22,7 +22,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        struct phy_device *phydev = dev->net->phydev;
  
        phydev = phy_find_first(dev->mdiobus);
-@@ -2074,6 +2075,19 @@ static int lan78xx_phy_init(struct lan78
+@@ -2076,6 +2077,19 @@ static int lan78xx_phy_init(struct lan78
        mii_adv = (u32)mii_advertise_flowctrl(dev->fc_request_control);
        phydev->advertising |= mii_adv_to_ethtool_adv_t(mii_adv);
  
index 8143e0efe99eb2a1c015f96c7efc7a02a209bbb6..d9de18f40122de5ab0eb1df2ad6565e840b65404 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2002,7 +2002,9 @@ static int lan78xx_phy_init(struct lan78
+@@ -2004,7 +2004,9 @@ static int lan78xx_phy_init(struct lan78
  {
        int ret;
        u32 mii_adv;
@@ -30,7 +30,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        struct phy_device *phydev = dev->net->phydev;
  
        phydev = phy_find_first(dev->mdiobus);
-@@ -2075,18 +2077,27 @@ static int lan78xx_phy_init(struct lan78
+@@ -2077,18 +2079,27 @@ static int lan78xx_phy_init(struct lan78
        mii_adv = (u32)mii_advertise_flowctrl(dev->fc_request_control);
        phydev->advertising |= mii_adv_to_ethtool_adv_t(mii_adv);
  
index 3e46e64385c4f701fedefa4c4643e28df7d0f0bf..fa4dbcd35e6bb8d3806089357a778112dcd7e190 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2198,7 +2198,7 @@ static int lan78xx_change_mtu(struct net
+@@ -2200,7 +2200,7 @@ static int lan78xx_change_mtu(struct net
        if ((ll_mtu % dev->maxpacket) == 0)
                return -EDOM;
  
@@ -26,7 +26,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  
        netdev->mtu = new_mtu;
  
-@@ -2491,7 +2491,8 @@ static int lan78xx_reset(struct lan78xx_
+@@ -2493,7 +2493,8 @@ static int lan78xx_reset(struct lan78xx_
        buf |= FCT_TX_CTL_EN_;
        ret = lan78xx_write_reg(dev, FCT_TX_CTL, buf);
  
index a90f25326ca429a7f1a3718eaeeac425c92964ca..1d334d009142e8b79a4a25e12805ea6337c65cd3 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2077,6 +2077,22 @@ static int lan78xx_phy_init(struct lan78
+@@ -2079,6 +2079,22 @@ static int lan78xx_phy_init(struct lan78
        mii_adv = (u32)mii_advertise_flowctrl(dev->fc_request_control);
        phydev->advertising |= mii_adv_to_ethtool_adv_t(mii_adv);
  
@@ -39,7 +39,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        /* Set LED modes:
         * led: 0=link/activity          1=link1000/activity
         *      2=link100/activity       3=link10/activity
-@@ -2544,22 +2560,6 @@ static int lan78xx_open(struct net_devic
+@@ -2546,22 +2562,6 @@ static int lan78xx_open(struct net_devic
  
        netif_dbg(dev, ifup, dev->net, "phy initialised successfully");
  
index ab9e09ed4e57b61c9a8662e04e31563a69abbf9e..206bd2588d4a200b57157ae42e872b372f93569f 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2896,8 +2896,12 @@ static void lan78xx_rx_csum_offload(stru
+@@ -2898,8 +2898,12 @@ static void lan78xx_rx_csum_offload(stru
                                    struct sk_buff *skb,
                                    u32 rx_cmd_a, u32 rx_cmd_b)
  {
index fc25c5f3d2750fe25f99d6f4e3116da741efb409..c66a6cde5e715a3d1d3d5331767516cf2a82c2aa 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2283,7 +2283,7 @@ static int lan78xx_set_features(struct n
+@@ -2285,7 +2285,7 @@ static int lan78xx_set_features(struct n
                pdata->rfe_ctl &= ~(RFE_CTL_ICMP_COE_ | RFE_CTL_IGMP_COE_);
        }
  
@@ -24,7 +24,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
                pdata->rfe_ctl |= RFE_CTL_VLAN_FILTER_;
        else
                pdata->rfe_ctl &= ~RFE_CTL_VLAN_FILTER_;
-@@ -2832,6 +2832,9 @@ static int lan78xx_bind(struct lan78xx_n
+@@ -2834,6 +2834,9 @@ static int lan78xx_bind(struct lan78xx_n
        if (DEFAULT_TSO_CSUM_ENABLE)
                dev->net->features |= NETIF_F_TSO | NETIF_F_TSO6 | NETIF_F_SG;
  
index 518ff32d14607f921289fac7e44c04d10f2dd661..ece8542c01ead99f5bae26d4db2fe4e1f7cd8b2c 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  #define TX_OVERHEAD                   (8)
  #define RXW_PADDING                   2
  
-@@ -2283,6 +2284,11 @@ static int lan78xx_set_features(struct n
+@@ -2285,6 +2286,11 @@ static int lan78xx_set_features(struct n
                pdata->rfe_ctl &= ~(RFE_CTL_ICMP_COE_ | RFE_CTL_IGMP_COE_);
        }
  
@@ -36,7 +36,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
        if (features & NETIF_F_HW_VLAN_CTAG_FILTER)
                pdata->rfe_ctl |= RFE_CTL_VLAN_FILTER_;
        else
-@@ -2832,6 +2838,9 @@ static int lan78xx_bind(struct lan78xx_n
+@@ -2834,6 +2840,9 @@ static int lan78xx_bind(struct lan78xx_n
        if (DEFAULT_TSO_CSUM_ENABLE)
                dev->net->features |= NETIF_F_TSO | NETIF_F_TSO6 | NETIF_F_SG;
  
@@ -46,7 +46,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
        if (DEFAULT_VLAN_FILTER_ENABLE)
                dev->net->features |= NETIF_F_HW_VLAN_CTAG_FILTER;
  
-@@ -2912,6 +2921,16 @@ static void lan78xx_rx_csum_offload(stru
+@@ -2914,6 +2923,16 @@ static void lan78xx_rx_csum_offload(stru
        }
  }
  
@@ -63,7 +63,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  static void lan78xx_skb_return(struct lan78xx_net *dev, struct sk_buff *skb)
  {
        int             status;
-@@ -2976,6 +2995,8 @@ static int lan78xx_rx(struct lan78xx_net
+@@ -2978,6 +2997,8 @@ static int lan78xx_rx(struct lan78xx_net
                        if (skb->len == size) {
                                lan78xx_rx_csum_offload(dev, skb,
                                                        rx_cmd_a, rx_cmd_b);
@@ -72,7 +72,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  
                                skb_trim(skb, skb->len - 4); /* remove fcs */
                                skb->truesize = size + sizeof(struct sk_buff);
-@@ -2994,6 +3015,7 @@ static int lan78xx_rx(struct lan78xx_net
+@@ -2996,6 +3017,7 @@ static int lan78xx_rx(struct lan78xx_net
                        skb_set_tail_pointer(skb2, size);
  
                        lan78xx_rx_csum_offload(dev, skb2, rx_cmd_a, rx_cmd_b);
index 0f68ebfda6468dd102070ff2514eb7e0d01ea59c..7aa49a9b0389ddd52862d06795c4b6751133cd8e 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2908,12 +2908,13 @@ static void lan78xx_rx_csum_offload(stru
+@@ -2910,12 +2910,13 @@ static void lan78xx_rx_csum_offload(stru
                                    struct sk_buff *skb,
                                    u32 rx_cmd_a, u32 rx_cmd_b)
  {
index bc2b6c2972b5f578cd434773adb877b6cf23b438..867aa44ffc62bbb239b97a2b71a5d7988bccf5c5 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -412,6 +412,15 @@ static int msg_level = -1;
+@@ -414,6 +414,15 @@ static int msg_level = -1;
  module_param(msg_level, int, 0);
  MODULE_PARM_DESC(msg_level, "Override default message level");
  
@@ -37,7 +37,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  static int lan78xx_read_reg(struct lan78xx_net *dev, u32 index, u32 *data)
  {
        u32 *buf = kmalloc(sizeof(u32), GFP_KERNEL);
-@@ -2835,8 +2844,14 @@ static int lan78xx_bind(struct lan78xx_n
+@@ -2837,8 +2846,14 @@ static int lan78xx_bind(struct lan78xx_n
        if (DEFAULT_RX_CSUM_ENABLE)
                dev->net->features |= NETIF_F_RXCSUM;
  
index 4170ebabd7a729e21e4b65d53d450dc40a7321b0..d308f082148f37ae5fc392278da12fb3de8ebc96 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2593,6 +2593,8 @@ static int lan78xx_open(struct net_devic
+@@ -2595,6 +2595,8 @@ static int lan78xx_open(struct net_devic
  
        dev->link_on = false;
  
index d68873582be0bfe1b6097a95a500778fa6b80d02..5a279cdebdd27516bbb97e3bc32b166b748c529c 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2593,8 +2593,6 @@ static int lan78xx_open(struct net_devic
+@@ -2595,8 +2595,6 @@ static int lan78xx_open(struct net_devic
  
        dev->link_on = false;
  
index b0e727f020ebfa2e2a2122fd574e9173d3fbb834..3bb25695738bd2f89c3187eba0421f15738768f7 100644 (file)
@@ -85,7 +85,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  #include <linux/of_net.h>
  #include "lan78xx.h"
  
-@@ -1766,6 +1767,7 @@ done:
+@@ -1768,6 +1769,7 @@ done:
  
  static int lan78xx_mdio_init(struct lan78xx_net *dev)
  {
@@ -93,7 +93,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        int ret;
  
        dev->mdiobus = mdiobus_alloc();
-@@ -1795,7 +1797,9 @@ static int lan78xx_mdio_init(struct lan7
+@@ -1797,7 +1799,9 @@ static int lan78xx_mdio_init(struct lan7
                break;
        }
  
index 6e03e4dedf46a91371505dd789f85072fdca4616..4da249abb8e129cc744069ae5527ad62d475cea8 100644 (file)
@@ -16,7 +16,7 @@ See: https://github.com/raspberrypi/linux/issues/2447
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -422,6 +422,11 @@ static bool enable_tso;
+@@ -424,6 +424,11 @@ static bool enable_tso;
  module_param(enable_tso, bool, 0644);
  MODULE_PARM_DESC(enable_tso, "Enables TCP segmentation offload");
  
@@ -28,7 +28,7 @@ See: https://github.com/raspberrypi/linux/issues/2447
  static int lan78xx_read_reg(struct lan78xx_net *dev, u32 index, u32 *data)
  {
        u32 *buf = kmalloc(sizeof(u32), GFP_KERNEL);
-@@ -3685,7 +3690,12 @@ static int lan78xx_probe(struct usb_inte
+@@ -3687,7 +3692,12 @@ static int lan78xx_probe(struct usb_inte
        netdev->max_mtu = MAX_SINGLE_PACKET_SIZE;
        netif_set_gso_max_size(netdev, MAX_SINGLE_PACKET_SIZE - MAX_HEADER);
  
index 1281c81c38080cc826de2e3292a6deb395a90de1..2b9f91137bc71667eb410662e2b70eb295b35b36 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2466,6 +2466,15 @@ static int lan78xx_reset(struct lan78xx_
+@@ -2468,6 +2468,15 @@ static int lan78xx_reset(struct lan78xx_
  
        ret = lan78xx_read_reg(dev, HW_CFG, &buf);
        buf |= HW_CFG_MEF_;
index 0ac5783624fc729977e14fd00151abb5168e710a..cbaaaa619a4b456983f13eebfd2c58c590760652 100644 (file)
@@ -88,7 +88,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  
 --- a/net/netfilter/nfnetlink_queue.c
 +++ b/net/netfilter/nfnetlink_queue.c
-@@ -941,23 +941,18 @@ static struct notifier_block nfqnl_dev_n
+@@ -942,23 +942,18 @@ static struct notifier_block nfqnl_dev_n
        .notifier_call  = nfqnl_rcv_dev_event,
  };
  
index 79f4342d7e8ae50ede115d6d55b4ba21a72d78d2..bd26f2d163c58dcf54f9049ed18b45b34d2839ff 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  static int __init nf_tables_module_init(void)
 --- a/net/netfilter/nfnetlink_log.c
 +++ b/net/netfilter/nfnetlink_log.c
-@@ -1093,10 +1093,15 @@ static int __net_init nfnl_log_net_init(
+@@ -1094,10 +1094,15 @@ static int __net_init nfnl_log_net_init(
  
  static void __net_exit nfnl_log_net_exit(struct net *net)
  {
@@ -62,7 +62,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  static struct pernet_operations nfnl_log_net_ops = {
 --- a/net/netfilter/nfnetlink_queue.c
 +++ b/net/netfilter/nfnetlink_queue.c
-@@ -1510,10 +1510,15 @@ static int __net_init nfnl_queue_net_ini
+@@ -1511,10 +1511,15 @@ static int __net_init nfnl_queue_net_ini
  
  static void __net_exit nfnl_queue_net_exit(struct net *net)
  {
index 91a645710bd41c9cdfd235489468abc6b18a15a8..47aa8a3f97366f5c47efbc71bed0f80a3f0b84f3 100644 (file)
@@ -86,7 +86,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
        if (!xhci->shared_hcd) {
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -293,6 +293,9 @@ static int xhci_pci_setup(struct usb_hcd
+@@ -296,6 +296,9 @@ static int xhci_pci_setup(struct usb_hcd
        if (!xhci->sbrn)
                pci_read_config_byte(pdev, XHCI_SBRN_OFFSET, &xhci->sbrn);