kernel: bump 4.14 to 4.14.248
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 2 Oct 2021 11:38:04 +0000 (13:38 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 2 Oct 2021 14:11:47 +0000 (16:11 +0200)
All updated automatically.

Compile-tested on: lantiq/xrx200, armvirt/64
Runtime-tested on: lantiq/xrx200, armvirt/64

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
21 files changed:
include/kernel-version.mk
target/linux/brcm2708/patches-4.14/950-0056-fbdev-add-FBIOCOPYAREA-ioctl.patch
target/linux/brcm2708/patches-4.14/950-0315-usb-gadget-ethernet-Re-enable-Jumbo-frames.patch
target/linux/gemini/patches-4.14/0028-usb-host-fotg2-add-device-tree-probing.patch
target/linux/gemini/patches-4.14/0029-usb-host-fotg2-add-silicon-clock-handling.patch
target/linux/gemini/patches-4.14/0030-usb-host-fotg2-add-Gemini-specific-handling.patch
target/linux/generic/backport-4.14/080-v5.1-0001-bcma-keep-a-direct-pointer-to-the-struct-device.patch
target/linux/generic/backport-4.14/274-flow_dissector-Parse-batman-adv-unicast-headers.patch
target/linux/generic/hack-4.14/220-gc_sections.patch
target/linux/generic/pending-4.14/810-pci_disable_common_quirks.patch
target/linux/generic/pending-4.14/834-ledtrig-libata.patch
target/linux/layerscape/patches-4.14/807-usb-support-layerscape.patch
target/linux/layerscape/patches-4.14/808-vfio-support-layerscape.patch
target/linux/layerscape/patches-4.14/816-pcie-support-layerscape.patch
target/linux/layerscape/patches-4.14/820-sec-support-layerscape.patch
target/linux/mediatek/patches-4.14/0012-clk-dont-disable-unused-clocks.patch
target/linux/mvebu/patches-4.14/524-PCI-aardvark-set-host-and-device-to-the-same-MAX-payload-size.patch
target/linux/mvebu/patches-4.14/527-PCI-aardvark-allow-to-specify-link-capability.patch
target/linux/mxs/patches-4.14/110-crypto-mxsdcp-provide-importexport.patch
target/linux/oxnas/patches-4.14/999-libata-hacks.patch
target/linux/x86/patches-4.14/200-pcengines-apu2-reboot.patch

index 5636a112162e2f7cc83b229138499bb635931c13..5230350d9b67ad5f1776c8314a63bca81ac8e2f2 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .245
+LINUX_VERSION-4.14 = .248
 
-LINUX_KERNEL_HASH-4.14.245 = 0d7461890bca7eb836ff9f61b129cead97c80725577f7077a5fd67b18ea6b220
+LINUX_KERNEL_HASH-4.14.248 = c993eecf5cc41acbd874fde56eecb87ac021df477defe3d8bd1d811548d3b654
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 242fa50d9c52610fb198a64e1d6c920594b3b2bb..881db93810552335682169f8f2641c5f1d679afb 100644 (file)
@@ -170,7 +170,7 @@ bcm2708_fb: Add ioctl for reading gpu memory through dma
                platform_set_drvdata(dev, fb);
 --- a/drivers/video/fbdev/core/fbmem.c
 +++ b/drivers/video/fbdev/core/fbmem.c
-@@ -1093,6 +1093,31 @@ fb_blank(struct fb_info *info, int blank
+@@ -1104,6 +1104,31 @@ fb_blank(struct fb_info *info, int blank
  }
  EXPORT_SYMBOL(fb_blank);
  
@@ -202,7 +202,7 @@ bcm2708_fb: Add ioctl for reading gpu memory through dma
  static long do_fb_ioctl(struct fb_info *info, unsigned int cmd,
                        unsigned long arg)
  {
-@@ -1103,6 +1128,7 @@ static long do_fb_ioctl(struct fb_info *
+@@ -1114,6 +1139,7 @@ static long do_fb_ioctl(struct fb_info *
        struct fb_cmap cmap_from;
        struct fb_cmap_user cmap;
        struct fb_event event;
@@ -210,7 +210,7 @@ bcm2708_fb: Add ioctl for reading gpu memory through dma
        void __user *argp = (void __user *)arg;
        long ret = 0;
  
-@@ -1220,6 +1246,15 @@ static long do_fb_ioctl(struct fb_info *
+@@ -1231,6 +1257,15 @@ static long do_fb_ioctl(struct fb_info *
                unlock_fb_info(info);
                console_unlock();
                break;
@@ -226,7 +226,7 @@ bcm2708_fb: Add ioctl for reading gpu memory through dma
        default:
                if (!lock_fb_info(info))
                        return -ENODEV;
-@@ -1365,6 +1400,7 @@ static long fb_compat_ioctl(struct file
+@@ -1376,6 +1411,7 @@ static long fb_compat_ioctl(struct file
        case FBIOPAN_DISPLAY:
        case FBIOGET_CON2FBMAP:
        case FBIOPUT_CON2FBMAP:
index fff3b6091f0ed13d13d3455ecbfa7aca3168d162..d72ec7dcaba1b05f394ceaa91c25c770247fe732 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
 
 --- a/drivers/usb/gadget/function/u_ether.c
 +++ b/drivers/usb/gadget/function/u_ether.c
-@@ -855,6 +855,10 @@ struct net_device *gether_setup_name_def
+@@ -856,6 +856,10 @@ struct net_device *gether_setup_name_def
        net->min_mtu = ETH_HLEN;
        net->max_mtu = GETHER_MAX_MTU_SIZE;
  
index 01a704830fd3a1c408b0807120c22ff7773ed4ae..98a6488a2454edf97bab454715d9a7f278689441 100644 (file)
@@ -24,7 +24,7 @@ ChangeLog v2->v3:
  #include <linux/device.h>
  #include <linux/dmapool.h>
  #include <linux/kernel.h>
-@@ -5604,6 +5605,15 @@ static int fotg210_hcd_probe(struct plat
+@@ -5601,6 +5602,15 @@ static int fotg210_hcd_probe(struct plat
        if (usb_disabled())
                return -ENODEV;
  
@@ -40,7 +40,7 @@ ChangeLog v2->v3:
        pdev->dev.power.power_state = PMSG_ON;
  
        res = platform_get_resource(pdev, IORESOURCE_IRQ, 0);
-@@ -5680,9 +5690,18 @@ static int fotg210_hcd_remove(struct pla
+@@ -5677,9 +5687,18 @@ static int fotg210_hcd_remove(struct pla
        return 0;
  }
  
index 5ecd9297e5260b85dd56c6bba9c52010ff6b0186..6a45ace14b0ef2e2c1bfeee62263e1f6148aa599 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
  
  #include <asm/byteorder.h>
  #include <asm/irq.h>
-@@ -5639,7 +5640,7 @@ static int fotg210_hcd_probe(struct plat
+@@ -5636,7 +5637,7 @@ static int fotg210_hcd_probe(struct plat
        hcd->regs = devm_ioremap_resource(&pdev->dev, res);
        if (IS_ERR(hcd->regs)) {
                retval = PTR_ERR(hcd->regs);
@@ -35,7 +35,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
        }
  
        hcd->rsrc_start = res->start;
-@@ -5649,22 +5650,35 @@ static int fotg210_hcd_probe(struct plat
+@@ -5646,22 +5647,35 @@ static int fotg210_hcd_probe(struct plat
  
        fotg210->caps = hcd->regs;
  
@@ -74,7 +74,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
        usb_put_hcd(hcd);
  fail_create_hcd:
        dev_err(dev, "init %s fail, %d\n", dev_name(dev), retval);
-@@ -5680,6 +5694,10 @@ static int fotg210_hcd_remove(struct pla
+@@ -5677,6 +5691,10 @@ static int fotg210_hcd_remove(struct pla
  {
        struct device *dev = &pdev->dev;
        struct usb_hcd *hcd = dev_get_drvdata(dev);
index 0125e816d6c92f8f926076cf1340007afa4e354a..4b015367226e085cbc7a4446895a1af2eaea5133 100644 (file)
@@ -43,7 +43,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
  
  #include <asm/byteorder.h>
  #include <asm/irq.h>
-@@ -5587,6 +5591,72 @@ static void fotg210_init(struct fotg210_
+@@ -5584,6 +5588,72 @@ static void fotg210_init(struct fotg210_
        iowrite32(value, &fotg210->regs->otgcsr);
  }
  
@@ -116,7 +116,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
  /**
   * fotg210_hcd_probe - initialize faraday FOTG210 HCDs
   *
-@@ -5666,6 +5736,12 @@ static int fotg210_hcd_probe(struct plat
+@@ -5663,6 +5733,12 @@ static int fotg210_hcd_probe(struct plat
  
        fotg210_init(fotg210);
  
index cc32aee17b689e4097e1c7e85bdac9f1e2602e28..377b5250613aa2503951ad9617122431c51692fd 100644 (file)
@@ -95,7 +95,7 @@ Signed-off-by: Kalle Valo <kvalo@codeaurora.org>
                return 0;
        case BCMA_HOSTTYPE_SDIO:
                return 0;
-@@ -239,18 +239,18 @@ void bcma_prepare_core(struct bcma_bus *
+@@ -240,18 +240,18 @@ void bcma_prepare_core(struct bcma_bus *
        core->dev.release = bcma_release_core_dev;
        core->dev.bus = &bcma_bus_type;
        dev_set_name(&core->dev, "bcma%d:%d", bus->num, core->core_index);
@@ -120,7 +120,7 @@ Signed-off-by: Kalle Valo <kvalo@codeaurora.org>
                } else {
                        core->dev.dma_mask = &core->dev.coherent_dma_mask;
                        core->dma_dev = &core->dev;
-@@ -261,28 +261,6 @@ void bcma_prepare_core(struct bcma_bus *
+@@ -262,28 +262,6 @@ void bcma_prepare_core(struct bcma_bus *
        }
  }
  
index a9b2fc40a3d9f0cb859db8fb50447f6fb9871b29..693e64c8a84467076b2e602b466c31965762ea1b 100644 (file)
@@ -94,7 +94,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  static void
  __skb_flow_dissect_tcp(const struct sk_buff *skb,
                       struct flow_dissector *flow_dissector,
-@@ -718,6 +770,11 @@ proto_again:
+@@ -722,6 +774,11 @@ proto_again:
                                               nhoff, hlen);
                break;
  
index db6564ed7a740081f4ad2875e98ad933fa87b137..0095b7983444483d7535c5b96f9a2031139db827 100644 (file)
@@ -57,7 +57,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
        select OF_EARLY_FLATTREE if OF
 --- a/arch/arm/boot/compressed/Makefile
 +++ b/arch/arm/boot/compressed/Makefile
-@@ -103,6 +103,7 @@ ifeq ($(CONFIG_FUNCTION_TRACER),y)
+@@ -105,6 +105,7 @@ ifeq ($(CONFIG_FUNCTION_TRACER),y)
  ORIG_CFLAGS := $(KBUILD_CFLAGS)
  KBUILD_CFLAGS = $(subst -pg, , $(ORIG_CFLAGS))
  endif
index 1d10af647f1b851ca813e51bc417ad5a6ea5e5ec..c844e2d46e1a1a1d63f579a8aa2c849b6fd98a49 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  /* The Mellanox Tavor device gives false positive parity errors
   * Mark this device with a broken_parity_status, to allow
   * PCI scanning code to "skip" this now blacklisted device.
-@@ -3108,6 +3109,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
+@@ -3109,6 +3110,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
  DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x65f9, quirk_intel_mc_errata);
  DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x65fa, quirk_intel_mc_errata);
  
@@ -40,7 +40,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  
  /*
   * Ivytown NTB BAR sizes are misreported by the hardware due to an erratum.  To
-@@ -3164,6 +3166,8 @@ static void fixup_debug_report(struct pc
+@@ -3165,6 +3167,8 @@ static void fixup_debug_report(struct pc
        }
  }
  
@@ -49,7 +49,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  /*
   * Some BIOS implementations leave the Intel GPU interrupts enabled,
   * even though no one is handling them (f.e. i915 driver is never loaded).
-@@ -3202,6 +3206,8 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_IN
+@@ -3203,6 +3207,8 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_IN
  DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x010a, disable_igfx_irq);
  DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x0152, disable_igfx_irq);
  
index e3fd88f6b0627d6ab1df050cf5f1b44cdcb0b9d9..b025785ae15fae78a154900a2bd8101e9c8107ee 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -5125,6 +5138,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -5129,6 +5142,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
                if (tag < 0)
                        return NULL;
        }
@@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = tag;
-@@ -6028,6 +6044,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -6032,6 +6048,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
-@@ -6049,6 +6068,12 @@ static void ata_host_release(struct devi
+@@ -6053,6 +6072,12 @@ static void ata_host_release(struct devi
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6495,7 +6520,23 @@ int ata_host_register(struct ata_host *h
+@@ -6499,7 +6524,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
index 43e680c5434377fc5785591819b65fe61e5bf7f5..6c9cdc3d6b134347126d5b64faa6b33ad29b0e24 100644 (file)
@@ -528,7 +528,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
                reg &= ~DWC3_DCTL_INITU2ENA;
 --- a/drivers/usb/dwc3/gadget.c
 +++ b/drivers/usb/dwc3/gadget.c
-@@ -3245,6 +3245,7 @@ int dwc3_gadget_init(struct dwc3 *dwc)
+@@ -3244,6 +3244,7 @@ int dwc3_gadget_init(struct dwc3 *dwc)
  {
        int ret;
        int irq;
@@ -536,7 +536,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
  
        irq = dwc3_gadget_get_irq(dwc);
        if (irq < 0) {
-@@ -3323,6 +3324,12 @@ int dwc3_gadget_init(struct dwc3 *dwc)
+@@ -3322,6 +3323,12 @@ int dwc3_gadget_init(struct dwc3 *dwc)
  
        dwc3_gadget_set_speed(&dwc->gadget, dwc->maximum_speed);
  
@@ -1515,7 +1515,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
                        return IRQ_HANDLED;
                }
        }
-@@ -920,12 +929,32 @@ int usb_otg_start(struct platform_device
+@@ -922,12 +931,32 @@ int usb_otg_start(struct platform_device
        temp &= ~(PORTSC_PHY_TYPE_SEL | PORTSC_PTW);
        switch (pdata->phy_mode) {
        case FSL_USB2_PHY_ULPI:
index c2424a41f007ed9b31a52ee7eb850410cd30f31c..51e2fc5a5af4a83d01eb491022f2ec30773f040d 100644 (file)
@@ -27,7 +27,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
 
 --- a/drivers/vfio/Kconfig
 +++ b/drivers/vfio/Kconfig
-@@ -47,4 +47,5 @@ menuconfig VFIO_NOIOMMU
+@@ -47,4 +47,5 @@ config VFIO_NOIOMMU
  source "drivers/vfio/pci/Kconfig"
  source "drivers/vfio/platform/Kconfig"
  source "drivers/vfio/mdev/Kconfig"
index 38a308e9d415c054e24705080e6d013cde23aaf7..d7878e83a0987c243d99203be16872e59267e7f4 100644 (file)
@@ -3128,7 +3128,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        /* Parse and map our Configuration Space windows */
 --- a/drivers/pci/host/pcie-xilinx-nwl.c
 +++ b/drivers/pci/host/pcie-xilinx-nwl.c
-@@ -778,16 +778,7 @@ static int nwl_pcie_parse_dt(struct nwl_
+@@ -780,16 +780,7 @@ static int nwl_pcie_parse_dt(struct nwl_
                             struct platform_device *pdev)
  {
        struct device *dev = pcie->dev;
@@ -5604,7 +5604,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
         * them, we have to fall back to INTx or other interrupts, e.g., a
 --- a/drivers/pci/quirks.c
 +++ b/drivers/pci/quirks.c
-@@ -3430,6 +3430,13 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_A
+@@ -3431,6 +3431,13 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_A
   */
  DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_TI, 0xb005, quirk_no_bus_reset);
  
@@ -5808,7 +5808,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        struct pci_epc          *epc;
 --- a/include/linux/pci.h
 +++ b/include/linux/pci.h
-@@ -1946,6 +1946,7 @@ void pcibios_release_device(struct pci_d
+@@ -1947,6 +1947,7 @@ void pcibios_release_device(struct pci_d
  void pcibios_penalize_isa_irq(int irq, int active);
  int pcibios_alloc_irq(struct pci_dev *dev);
  void pcibios_free_irq(struct pci_dev *dev);
index 63f6540be08e1c926a8081fd8bc7ead0b1fefc74..5c75068749ca2d57071e136ffdbff4e5739d797a 100644 (file)
@@ -15267,7 +15267,7 @@ Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>
  #endif /* __SG_SW_QM_H */
 --- a/drivers/crypto/talitos.c
 +++ b/drivers/crypto/talitos.c
-@@ -1250,6 +1250,14 @@ static int ipsec_esp(struct talitos_edes
+@@ -1254,6 +1254,14 @@ static int ipsec_esp(struct talitos_edes
        ret = talitos_sg_map_ext(dev, areq->src, cryptlen, edesc, &desc->ptr[4],
                                 sg_count, areq->assoclen, tbl_off, elen);
  
index a3fd3138cc69f0df7e1933778ca4507960a47fa0..c5048c8e6f950ec02d4a6ceda07184ccb54d51b6 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/clk/clk.c
 +++ b/drivers/clk/clk.c
-@@ -808,7 +808,7 @@ unlock_out:
+@@ -803,7 +803,7 @@ unlock_out:
                clk_core_disable_unprepare(core->parent);
  }
  
index aa5bfe7d066272e499c57fe7a4ed338e4f7e33b6..702e1158f11bb5c9f5adc7189bf0e15e8283dc36 100644 (file)
@@ -57,7 +57,7 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
  #define PCIE_CORE_LINK_CTRL_STAT_REG                          0xd0
  #define     PCIE_CORE_LINK_L0S_ENTRY                          BIT(0)
  #define     PCIE_CORE_LINK_TRAINING                           BIT(5)
-@@ -298,7 +300,8 @@ static void advk_pcie_setup_hw(struct ad
+@@ -299,7 +301,8 @@ static void advk_pcie_setup_hw(struct ad
  
        /* Set PCIe Device Control and Status 1 PF0 register */
        reg = PCIE_CORE_DEV_CTRL_STATS_RELAX_ORDER_DISABLE |
@@ -67,7 +67,7 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
                PCIE_CORE_DEV_CTRL_STATS_SNOOP_DISABLE |
                (PCIE_CORE_DEV_CTRL_STATS_MAX_RD_REQ_SZ <<
                 PCIE_CORE_DEV_CTRL_STATS_MAX_RD_REQ_SIZE_SHIFT);
-@@ -913,6 +916,58 @@ out_release_res:
+@@ -922,6 +925,58 @@ out_release_res:
        return err;
  }
  
@@ -126,7 +126,7 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
  static int advk_pcie_probe(struct platform_device *pdev)
  {
        struct device *dev = &pdev->dev;
-@@ -987,6 +1042,9 @@ static int advk_pcie_probe(struct platfo
+@@ -996,6 +1051,9 @@ static int advk_pcie_probe(struct platfo
        list_for_each_entry(child, &bus->children, node)
                pcie_bus_configure_settings(child);
  
index d9ebf2e498edce762d73c820585b107e8fb0aff1..b5d694102407044f869d93e8a252d54b857ce1bc 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
 
 --- a/drivers/pci/host/pci-aardvark.c
 +++ b/drivers/pci/host/pci-aardvark.c
-@@ -273,6 +273,8 @@ static void advk_pcie_set_ob_win(struct
+@@ -274,6 +274,8 @@ static void advk_pcie_set_ob_win(struct
  
  static void advk_pcie_setup_hw(struct advk_pcie *pcie)
  {
@@ -23,7 +23,7 @@ Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
        u32 reg;
        int i;
  
-@@ -312,10 +314,15 @@ static void advk_pcie_setup_hw(struct ad
+@@ -313,10 +315,15 @@ static void advk_pcie_setup_hw(struct ad
                PCIE_CORE_CTRL2_TD_ENABLE;
        advk_writel(pcie, reg, PCIE_CORE_CTRL2_REG);
  
index 49e96d1e9552c5fb4ae08b4052a4f6ff1fdbfb78..18ef42f30a1d3e3ab762f1b7587f2211ebe026b3 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/crypto/mxs-dcp.c
 +++ b/drivers/crypto/mxs-dcp.c
-@@ -831,6 +831,24 @@ static void dcp_sha_cra_exit(struct cryp
+@@ -838,6 +838,24 @@ static void dcp_sha_cra_exit(struct cryp
  {
  }
  
@@ -25,7 +25,7 @@
  /* AES 128 ECB and AES 128 CBC */
  static struct crypto_alg dcp_aes_algs[] = {
        {
-@@ -890,8 +908,11 @@ static struct ahash_alg dcp_sha1_alg = {
+@@ -897,8 +915,11 @@ static struct ahash_alg dcp_sha1_alg = {
        .final  = dcp_sha_final,
        .finup  = dcp_sha_finup,
        .digest = dcp_sha_digest,
@@ -37,7 +37,7 @@
                .base           = {
                        .cra_name               = "sha1",
                        .cra_driver_name        = "sha1-dcp",
-@@ -914,8 +935,11 @@ static struct ahash_alg dcp_sha256_alg =
+@@ -921,8 +942,11 @@ static struct ahash_alg dcp_sha256_alg =
        .final  = dcp_sha_final,
        .finup  = dcp_sha_finup,
        .digest = dcp_sha_digest,
index d5c425b877486879fd16662978a6b6a3ced48043..a8b0f967f06ac1941ee71f146fbc7df0e8b6f8af 100644 (file)
@@ -15,7 +15,7 @@
        /* initialize internal qc */
  
        /* XXX: Tag 0 is used for drivers with legacy EH as some
-@@ -5132,6 +5140,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -5136,6 +5144,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
        if (unlikely(ap->pflags & ATA_PFLAG_FROZEN))
                return NULL;
  
@@ -25,7 +25,7 @@
        /* libsas case */
        if (ap->flags & ATA_FLAG_SAS_HOST) {
                tag = ata_sas_allocate_tag(ap);
-@@ -5177,6 +5188,8 @@ void ata_qc_free(struct ata_queued_cmd *
+@@ -5181,6 +5192,8 @@ void ata_qc_free(struct ata_queued_cmd *
                qc->tag = ATA_TAG_POISON;
                if (ap->flags & ATA_FLAG_SAS_HOST)
                        ata_sas_free_tag(tag, ap);
index 742b6d6ad555481bcc82a38f0f0507dd40c3d583..d6f11ac9359c8265d4828b432a03ff51c2351159 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/x86/kernel/reboot.c
 +++ b/arch/x86/kernel/reboot.c
-@@ -486,6 +486,16 @@ static const struct dmi_system_id reboot
+@@ -487,6 +487,16 @@ static const struct dmi_system_id reboot
                },
        },