kernel: bump 4.14 to 4.14.273
authorPetr Štetiar <ynezz@true.cz>
Thu, 24 Mar 2022 09:48:59 +0000 (10:48 +0100)
committerPetr Štetiar <ynezz@true.cz>
Thu, 24 Mar 2022 09:48:59 +0000 (10:48 +0100)
All patches refreshed automagically without conflicts.

Run tested on ipq40xx/glinet-b1300 and mvebu/turris-omnia.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/kernel-version.mk
target/linux/ar71xx/patches-4.14/310-lib-add-rle-decompression.patch
target/linux/generic/hack-4.14/251-sound_kconfig.patch
target/linux/generic/pending-4.14/530-jffs2_make_lzma_available.patch
target/linux/generic/pending-4.14/630-packet_socket_type.patch

index 931838a05716762693fe876d043c53e9446eb261..73bbcbb04e032143f611854530948855c52dd266 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .272
+LINUX_VERSION-4.14 = .273
 
-LINUX_KERNEL_HASH-4.14.272 = 9b6178099cf33c534c971f3f065c0debe92788f0f504d54badb2f8c2ee089d69
+LINUX_KERNEL_HASH-4.14.273 = 1bfd1b320a7167cf6cf0a8a1e9f7f1e5932b997c9041507c5aaff80b8dacbc2d
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 727f4d8343e01ab7fa229568dcbf33d09d45e90b..b073e822beb524b6330d1934c3779968ba2c8f8e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/lib/Kconfig
 +++ b/lib/Kconfig
-@@ -265,6 +265,9 @@ config LZMA_COMPRESS
+@@ -264,6 +264,9 @@ config LZMA_COMPRESS
  config LZMA_DECOMPRESS
      tristate
  
index 5bf5c01ad3acd5e972ab1c3fa4ab67090ac5f26c..883adbdc5ca1781cc2193d60a7669d326f79d283 100644 (file)
@@ -92,7 +92,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
        bool
 --- a/lib/Kconfig
 +++ b/lib/Kconfig
-@@ -358,16 +358,16 @@ config BCH_CONST_T
+@@ -357,16 +357,16 @@ config BCH_CONST_T
  # Textsearch support is select'ed if needed
  #
  config TEXTSEARCH
index e74a6a11ed6b528d3c542fd0d62969401cac22e5..96a07754a28b81f6f2f8bb68d16e0e5b0f5dd58a 100644 (file)
@@ -1087,7 +1087,7 @@ Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
  #define JFFS2_NODE_ACCURATE 0x2000
 --- a/lib/Kconfig
 +++ b/lib/Kconfig
-@@ -259,6 +259,12 @@ config ZSTD_DECOMPRESS
+@@ -258,6 +258,12 @@ config ZSTD_DECOMPRESS
  
  source "lib/xz/Kconfig"
  
index 3b7b25c75ff93e0839e4ca40c43d08d45d6ed827..98b20a82466c73d00d640789cc5750ee6deffb07 100644 (file)
@@ -87,7 +87,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -3329,6 +3331,7 @@ static int packet_create(struct net *net
+@@ -3332,6 +3334,7 @@ static int packet_create(struct net *net
        mutex_init(&po->pg_vec_lock);
        po->rollover = NULL;
        po->prot_hook.func = packet_rcv;
@@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -3955,6 +3958,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3964,6 +3967,16 @@ packet_setsockopt(struct socket *sock, i
                po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
                return 0;
        }
@@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        default:
                return -ENOPROTOOPT;
        }
-@@ -4007,6 +4020,13 @@ static int packet_getsockopt(struct sock
+@@ -4016,6 +4029,13 @@ static int packet_getsockopt(struct sock
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;