ipq40xx: add support for 8devices Habanero DVK
authorRobert Marko <robimarko@gmail.com>
Sun, 8 Mar 2020 16:21:27 +0000 (17:21 +0100)
committerPetr Štetiar <ynezz@true.cz>
Sun, 8 Mar 2020 23:53:50 +0000 (00:53 +0100)
This patch adds support for the 8devices Habanero development board.

Specs are:
CPU: QCA IPQ4019
RAM: DDR3L 512MB
Storage: 32MB SPI-NOR and optional Parallel SLC NAND(Some boards ship with it and some without)
WLAN1: 2.4 GHz built into IPQ4019 (802.11n) 2x2
WLAN2: 5 GHz built into IPO4019 (802.11ac Wawe-2) 2x2
Ethernet: 5x Gbit LAN (QCA 8075)
USB: 1x USB 2.0 and 1x USB 3.0 (Both built into IPQ4019)
MicroSD slot (Uses SD controller built into IPQ4019)
SDIO3.0/EMMC slot (Uses the same SD controller)
Mini PCI-E Gen 2.0 slot (Built into IPQ4019)
5x LEDs (4 GPIO controllable)
2x Pushbutton (1 is connected to GPIO, other to SoC reset)
LCD ZIF socket (Uses the LCD controller built into IPQ4019 which has no driver support)
1x UART 115200 rate on J18

2x breakout development headers
12V DC Jack for power
DIP switch for bootstrap configuration

Installation instructions:
Since boards ship with vendors fork of OpenWrt sysupgrade can be used.

Signed-off-by: Robert Marko <robimarko@gmail.com>
package/firmware/ipq-wifi/Makefile
package/firmware/ipq-wifi/board-8dev_habanero-dvk.qca4019 [new file with mode: 0644]
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ipq40xx/files-4.19/arch/arm/boot/dts/qcom-ipq4019-habanero-dvk.dts [new file with mode: 0644]
target/linux/ipq40xx/files-5.4/arch/arm/boot/dts/qcom-ipq4019-habanero-dvk.dts [new file with mode: 0644]
target/linux/ipq40xx/image/Makefile
target/linux/ipq40xx/patches-4.19/087-v5.6-mtd-spi-nor-Add-4B_OPCODES-flag-to-w25q256.patch [new file with mode: 0644]
target/linux/ipq40xx/patches-4.19/901-arm-boot-add-dts-files.patch
target/linux/ipq40xx/patches-5.4/901-arm-boot-add-dts-files.patch

index fc1b10343e2fa44598b3bf669c48a0c94aed4a35..12e000bac8aef8e23e70cc20b6e45997e26625e9 100644 (file)
@@ -25,6 +25,7 @@ endef
 # <https://wireless.wiki.kernel.org/en/users/drivers/ath10k/boardfiles>
 
 ALLWIFIBOARDS:= \
+       8dev_habanero-dvk \
        aruba_ap-303 \
        avm_fritzrepeater-1200 \
        dlink_dap2610 \
@@ -93,6 +94,7 @@ endef
 # Place files in this directory as board-<devicename>.<qca4019|qca9888|qca9984>
 # Add $(eval $(call generate-ipq-wifi-package,<devicename>,<display name>))
 
+$(eval $(call generate-ipq-wifi-package,8dev_habanero-dvk,8devices Habanero DVK))
 $(eval $(call generate-ipq-wifi-package,aruba_ap-303,Aruba AP-303))
 $(eval $(call generate-ipq-wifi-package,avm_fritzrepeater-1200,AVM FRITZRepeater 1200))
 $(eval $(call generate-ipq-wifi-package,dlink_dap2610,D-Link DAP-2610))
diff --git a/package/firmware/ipq-wifi/board-8dev_habanero-dvk.qca4019 b/package/firmware/ipq-wifi/board-8dev_habanero-dvk.qca4019
new file mode 100644 (file)
index 0000000..9048239
Binary files /dev/null and b/package/firmware/ipq-wifi/board-8dev_habanero-dvk.qca4019 differ
index fb41572e3723da8faf46de56b0b63478eca608e3..44cb9f9d126c763620276087a4db67a925fdbadd 100755 (executable)
@@ -12,6 +12,7 @@ ipq40xx_setup_interfaces()
        local board="$1"
 
        case "$board" in
+       8dev,habanero-dvk|\
        8dev,jalapeno|\
        alfa-network,ap120c-ac|\
        engenius,ens620ext)
@@ -97,6 +98,9 @@ ipq40xx_setup_macs()
        local label_mac=""
 
        case "$board" in
+       8dev,habanero-dvk)
+               label_mac=$(mtd_get_mac_binary "ART" 0x1006)
+               ;;
        asus,rt-ac58u)
                CI_UBIPART=UBI_DEV
                wan_mac=$(mtd_get_mac_binary_ubi Factory 0x1006)
index 50bfbb0a8644d89c35f86ba2cfdbd058d841d976..c65fa3047431eb6265b10fef21bc08107976daa5 100644 (file)
@@ -44,6 +44,7 @@ case "$FIRMWARE" in
        ;;
 "ath10k/pre-cal-ahb-a000000.wifi.bin")
        case "$board" in
+       8dev,habanero-dvk |\
        8dev,jalapeno |\
        alfa-network,ap120c-ac |\
        cilab,meshpoint-one |\
@@ -124,6 +125,7 @@ case "$FIRMWARE" in
        ;;
 "ath10k/pre-cal-ahb-a800000.wifi.bin")
        case "$board" in
+       8dev,habanero-dvk |\
        8dev,jalapeno |\
        alfa-network,ap120c-ac |\
        cilab,meshpoint-one |\
diff --git a/target/linux/ipq40xx/files-4.19/arch/arm/boot/dts/qcom-ipq4019-habanero-dvk.dts b/target/linux/ipq40xx/files-4.19/arch/arm/boot/dts/qcom-ipq4019-habanero-dvk.dts
new file mode 100644 (file)
index 0000000..8fe7644
--- /dev/null
@@ -0,0 +1,357 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/* Copyright (c) 2019, Robert Marko <robimarko@gmail.com> */
+
+#include "qcom-ipq4019.dtsi"
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/soc/qcom,tcsr.h>
+
+/ {
+       model = "8devices Habanero DVK";
+       compatible = "8dev,habanero-dvk";
+
+       aliases {
+               led-boot = &led_status;
+               led-failsafe = &led_status;
+               led-running = &led_status;
+               led-upgrade = &led_upgrade;
+       };
+
+       soc {
+               rng@22000 {
+                       status = "okay";
+               };
+
+               mdio@90000 {
+                       status = "okay";
+
+                       pinctrl-0 = <&mdio_pins>;
+                       pinctrl-names = "default";
+               };
+
+               ess-psgmii@98000 {
+                       status = "okay";
+               };
+
+               counter@4a1000 {
+                       compatible = "qcom,qca-gcnt";
+                       reg = <0x4a1000 0x4>;
+               };
+
+               tcsr@1949000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1949000 0x100>;
+                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
+               };
+
+               tcsr@194b000 {
+                       status = "okay";
+
+                       compatible = "qcom,tcsr";
+                       reg = <0x194b000 0x100>;
+                       qcom,usb-hsphy-mode-select = <TCSR_USB_HSPHY_HOST_MODE>;
+               };
+
+               ess_tcsr@1953000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1953000 0x1000>;
+                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
+               };
+
+               tcsr@1957000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1957000 0x100>;
+                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
+               };
+
+               usb2: usb2@60f8800 {
+                       status = "okay";
+               };
+
+               usb3: usb3@8af8800 {
+                       status = "okay";
+               };
+
+               crypto@8e3a000 {
+                       status = "okay";
+               };
+
+               watchdog@b017000 {
+                       status = "okay";
+               };
+
+               ess-switch@c000000 {
+                       status = "okay";
+               };
+
+               edma@c080000 {
+                       status = "okay";
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&tlmm 8 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_status: status {
+                       label = "habanero-dvk:green:status";
+                       gpios = <&tlmm 37 GPIO_ACTIVE_HIGH>;
+                       panic-indicator;
+               };
+
+               led_upgrade: upgrade {
+                       label = "habanero-dvk:green:upgrade";
+                       gpios = <&tlmm 40 GPIO_ACTIVE_HIGH>;
+               };
+
+               wlan2g {
+                       label = "habanero-dvk:green:wlan2g";
+                       gpios = <&tlmm 46 GPIO_ACTIVE_HIGH>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               wlan5g {
+                       label = "habanero-dvk:green:wlan5g";
+                       gpios = <&tlmm 48 GPIO_ACTIVE_HIGH>;
+                       linux,default-trigger = "phy1tpt";
+               };
+       };
+};
+
+&vqmmc {
+       status = "okay";
+};
+
+&sdhci {
+       status = "okay";
+
+       pinctrl-0 = <&sd_pins>;
+       pinctrl-names = "default";
+       cd-gpios = <&tlmm 22 GPIO_ACTIVE_LOW>;
+       vqmmc-supply = <&vqmmc>;
+};
+
+&qpic_bam {
+       status = "okay";
+};
+
+&tlmm {
+       mdio_pins: mdio_pinmux {
+               mux_1 {
+                       pins = "gpio6";
+                       function = "mdio";
+                       bias-pull-up;
+               };
+
+               mux_2 {
+                       pins = "gpio7";
+                       function = "mdc";
+                       bias-pull-up;
+               };
+       };
+
+       serial_pins: serial_pinmux {
+               mux {
+                       pins = "gpio16", "gpio17";
+                       function = "blsp_uart0";
+                       bias-disable;
+               };
+       };
+
+       spi_0_pins: spi_0_pinmux {
+               pinmux {
+                       function = "blsp_spi0";
+                       pins = "gpio13", "gpio14", "gpio15";
+                       drive-strength = <12>;
+                       bias-disable;
+               };
+
+               pinmux_cs {
+                       function = "gpio";
+                       pins = "gpio12";
+                       drive-strength = <2>;
+                       bias-disable;
+                       output-high;
+               };
+       };
+
+       nand_pins: nand_pins {
+               pullups {
+                       pins =  "gpio52", "gpio53", "gpio58", "gpio59";
+                       function = "qpic";
+                       bias-pull-up;
+               };
+
+               pulldowns {
+                       pins = "gpio54", "gpio55", "gpio56", "gpio57",
+                               "gpio60", "gpio62", "gpio63", "gpio64",
+                               "gpio65", "gpio66", "gpio67", "gpio68",
+                               "gpio69";
+                       function = "qpic";
+                       bias-pull-down;
+               };
+       };
+
+       sd_pins: sd_pins {
+               pinmux {
+                       function = "sdio";
+                       pins = "gpio23", "gpio24", "gpio25", "gpio26",
+                               "gpio28", "gpio29", "gpio30", "gpio31";
+                       drive-strength = <10>;
+               };
+
+               pinmux_sd_clk {
+                       function = "sdio";
+                       pins = "gpio27";
+                       drive-strength = <16>;
+               };
+
+               pinmux_sd7 {
+                       function = "sdio";
+                       pins = "gpio32";
+                       drive-strength = <10>;
+                       bias-disable;
+               };
+       };
+};
+
+&blsp_dma {
+       status = "okay";
+};
+
+&blsp1_spi1 {
+       status = "okay";
+
+       pinctrl-0 = <&spi_0_pins>;
+       pinctrl-names = "default";
+       cs-gpios = <&tlmm 12 GPIO_ACTIVE_HIGH>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               spi-max-frequency = <24000000>;
+               reg = <0>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "SBL1";
+                               reg = <0x00000000 0x00040000>;
+                               read-only;
+                       };
+                       partition@40000 {
+                               label = "MIBIB";
+                               reg = <0x00040000 0x00020000>;
+                               read-only;
+                       };
+                       partition@60000 {
+                               label = "QSEE";
+                               reg = <0x00060000 0x00060000>;
+                               read-only;
+                       };
+                       partition@c0000 {
+                               label = "CDT";
+                               reg = <0x000c0000 0x00010000>;
+                               read-only;
+                       };
+                       partition@d0000 {
+                               label = "DDRPARAMS";
+                               reg = <0x000d0000 0x00010000>;
+                               read-only;
+                       };
+                       partition@e0000 {
+                               label = "APPSBLENV"; /* uboot env */
+                               reg = <0x000e0000 0x00010000>;
+                               read-only;
+                       };
+                       partition@f0000 {
+                               label = "APPSBL"; /* uboot */
+                               reg = <0x000f0000 0x00080000>;
+                               read-only;
+                       };
+                       partition@170000 {
+                               label = "ART";
+                               reg = <0x00170000 0x00010000>;
+                               read-only;
+                       };
+                       partition@180000 {
+                               label = "cfg";
+                               reg = <0x00180000 0x00040000>;
+                       };
+                       partition@1c0000 {
+                               label = "firmware";
+                               compatible = "denx,fit";
+                               reg = <0x001c0000 0x01e40000>;
+                       };
+               };
+       };
+};
+
+/* Some DVK boards ship without NAND */
+&nand {
+       status = "okay";
+
+       pinctrl-0 = <&nand_pins>;
+       pinctrl-names = "default";
+};
+
+&blsp1_uart1 {
+       status = "okay";
+
+       pinctrl-0 = <&serial_pins>;
+       pinctrl-names = "default";
+};
+
+&cryptobam {
+       status = "okay";
+};
+
+&pcie0 {
+       status = "okay";
+
+       perst-gpio = <&tlmm 38 GPIO_ACTIVE_LOW>;
+       wake-gpio = <&tlmm 50 GPIO_ACTIVE_LOW>;
+
+       /* Free slot for use */
+       bridge@0,0 {
+               reg = <0x00000000 0 0 0 0>;
+               #address-cells = <3>;
+               #size-cells = <2>;
+               ranges;
+       };
+};
+
+&wifi0 {
+       status = "okay";
+
+       qcom,ath10k-calibration-variant = "8devices-Habanero";
+};
+
+&wifi1 {
+       status = "okay";
+
+       qcom,ath10k-calibration-variant = "8devices-Habanero";
+};
+
+&usb3_ss_phy {
+       status = "okay";
+};
+
+&usb3_hs_phy {
+       status = "okay";
+};
+
+&usb2_hs_phy {
+       status = "okay";
+};
diff --git a/target/linux/ipq40xx/files-5.4/arch/arm/boot/dts/qcom-ipq4019-habanero-dvk.dts b/target/linux/ipq40xx/files-5.4/arch/arm/boot/dts/qcom-ipq4019-habanero-dvk.dts
new file mode 100644 (file)
index 0000000..8fe7644
--- /dev/null
@@ -0,0 +1,357 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/* Copyright (c) 2019, Robert Marko <robimarko@gmail.com> */
+
+#include "qcom-ipq4019.dtsi"
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/soc/qcom,tcsr.h>
+
+/ {
+       model = "8devices Habanero DVK";
+       compatible = "8dev,habanero-dvk";
+
+       aliases {
+               led-boot = &led_status;
+               led-failsafe = &led_status;
+               led-running = &led_status;
+               led-upgrade = &led_upgrade;
+       };
+
+       soc {
+               rng@22000 {
+                       status = "okay";
+               };
+
+               mdio@90000 {
+                       status = "okay";
+
+                       pinctrl-0 = <&mdio_pins>;
+                       pinctrl-names = "default";
+               };
+
+               ess-psgmii@98000 {
+                       status = "okay";
+               };
+
+               counter@4a1000 {
+                       compatible = "qcom,qca-gcnt";
+                       reg = <0x4a1000 0x4>;
+               };
+
+               tcsr@1949000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1949000 0x100>;
+                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
+               };
+
+               tcsr@194b000 {
+                       status = "okay";
+
+                       compatible = "qcom,tcsr";
+                       reg = <0x194b000 0x100>;
+                       qcom,usb-hsphy-mode-select = <TCSR_USB_HSPHY_HOST_MODE>;
+               };
+
+               ess_tcsr@1953000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1953000 0x1000>;
+                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
+               };
+
+               tcsr@1957000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1957000 0x100>;
+                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
+               };
+
+               usb2: usb2@60f8800 {
+                       status = "okay";
+               };
+
+               usb3: usb3@8af8800 {
+                       status = "okay";
+               };
+
+               crypto@8e3a000 {
+                       status = "okay";
+               };
+
+               watchdog@b017000 {
+                       status = "okay";
+               };
+
+               ess-switch@c000000 {
+                       status = "okay";
+               };
+
+               edma@c080000 {
+                       status = "okay";
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&tlmm 8 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_status: status {
+                       label = "habanero-dvk:green:status";
+                       gpios = <&tlmm 37 GPIO_ACTIVE_HIGH>;
+                       panic-indicator;
+               };
+
+               led_upgrade: upgrade {
+                       label = "habanero-dvk:green:upgrade";
+                       gpios = <&tlmm 40 GPIO_ACTIVE_HIGH>;
+               };
+
+               wlan2g {
+                       label = "habanero-dvk:green:wlan2g";
+                       gpios = <&tlmm 46 GPIO_ACTIVE_HIGH>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               wlan5g {
+                       label = "habanero-dvk:green:wlan5g";
+                       gpios = <&tlmm 48 GPIO_ACTIVE_HIGH>;
+                       linux,default-trigger = "phy1tpt";
+               };
+       };
+};
+
+&vqmmc {
+       status = "okay";
+};
+
+&sdhci {
+       status = "okay";
+
+       pinctrl-0 = <&sd_pins>;
+       pinctrl-names = "default";
+       cd-gpios = <&tlmm 22 GPIO_ACTIVE_LOW>;
+       vqmmc-supply = <&vqmmc>;
+};
+
+&qpic_bam {
+       status = "okay";
+};
+
+&tlmm {
+       mdio_pins: mdio_pinmux {
+               mux_1 {
+                       pins = "gpio6";
+                       function = "mdio";
+                       bias-pull-up;
+               };
+
+               mux_2 {
+                       pins = "gpio7";
+                       function = "mdc";
+                       bias-pull-up;
+               };
+       };
+
+       serial_pins: serial_pinmux {
+               mux {
+                       pins = "gpio16", "gpio17";
+                       function = "blsp_uart0";
+                       bias-disable;
+               };
+       };
+
+       spi_0_pins: spi_0_pinmux {
+               pinmux {
+                       function = "blsp_spi0";
+                       pins = "gpio13", "gpio14", "gpio15";
+                       drive-strength = <12>;
+                       bias-disable;
+               };
+
+               pinmux_cs {
+                       function = "gpio";
+                       pins = "gpio12";
+                       drive-strength = <2>;
+                       bias-disable;
+                       output-high;
+               };
+       };
+
+       nand_pins: nand_pins {
+               pullups {
+                       pins =  "gpio52", "gpio53", "gpio58", "gpio59";
+                       function = "qpic";
+                       bias-pull-up;
+               };
+
+               pulldowns {
+                       pins = "gpio54", "gpio55", "gpio56", "gpio57",
+                               "gpio60", "gpio62", "gpio63", "gpio64",
+                               "gpio65", "gpio66", "gpio67", "gpio68",
+                               "gpio69";
+                       function = "qpic";
+                       bias-pull-down;
+               };
+       };
+
+       sd_pins: sd_pins {
+               pinmux {
+                       function = "sdio";
+                       pins = "gpio23", "gpio24", "gpio25", "gpio26",
+                               "gpio28", "gpio29", "gpio30", "gpio31";
+                       drive-strength = <10>;
+               };
+
+               pinmux_sd_clk {
+                       function = "sdio";
+                       pins = "gpio27";
+                       drive-strength = <16>;
+               };
+
+               pinmux_sd7 {
+                       function = "sdio";
+                       pins = "gpio32";
+                       drive-strength = <10>;
+                       bias-disable;
+               };
+       };
+};
+
+&blsp_dma {
+       status = "okay";
+};
+
+&blsp1_spi1 {
+       status = "okay";
+
+       pinctrl-0 = <&spi_0_pins>;
+       pinctrl-names = "default";
+       cs-gpios = <&tlmm 12 GPIO_ACTIVE_HIGH>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               spi-max-frequency = <24000000>;
+               reg = <0>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "SBL1";
+                               reg = <0x00000000 0x00040000>;
+                               read-only;
+                       };
+                       partition@40000 {
+                               label = "MIBIB";
+                               reg = <0x00040000 0x00020000>;
+                               read-only;
+                       };
+                       partition@60000 {
+                               label = "QSEE";
+                               reg = <0x00060000 0x00060000>;
+                               read-only;
+                       };
+                       partition@c0000 {
+                               label = "CDT";
+                               reg = <0x000c0000 0x00010000>;
+                               read-only;
+                       };
+                       partition@d0000 {
+                               label = "DDRPARAMS";
+                               reg = <0x000d0000 0x00010000>;
+                               read-only;
+                       };
+                       partition@e0000 {
+                               label = "APPSBLENV"; /* uboot env */
+                               reg = <0x000e0000 0x00010000>;
+                               read-only;
+                       };
+                       partition@f0000 {
+                               label = "APPSBL"; /* uboot */
+                               reg = <0x000f0000 0x00080000>;
+                               read-only;
+                       };
+                       partition@170000 {
+                               label = "ART";
+                               reg = <0x00170000 0x00010000>;
+                               read-only;
+                       };
+                       partition@180000 {
+                               label = "cfg";
+                               reg = <0x00180000 0x00040000>;
+                       };
+                       partition@1c0000 {
+                               label = "firmware";
+                               compatible = "denx,fit";
+                               reg = <0x001c0000 0x01e40000>;
+                       };
+               };
+       };
+};
+
+/* Some DVK boards ship without NAND */
+&nand {
+       status = "okay";
+
+       pinctrl-0 = <&nand_pins>;
+       pinctrl-names = "default";
+};
+
+&blsp1_uart1 {
+       status = "okay";
+
+       pinctrl-0 = <&serial_pins>;
+       pinctrl-names = "default";
+};
+
+&cryptobam {
+       status = "okay";
+};
+
+&pcie0 {
+       status = "okay";
+
+       perst-gpio = <&tlmm 38 GPIO_ACTIVE_LOW>;
+       wake-gpio = <&tlmm 50 GPIO_ACTIVE_LOW>;
+
+       /* Free slot for use */
+       bridge@0,0 {
+               reg = <0x00000000 0 0 0 0>;
+               #address-cells = <3>;
+               #size-cells = <2>;
+               ranges;
+       };
+};
+
+&wifi0 {
+       status = "okay";
+
+       qcom,ath10k-calibration-variant = "8devices-Habanero";
+};
+
+&wifi1 {
+       status = "okay";
+
+       qcom,ath10k-calibration-variant = "8devices-Habanero";
+};
+
+&usb3_ss_phy {
+       status = "okay";
+};
+
+&usb3_hs_phy {
+       status = "okay";
+};
+
+&usb2_hs_phy {
+       status = "okay";
+};
index 9ddcd17f1d1dda5111ed95fe08062afcd2e61817..8097bf439aeb5195f63c84d9eea8361abbda08fe 100644 (file)
@@ -71,6 +71,18 @@ define Build/wrgg-image
        mv $@.new $@
 endef
 
+define Device/8dev_habanero-dvk
+       $(call Device/FitImageLzma)
+       DEVICE_VENDOR := 8devices
+       DEVICE_MODEL := Habanero DVK
+       IMAGE_SIZE := 30976k
+       SOC := qcom-ipq4019
+       DEVICE_PACKAGES := ipq-wifi-8dev_habanero-dvk
+       IMAGES := sysupgrade.bin
+       IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += 8dev_habanero-dvk
+
 define Device/8dev_jalapeno-common
        $(call Device/FitImage)
        $(call Device/UbiFit)
diff --git a/target/linux/ipq40xx/patches-4.19/087-v5.6-mtd-spi-nor-Add-4B_OPCODES-flag-to-w25q256.patch b/target/linux/ipq40xx/patches-4.19/087-v5.6-mtd-spi-nor-Add-4B_OPCODES-flag-to-w25q256.patch
new file mode 100644 (file)
index 0000000..03fae84
--- /dev/null
@@ -0,0 +1,27 @@
+From 10050a02f7d508fa88f70fcfceefbacd13488ca7 Mon Sep 17 00:00:00 2001
+From: Robert Marko <robimarko@gmail.com>
+Date: Mon, 23 Dec 2019 17:05:49 +0200
+Subject: [PATCH] mtd: spi-nor: Add 4B_OPCODES flag to w25q256
+
+The w25q256 supports 4-byte opcodes so lets add the flag.
+Tested on OpenWrt under 4.19.82 kernel on 8devices Habanero.
+
+Signed-off-by: Robert Marko <robimarko@gmail.com>
+Signed-off-by: Tudor Ambarus <tudor.ambarus@microchip.com>
+---
+ drivers/mtd/spi-nor/spi-nor.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+--- a/drivers/mtd/spi-nor/spi-nor.c
++++ b/drivers/mtd/spi-nor/spi-nor.c
+@@ -1252,7 +1252,9 @@ static const struct flash_info spi_nor_i
+       { "w25q80", INFO(0xef5014, 0, 64 * 1024,  16, SECT_4K) },
+       { "w25q80bl", INFO(0xef4014, 0, 64 * 1024,  16, SECT_4K) },
+       { "w25q128", INFO(0xef4018, 0, 64 * 1024, 256, SECT_4K) },
+-      { "w25q256", INFO(0xef4019, 0, 64 * 1024, 512, SECT_4K | SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ) },
++      { "w25q256", INFO(0xef4019, 0, 64 * 1024, 512,
++                        SECT_4K | SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ |
++                        SPI_NOR_4B_OPCODES) },
+       { "w25m512jv", INFO(0xef7119, 0, 64 * 1024, 1024,
+                       SECT_4K | SPI_NOR_QUAD_READ | SPI_NOR_DUAL_READ) },
index 89e665db23b19ad881305c3982f351f19bcba385..81e33b15a9d5fa01c1c8f4ead959dac2d89d9b31 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -785,11 +785,43 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -785,11 +785,44 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-apq8074-dragonboard.dtb \
        qcom-apq8084-ifc6540.dtb \
        qcom-apq8084-mtp.dtb \
@@ -41,6 +41,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 +      qcom-ipq4019-fritzrepeater-1200.dtb \
 +      qcom-ipq4019-fritzrepeater-3000.dtb \
 +      qcom-ipq4019-ea8300.dtb \
++      qcom-ipq4019-habanero-dvk.dtb \
 +      qcom-ipq4019-map-ac2200.dtb \
 +      qcom-ipq4019-e2600ac-c1.dtb \
 +      qcom-ipq4019-e2600ac-c2.dtb \
index d49c03c1d01ad43271051c66e25f7dae56c8c8d8..a63f0da85d0470311c72c9675c9f64db6141a0a2 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -837,11 +837,43 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -837,11 +837,44 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-apq8074-dragonboard.dtb \
        qcom-apq8084-ifc6540.dtb \
        qcom-apq8084-mtp.dtb \
@@ -44,6 +44,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 +      qcom-ipq4019-map-ac2200.dtb \
 +      qcom-ipq4019-e2600ac-c1.dtb \
 +      qcom-ipq4019-e2600ac-c2.dtb \
++      qcom-ipq4019-habanero-dvk.dtb \
 +      qcom-ipq4019-u4019-32m.dtb \
 +      qcom-ipq4019-wpj419.dtb \
 +      qcom-ipq4028-wpj428.dtb \