toolchain: glibc: Enable --enable-bind-now
authorHauke Mehrtens <hauke@hauke-m.de>
Tue, 28 Dec 2021 20:37:21 +0000 (21:37 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 7 Jan 2022 21:30:40 +0000 (22:30 +0100)
Enable --enable-bind-now when CONFIG_PKG_RELRO_FULL is set. This option
is activated by default. This will enable full RELRO protection.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
toolchain/glibc/common.mk

index 19610c1e904e8b983dfd51d82f8619021d51dcd8..e957ff52e509a59036560de01787e6f0eec33d54 100644 (file)
@@ -63,6 +63,7 @@ GLIBC_CONFIGURE:= \
                --$(if $(CONFIG_SOFT_FLOAT),without,with)-fp \
                  $(if $(CONFIG_PKG_CC_STACKPROTECTOR_REGULAR),--enable-stack-protector=yes) \
                  $(if $(CONFIG_PKG_CC_STACKPROTECTOR_STRONG),--enable-stack-protector=strong) \
+                 $(if $(CONFIG_PKG_RELRO_FULL),--enable-bind-now) \
                --enable-kernel=5.4.0
 
 export libc_cv_ssp=no