kernel: bump 5.10 to 5.10.89
authorRui Salvaterra <rsalvaterra@gmail.com>
Wed, 29 Dec 2021 13:13:29 +0000 (13:13 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 3 Jan 2022 00:00:03 +0000 (01:00 +0100)
Deleted (upstreamed):
bcm27xx/patches-5.10/950-0186-pinctrl-bcm2835-Change-init-order-for-gpio-hogs.patch [1]
sunxi/patches-5.10/103-arm64-dts-allwinner-orangepi-zero-plus-fix-PHY-mo.patch [2]

[1] https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.10.89&id=ba696b470839d70c6b8290c1f798bac7fb2a584c
[2] https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.10.89&id=93a957bbf46ceb224b959de61fe85cfc6f71b6c7

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
13 files changed:
include/kernel-version.mk
target/linux/bcm27xx/patches-5.10/950-0030-lan78xx-Enable-LEDs-and-auto-negotiation.patch
target/linux/bcm27xx/patches-5.10/950-0076-lan78xx-Read-initial-EEE-status-from-DT.patch
target/linux/bcm27xx/patches-5.10/950-0082-net-lan78xx-Disable-TCP-Segmentation-Offload-TSO.patch
target/linux/bcm27xx/patches-5.10/950-0083-lan78xx-Move-enabling-of-EEE-into-PHY-init-code.patch
target/linux/bcm27xx/patches-5.10/950-0094-lan78xx-Debounce-link-events-to-minimize-poll-storm.patch
target/linux/bcm27xx/patches-5.10/950-0095-lan78xx-EEE-support-is-now-a-PHY-property.patch
target/linux/bcm27xx/patches-5.10/950-0098-lan78xx-use-default-alignment-for-rx-buffers.patch
target/linux/bcm27xx/patches-5.10/950-0185-pinctrl-bcm2835-Remove-gpiochip-on-error.patch
target/linux/bcm27xx/patches-5.10/950-0186-pinctrl-bcm2835-Change-init-order-for-gpio-hogs.patch [deleted file]
target/linux/bcm27xx/patches-5.10/950-0401-net-lan78xx-Ack-pending-PHY-ints-when-resetting.patch
target/linux/generic/backport-5.10/732-net-next-1-of-net-pass-the-dst-buffer-to-of_get_mac_address.patch
target/linux/sunxi/patches-5.10/103-arm64-dts-allwinner-orangepi-zero-plus-fix-PHY-mo.patch [deleted file]

index 456aaf7dba791a77810505cb4f594828eb2e2593..9cd2b77e16d5673b1497e82389c64ddb46465bf5 100644 (file)
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-5.4 = .169
-LINUX_VERSION-5.10 = .88
+LINUX_VERSION-5.10 = .89
 
 LINUX_KERNEL_HASH-5.4.169 = 554382d95f71afd5f9b49292eb5d1cbe3be1a0bad22d21487c9e6d506ee01a19
-LINUX_KERNEL_HASH-5.10.88 = 6f8631b6c382a2b0cfeff1e5f8805c8e1cfbe8d714b6e65f5bb79733c99068eb
+LINUX_KERNEL_HASH-5.10.89 = 92218b1a4a18f1cb9ec07d2b7fce41577452aa552c54c25b6d5fe9b4b543bb30
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 893461975bbc3af3bf68c3c9d31a00645fcc8187..9d03b49ab2135b6ddd9f267739b383350ffcff36 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2461,6 +2461,11 @@ static int lan78xx_reset(struct lan78xx_
+@@ -2463,6 +2463,11 @@ static int lan78xx_reset(struct lan78xx_
        int ret = 0;
        unsigned long timeout;
        u8 sig;
@@ -26,7 +26,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  
        ret = lan78xx_read_reg(dev, HW_CFG, &buf);
        buf |= HW_CFG_LRST_;
-@@ -2514,6 +2519,9 @@ static int lan78xx_reset(struct lan78xx_
+@@ -2516,6 +2521,9 @@ static int lan78xx_reset(struct lan78xx_
  
        ret = lan78xx_read_reg(dev, HW_CFG, &buf);
        buf |= HW_CFG_MEF_;
@@ -36,7 +36,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        ret = lan78xx_write_reg(dev, HW_CFG, buf);
  
        ret = lan78xx_read_reg(dev, USB_CFG0, &buf);
-@@ -2569,6 +2577,9 @@ static int lan78xx_reset(struct lan78xx_
+@@ -2571,6 +2579,9 @@ static int lan78xx_reset(struct lan78xx_
                        buf |= MAC_CR_AUTO_DUPLEX_ | MAC_CR_AUTO_SPEED_;
                }
        }
index 1670e8f1f05f612a020a0230d78a20ac54c7330a..58dc9997d60ec25278d5ecd497b2a5d1c363fe56 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2643,6 +2643,22 @@ static int lan78xx_open(struct net_devic
+@@ -2645,6 +2645,22 @@ static int lan78xx_open(struct net_devic
  
        netif_dbg(dev, ifup, dev->net, "phy initialised successfully");
  
index 7123c383555ee74f7a8253b8994fc8e28f2cfc5b..919d6b0f83d1f82e1c98ed187b58009af0727506 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -425,6 +425,15 @@ static int msg_level = -1;
+@@ -427,6 +427,15 @@ static int msg_level = -1;
  module_param(msg_level, int, 0);
  MODULE_PARM_DESC(msg_level, "Override default message level");
  
@@ -37,7 +37,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  static int lan78xx_read_reg(struct lan78xx_net *dev, u32 index, u32 *data)
  {
        u32 *buf = kmalloc(sizeof(u32), GFP_KERNEL);
-@@ -2925,8 +2934,14 @@ static int lan78xx_bind(struct lan78xx_n
+@@ -2927,8 +2936,14 @@ static int lan78xx_bind(struct lan78xx_n
        if (DEFAULT_RX_CSUM_ENABLE)
                dev->net->features |= NETIF_F_RXCSUM;
  
index ea7bffa67a516962fec1d70a9c9c55a5e91942d8..4069ab598ca1dfa5978a3375cb7387eceb325241 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2175,6 +2175,22 @@ static int lan78xx_phy_init(struct lan78
+@@ -2177,6 +2177,22 @@ static int lan78xx_phy_init(struct lan78
        mii_adv_to_linkmode_adv_t(fc, mii_adv);
        linkmode_or(phydev->advertising, fc, phydev->advertising);
  
@@ -39,7 +39,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        if (phydev->mdio.dev.of_node) {
                u32 reg;
                int len;
-@@ -2652,22 +2668,6 @@ static int lan78xx_open(struct net_devic
+@@ -2654,22 +2670,6 @@ static int lan78xx_open(struct net_devic
  
        netif_dbg(dev, ifup, dev->net, "phy initialised successfully");
  
index a4fa444f9a43fc938646f0a6c4cc45d1c9c48e3d..d91488075b097e01e6295b3b478c6d11c46d1612 100644 (file)
@@ -16,7 +16,7 @@ See: https://github.com/raspberrypi/linux/issues/2447
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -434,6 +434,11 @@ static bool enable_tso;
+@@ -436,6 +436,11 @@ static bool enable_tso;
  module_param(enable_tso, bool, 0644);
  MODULE_PARM_DESC(enable_tso, "Enables TCP segmentation offload");
  
@@ -28,7 +28,7 @@ See: https://github.com/raspberrypi/linux/issues/2447
  static int lan78xx_read_reg(struct lan78xx_net *dev, u32 index, u32 *data)
  {
        u32 *buf = kmalloc(sizeof(u32), GFP_KERNEL);
-@@ -3768,7 +3773,13 @@ static int lan78xx_probe(struct usb_inte
+@@ -3770,7 +3775,13 @@ static int lan78xx_probe(struct usb_inte
        netdev->max_mtu = MAX_SINGLE_PACKET_SIZE;
        netif_set_gso_max_size(netdev, MAX_SINGLE_PACKET_SIZE - MAX_HEADER);
  
index 87bda1b41f7f93a480d29111790d35024cc32da7..e556f46d9f9dc9323a431b5f1392a4b1f4701d36 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -2180,7 +2180,7 @@ static int lan78xx_phy_init(struct lan78
+@@ -2182,7 +2182,7 @@ static int lan78xx_phy_init(struct lan78
        mii_adv_to_linkmode_adv_t(fc, mii_adv);
        linkmode_or(phydev->advertising, fc, phydev->advertising);
  
index e8022aeed557566d1e922278ebe6213dcba5ed55..d7527c3399ed7b40a983b44fee805dd275cf3f12 100644 (file)
@@ -12,7 +12,7 @@ in both dwc_otg and in ipv6 processing.
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -3169,7 +3169,7 @@ static int rx_submit(struct lan78xx_net
+@@ -3171,7 +3171,7 @@ static int rx_submit(struct lan78xx_net
        size_t size = dev->rx_urb_size;
        int ret = 0;
  
index 497c2833258e7926ba9708c59be941288becd866..c08a3f02cd2d426d3adef9bc78249f79d597f92b 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/pinctrl/bcm/pinctrl-bcm2835.c
 +++ b/drivers/pinctrl/bcm/pinctrl-bcm2835.c
-@@ -1300,7 +1300,7 @@ static int bcm2835_pinctrl_probe(struct
+@@ -1314,7 +1314,7 @@ static int bcm2835_pinctrl_probe(struct
        girq->default_type = IRQ_TYPE_NONE;
        girq->handler = handle_level_irq;
  
@@ -22,4 +22,4 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 +      err = devm_gpiochip_add_data(dev, &pc->gpio_chip, pc);
        if (err) {
                dev_err(dev, "could not add GPIO chip\n");
-               return err;
+               pinctrl_remove_gpio_range(pc->pctl_dev, &pc->gpio_range);
diff --git a/target/linux/bcm27xx/patches-5.10/950-0186-pinctrl-bcm2835-Change-init-order-for-gpio-hogs.patch b/target/linux/bcm27xx/patches-5.10/950-0186-pinctrl-bcm2835-Change-init-order-for-gpio-hogs.patch
deleted file mode 100644 (file)
index 2d13736..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-From 069990e0b524a7acdcfef0505913ee20401fec5a Mon Sep 17 00:00:00 2001
-From: Phil Elwell <phil@raspberrypi.org>
-Date: Mon, 6 Jan 2020 14:05:42 +0000
-Subject: [PATCH] pinctrl: bcm2835: Change init order for gpio hogs
-
-pinctrl-bcm2835 is a combined pinctrl/gpio driver. Currently the gpio
-side is registered first, but this breaks gpio hogs (which are
-configured during gpiochip_add_data). Part of the hog initialisation
-is a call to pinctrl_gpio_request, and since the pinctrl driver hasn't
-yet been registered this results in an -EPROBE_DEFER from which it can
-never recover.
-
-Change the initialisation sequence to register the pinctrl driver
-first.
-
-See: https://www.raspberrypi.org/forums/viewtopic.php?f=107&t=260600
-
-Signed-off-by: Phil Elwell <phil@raspberrypi.org>
----
- drivers/pinctrl/bcm/pinctrl-bcm2835.c | 29 +++++++++++++++------------
- 1 file changed, 16 insertions(+), 13 deletions(-)
-
---- a/drivers/pinctrl/bcm/pinctrl-bcm2835.c
-+++ b/drivers/pinctrl/bcm/pinctrl-bcm2835.c
-@@ -1244,6 +1244,18 @@ static int bcm2835_pinctrl_probe(struct
-               raw_spin_lock_init(&pc->irq_lock[i]);
-       }
-+      pc->pctl_desc = *pdata->pctl_desc;
-+      pc->pctl_dev = devm_pinctrl_register(dev, &pc->pctl_desc, pc);
-+      if (IS_ERR(pc->pctl_dev)) {
-+              gpiochip_remove(&pc->gpio_chip);
-+              return PTR_ERR(pc->pctl_dev);
-+      }
-+
-+      pc->gpio_range = *pdata->gpio_range;
-+      pc->gpio_range.base = pc->gpio_chip.base;
-+      pc->gpio_range.gc = &pc->gpio_chip;
-+      pinctrl_add_gpio_range(pc->pctl_dev, &pc->gpio_range);
-+
-       girq = &pc->gpio_chip.irq;
-       girq->chip = &bcm2835_gpio_irq_chip;
-       girq->parent_handler = bcm2835_gpio_irq_handler;
-@@ -1251,8 +1263,10 @@ static int bcm2835_pinctrl_probe(struct
-       girq->parents = devm_kcalloc(dev, BCM2835_NUM_IRQS,
-                                    sizeof(*girq->parents),
-                                    GFP_KERNEL);
--      if (!girq->parents)
-+      if (!girq->parents) {
-+              pinctrl_remove_gpio_range(pc->pctl_dev, &pc->gpio_range);
-               return -ENOMEM;
-+      }
-       if (is_7211) {
-               pc->wake_irq = devm_kcalloc(dev, BCM2835_NUM_IRQS,
-@@ -1303,21 +1317,10 @@ static int bcm2835_pinctrl_probe(struct
-       err = devm_gpiochip_add_data(dev, &pc->gpio_chip, pc);
-       if (err) {
-               dev_err(dev, "could not add GPIO chip\n");
-+              pinctrl_remove_gpio_range(pc->pctl_dev, &pc->gpio_range);
-               return err;
-       }
--      pc->pctl_desc = *pdata->pctl_desc;
--      pc->pctl_dev = devm_pinctrl_register(dev, &pc->pctl_desc, pc);
--      if (IS_ERR(pc->pctl_dev)) {
--              gpiochip_remove(&pc->gpio_chip);
--              return PTR_ERR(pc->pctl_dev);
--      }
--
--      pc->gpio_range = *pdata->gpio_range;
--      pc->gpio_range.base = pc->gpio_chip.base;
--      pc->gpio_range.gc = &pc->gpio_chip;
--      pinctrl_add_gpio_range(pc->pctl_dev, &pc->gpio_range);
--
-       return 0;
- }
index 840a446b7894e57d830aa3bdd284c1aab76feee0..0f35bfe060cd00dbd8bedf87f2c36f585ad8a26b 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -1181,6 +1181,9 @@ static int lan78xx_link_reset(struct lan
+@@ -1183,6 +1183,9 @@ static int lan78xx_link_reset(struct lan
        if (unlikely(ret < 0))
                return -EIO;
  
index fff6b25ac5c751d61db7292d37105ba83109a4ea..696892786eda164679e14b54cb5e3c1add23ed15 100644 (file)
@@ -819,7 +819,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                if (is_valid_ether_addr(hw_mac_addr)) {
 --- a/drivers/net/ethernet/marvell/prestera/prestera_main.c
 +++ b/drivers/net/ethernet/marvell/prestera/prestera_main.c
-@@ -462,20 +462,17 @@ static int prestera_switch_set_base_mac_
+@@ -466,20 +466,17 @@ static int prestera_switch_set_base_mac_
  {
        struct device_node *base_mac_np;
        struct device_node *np;
diff --git a/target/linux/sunxi/patches-5.10/103-arm64-dts-allwinner-orangepi-zero-plus-fix-PHY-mo.patch b/target/linux/sunxi/patches-5.10/103-arm64-dts-allwinner-orangepi-zero-plus-fix-PHY-mo.patch
deleted file mode 100644 (file)
index e3a0034..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-From 4f45f9f370a5bc6a43a7a166f10b3a30ca21353c Mon Sep 17 00:00:00 2001
-From: Robert Marko <robert.marko@sartura.hr>
-Date: Wed, 17 Nov 2021 10:36:31 +0100
-Subject: [PATCH v2] arm64: dts: allwinner: orangepi-zero-plus: fix PHY mode
-
-Orange Pi Zero Plus uses a Realtek RTL8211E RGMII Gigabit PHY, but its
-currently set to plain RGMII mode meaning that it doesn't introduce
-delays.
-
-With this setup, TX packets are completely lost and changing the mode to
-RGMII-ID so the PHY will add delays internally fixes the issue.
-
-Fixes: a7affb13b271 ("arm64: allwinner: H5: Add Xunlong Orange Pi Zero Plus")
-
-Tested-by: Ron Goossens <rgoossens@gmail.com>
-Signed-off-by: Robert Marko <robert.marko@sartura.hr>
-Tested-by: Samuel Holland <samuel@sholland.org>
----
- arch/arm64/boot/dts/allwinner/sun50i-h5-orangepi-zero-plus.dts | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/arch/arm64/boot/dts/allwinner/sun50i-h5-orangepi-zero-plus.dts
-+++ b/arch/arm64/boot/dts/allwinner/sun50i-h5-orangepi-zero-plus.dts
-@@ -69,7 +69,7 @@
-       pinctrl-0 = <&emac_rgmii_pins>;
-       phy-supply = <&reg_gmac_3v3>;
-       phy-handle = <&ext_rgmii_phy>;
--      phy-mode = "rgmii";
-+      phy-mode = "rgmii-id";
-       status = "okay";
- };