remove unused wget menuconfig option; make the package autorebuild optional (but...
authorFelix Fietkau <nbd@openwrt.org>
Fri, 2 Jun 2006 16:17:56 +0000 (16:17 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 2 Jun 2006 16:17:56 +0000 (16:17 +0000)
SVN-Revision: 3896

openwrt/Config.in
openwrt/package/rules.mk

index 4a887cc135637a7c63fc98f4f9b5ba963f482aa4..740205e3ec0a817c4d5ab7dc47dfb2037ceeef1b 100644 (file)
@@ -21,10 +21,12 @@ menuconfig DEVEL
 menuconfig BUILDOPTS
        bool "Build Options" if DEVEL
 
-config WGET
-        string
-       prompt "WGET command" if BUILDOPTS
-        default "wget --passive-ftp -nd"
+config AUTOREBUILD
+       bool
+       prompt "Automatic rebuild of packages" if BUILDOPTS
+       default y
+       help
+               Automatically rebuild packages when their files change
 
 config TAR_VERBOSITY
        bool 
index 1fd6f2a8ab7abcfa5012d538249bbac88daf37cf..c05333b021d1e1d121b4526937361c25f73fe63b 100644 (file)
@@ -7,12 +7,16 @@ endif
 define Build/DefaultTargets
   ifeq ($(DUMP),)
     ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . $(TOPDIR)/package/rules.mk),$(PKG_BUILD_DIR))
-      $(PKG_BUILD_DIR)/.prepared: package-clean
+         ifeq ($(CONFIG_AUTOREBUILD),y)
+        $(PKG_BUILD_DIR)/.prepared: package-clean
+      endif
     endif
 
     ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
-      $(PKG_BUILD_DIR)/.built: package-rebuild
-    endif
+         ifeq ($(CONFIG_AUTOREBUILD),y)
+        $(PKG_BUILD_DIR)/.built: package-rebuild
+      endif
+       endif
   endif
 
   $(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)