base-files: config_get: prevent filename globbing
authorGünther Kelleter <guenther.kelleter@devolo.de>
Mon, 8 Oct 2018 13:30:00 +0000 (15:30 +0200)
committerJo-Philipp Wich <jo@mein.io>
Wed, 30 Jan 2019 12:20:14 +0000 (13:20 +0100)
When config_get is called as "config_get section option" the option
is unexpectedly globbed by the shell which differs from the way options
are read to a variable with "config_get variable section option".
Add another layer of double quotes to fix it.

Signed-off-by: Günther Kelleter <guenther.kelleter@devolo.de>
package/base-files/Makefile
package/base-files/files/lib/functions.sh

index 0dc8b6d61e491aa3d260110b183401ff37e27e9f..609ffa2c38912aa7c3e5c16c0200c11f0d0cfdc4 100644 (file)
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=196
+PKG_RELEASE:=197
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
index 50a7b408698cbf5141d65f1f4eaf851c16d84876..edce75e8ff877aa28adea5b58463a95b19f8f7e2 100755 (executable)
@@ -92,7 +92,7 @@ config_unset() {
 # config_get <section> <option>
 config_get() {
        case "$3" in
-               "") eval echo "\${CONFIG_${1}_${2}:-\${4}}";;
+               "") eval echo "\"\${CONFIG_${1}_${2}:-\${4}}\"";;
                *)  eval export ${NO_EXPORT:+-n} -- "${1}=\${CONFIG_${2}_${3}:-\${4}}";;
        esac
 }