kernel: add usb-serial-simple module
authorJohn Crispin <john@openwrt.org>
Thu, 2 Apr 2015 14:31:15 +0000 (14:31 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 2 Apr 2015 14:31:15 +0000 (14:31 +0000)
replaces kmod-usb-serial-motorola-phone it's found only in Kernel <3.12

This module handles many simple USB serial devices
like Motorola Phones, GPS reveivers in Kernels above 3.14

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
SVN-Revision: 45233

package/kernel/linux/modules/usb.mk

index fc47568dbc646a81665e83b7af655ec294bda671..53a0c9cd49dd3f6bf11c3dfa916272827fffc4da 100644 (file)
@@ -631,6 +631,7 @@ endef
 $(eval $(call KernelPackage,usb-serial-ftdi))
 
 
+<<<<<<< HEAD
 define KernelPackage/usb-serial-garmin
   TITLE:=Support for Garmin GPS devices
   KCONFIG:=CONFIG_USB_SERIAL_GARMIN
@@ -644,6 +645,62 @@ define KernelPackage/usb-serial-garmin/description
 endef
 
 $(eval $(call KernelPackage,usb-serial-garmin))
+=======
+define KernelPackage/usb-serial-simple
+  TITLE:=USB Serial Simple (Motorola phone)
+  KCONFIG:=CONFIG_USB_SERIAL_SIMPLE
+  FILES:=$(LINUX_DIR)/drivers/usb/serial/usb-serial-simple.ko
+  AUTOLOAD:=$(call AutoProbe,usb-serial-simple)
+  $(call AddDepends/usb-serial)
+endef
+
+define KernelPackage/usb-serial-simple/description
+  Kernel support for "very simple devices".
+
+Specifically, it supports:
+       - Suunto ANT+ USB device.
+       - Medtronic CareLink USB device (3.18)
+       - Fundamental Software dongle.
+       - Google USB serial devices (3.19)
+       - HP4x calculators
+       - a number of Motorola phones
+       - Novatel Wireless GPS receivers (3.18)
+       - Siemens USB/MPI adapter.
+       - ViVOtech ViVOpay USB device.
+       - Infineon Modem Flashloader USB interface
+       - ZIO Motherboard USB serial interface
+endef
+
+$(eval $(call KernelPackage,usb-serial-simple))
+>>>>>>> kernel: add usb-serial-simple module
+
+
+define KernelPackage/usb-serial-simple
+  TITLE:=USB Serial Simple (Motorola phone)
+  KCONFIG:=CONFIG_USB_SERIAL_SIMPLE
+  FILES:=$(LINUX_DIR)/drivers/usb/serial/usb-serial-simple.ko
+  AUTOLOAD:=$(call AutoProbe,usb-serial-simple)
+  $(call AddDepends/usb-serial)
+endef
+
+define KernelPackage/usb-serial-simple/description
+  Kernel support for "very simple devices".
+
+Specifically, it supports:
+       - Suunto ANT+ USB device.
+       - Medtronic CareLink USB device (3.18)
+       - Fundamental Software dongle.
+       - Google USB serial devices (3.19)
+       - HP4x calculators
+       - a number of Motorola phones
+       - Novatel Wireless GPS receivers (3.18)
+       - Siemens USB/MPI adapter.
+       - ViVOtech ViVOpay USB device.
+       - Infineon Modem Flashloader USB interface
+       - ZIO Motherboard USB serial interface
+endef
+
+$(eval $(call KernelPackage,usb-serial-simple))
 
 
 define KernelPackage/usb-serial-ti-usb