base-files: calling stop_service before procd_kill.
authorJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 12:42:44 +0000 (12:42 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 12:42:44 +0000 (12:42 +0000)
Before this patch, doing `/e/c/network restart' will emit the folloing
error by `ubus network.wireless down "{}"' because netifd already quit
by that time.

Command failed: not found

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
SVN-Revision: 40906

package/base-files/Makefile
package/base-files/files/etc/rc.common

index 207af352666859152d5f260fe6fec5c2516c60ee..eea9ecb8e08d80db654c8dee9dbf27188afea328 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=152
+PKG_RELEASE:=153
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 829ec76bacff86ba363974c4114605ba6b861895..8701312e4c842d9a6067c8d40c1dd31750696be0 100755 (executable)
@@ -112,8 +112,8 @@ ${INIT_TRACE:+set -x}
        }
 
        stop() {
-               procd_kill "$(basename ${basescript:-$initscript})" "$1"
                stop_service "$@"
+               procd_kill "$(basename ${basescript:-$initscript})" "$1"
        }
 
        reload() {