hostapd: remove unused struct hostapd_ubus_iface
[openwrt/openwrt.git] / rules.mk
index 56ecbf2eb8f6ae2793d1d0cf83684dfa2a91b3ef..6b881a0c619c11e63d7504b31e4c16f4271f81bc 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -276,7 +276,7 @@ PATCH:=patch
 PYTHON:=python
 
 INSTALL_BIN:=install -m0755
-INSTALL_SUID:install -m4755
+INSTALL_SUID:=install -m4755
 INSTALL_DIR:=install -d -m0755
 INSTALL_DATA:=install -m0644
 INSTALL_CONF:=install -m0600
@@ -391,8 +391,9 @@ endef
 
 # Calculate sha256sum of any plain file within a given directory
 # $(1) => Input directory
+# $(2) => If set, recurse into subdirectories
 define sha256sums
-       (cd $(1); find . -maxdepth 1 -type f -not -name 'sha256sums' -printf "%P\n" | sort | \
+       (cd $(1); find . $(if $(2),,-maxdepth 1) -type f -not -name 'sha256sums' -printf "%P\n" | sort | \
                xargs -r $(STAGING_DIR_HOST)/bin/mkhash -n sha256 | sed -ne 's!^\(.*\) \(.*\)$$!\1 *\2!p' > sha256sums)
 endef