update to 2.6.30.6, compile tested on some targets only
[openwrt/openwrt.git] / target / linux / ar71xx / Makefile
index 8c43898b9c24e5f54df67be1510f94f1d9127786..dc18d1c275c1352c32006d124804d245a5e0bdb0 100644 (file)
@@ -8,16 +8,16 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx/AR913x
-FEATURES:=squashfs tgz
+BOARDNAME:=Atheros AR71xx/AR7240/AR913x
+FEATURES:=squashfs jffs2 tgz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
-LINUX_VERSION:=2.6.28.8
+LINUX_VERSION:=2.6.30.6
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-gpio-leds kmod-input-core kmod-input-polldev \
+       kmod-leds-gpio kmod-input-core kmod-input-polldev \
        kmod-input-gpio-buttons kmod-button-hotplug
 
 define Target/Description