update to the latest stable kernels
[openwrt/openwrt.git] / target / linux / ifxmips / Makefile
index 420309661c74e34b5a53aad0ce42588f4744dd43..9de534358fc93e48ed53cac50a6a6aa4e38a9cf7 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,11 +9,15 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
-FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.25.16
+FEATURES:=squashfs jffs2 atm
+SUBTARGETS:=danube ar9
+
+LINUX_VERSION:=2.6.35.9
+
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=uboot-ifxmips
+DEFAULT_PACKAGES+=uboot-lantiq kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl ifxmips-dsl-api ifxmips-dsl-control tapi_sip lqtapi_firmware_danube
 
 define Target/Description
        Build firmware images for Infineon Mips Controllers