kernel: update linux 3.8 to 3.8.8
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index 0f5064c3fc5f881549609f4e73a6eaf7b78a591e..e042ca4d31b7778e9f9b7e5fc3c8dc2dce1d48fa 100644 (file)
@@ -6,15 +6,14 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
+BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
-#SUBTARGETS:=xway falcon ase
+SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=2.6.39.2
+LINUX_VERSION:=3.8.8
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
 define Target/Description
        Build firmware images for Lantiq SoC