kernel: update linux 3.8 to 3.8.8
authorGabor Juhos <juhosg@openwrt.org>
Fri, 19 Apr 2013 08:07:34 +0000 (08:07 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 19 Apr 2013 08:07:34 +0000 (08:07 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 36363

25 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar71xx/Makefile
target/linux/atheros/Makefile
target/linux/avr32/Makefile
target/linux/cns21xx/Makefile
target/linux/cns3xxx/Makefile
target/linux/ep93xx/Makefile
target/linux/generic/patches-3.8/950-vm_exports.patch
target/linux/lantiq/Makefile
target/linux/malta/Makefile
target/linux/mpc52xx/Makefile
target/linux/mpc83xx/Makefile
target/linux/mpc85xx/Makefile
target/linux/mvebu/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/ramips/patches-3.8/0209-owrt-GPIO-add-gpio_export_with_name.patch
target/linux/rb532/Makefile
target/linux/realview/Makefile
target/linux/uml/Makefile
target/linux/x86/alix2/target.mk
target/linux/x86/generic/target.mk
target/linux/xburst/Makefile

index b565df3e44425f1e9f72e11e7a54ec334d6a3ad6..2eb73cedccb6ac5dce1496fbd73538e1864054f5 100644 (file)
@@ -11,8 +11,8 @@ endif
 ifeq ($(LINUX_VERSION),3.7.10)
   LINUX_KERNEL_MD5SUM:=09624c3702107076efcac5e1cd8a18ec
 endif
-ifeq ($(LINUX_VERSION),3.8.7)
-  LINUX_KERNEL_MD5SUM:=37ce9b5cc33551b45fea59c1c4c9da13
+ifeq ($(LINUX_VERSION),3.8.8)
+  LINUX_KERNEL_MD5SUM:=3b4feff68460881a5dde1307fe1ce87f
 endif
 
 # disable the md5sum check for unknown kernel versions
index 6a58a25e42671b8463429efa876d181b767fd2a5..3910a859427c6f5c3f262c7abf7cd5b658e8db99 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
index 746b4be28c53465147dba0b16b37fb64fab3c0f3..fa698a446edfbbf82a4e90048a29ea1dc35ce57b 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
index a5b2d093f3bd4f841316c0a632cc9b0cbfdae13f..2b7703223732779497e5818becead86c32adcecc 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
index cec5ae400d2760c7061ba15b7d56cdc247743bda..78962022328354aba0db3ec80d6228ca7cb5cddb 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
index 05436e4796c4fe99f2f7641016fe632c44c953d6..d851ba2cb089fb0ca8890543275a2c6d5e50304f 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
index 6b5b45b7ff81072e01bf97620e24c374eee36422..c604ea85c73173753a238bc81eda96889b9e203b 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs fpu gpio pcie usb usbgadget
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
index 8ad8318204cfad485b2bccc04fc971de497f5572..80b8fcc4b9cb2f2057634a1b775a7be70c343eab 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb display sound
 CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 DEVICE_TYPE:=developerboard
 
index 66015992c180ce292bf747fd791d1fda201bd8dd..9c15a1b813d23445cfd3292884d2d0f57c945272 100644 (file)
@@ -62,7 +62,7 @@
  
 --- a/mm/memory.c
 +++ b/mm/memory.c
-@@ -1408,6 +1408,7 @@ void zap_page_range(struct vm_area_struc
+@@ -1409,6 +1409,7 @@ void zap_page_range(struct vm_area_struc
        mmu_notifier_invalidate_range_end(mm, start, end);
        tlb_finish_mmu(&tlb, start, end);
  }
index 87827fe1852712b413b629b4e1a532e23746bba8..e042ca4d31b7778e9f9b7e5fc3c8dc2dce1d48fa 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
 SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
index efac73e3abed283283501245aab3ef23389a7eca..6161443d932b6149808a48a88b950a42f402fc08 100644 (file)
@@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 DEVICE_TYPE:=developerboard
 
index 9d894e6022b0b7ae4f88d8e8244a5584fd409afc..e06ff6a57a15c063857395564762b77a16d3f6c4 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale MPC52xx
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=targz ext4
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
index b3020899008ba88e0350f3d5774dea4957f7a69f..fa30ecf5fe541e8b14c461654d433bf8e8b49442 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
index 319dd4d0e6b84c071f9f488fbd05edddef2b4be3..9e5109efd834c1b1fb9c420089401708d721115d 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
 FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
index 22fd05a7378f6c85cbe92036f3a0cdb8fb613d5c..4c49e2757b1351c11ccd63d948f44021ba6ba1f0 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2 pci pcie gpio
 CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
index 8f9b9b61037ee69ebd900b9699dda773cab6b569..27e1a14170132d00dfc3e28443e19fdce420a4ee 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
index 10c9f75f872b60feb1c608b13b2943222aa964b6..9612e90d59aa873547abc93606410620e2d32301 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
index b78a00174cc1e288661141aeb5b18045a8bc1ebe..43520abe96b2c89d135123ce2cccdf270705b369 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index c8b16dc79006b58702174677421ca08b544bc760..efbd0858d69479536659d74d1aaac0cfad519e93 100644 (file)
@@ -91,7 +91,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  
  /* Private data structure for of_gpiochip_find_and_xlate */
  struct gg_data {
-@@ -289,3 +291,62 @@ void of_gpiochip_remove(struct gpio_chip
+@@ -288,3 +290,62 @@ void of_gpiochip_remove(struct gpio_chip
        if (chip->of_node)
                of_node_put(chip->of_node);
  }
index 5b55afa4de1583f863453ca2ca52c193841fbd2c..270830806e1572e39c0f051fae13ff8ff63b4e5e 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index 718141b8e7841e2b604739c0e32ca73cd9762813..801b3fde7b0306318f3e414371466743f9e6b498 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 DEVICE_TYPE:=developerboard
 
index a10f0dd17bd3552549d646d13432e10e786d0fe5..650a0bebee9626d36868b7157763e439542b8f65 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 include $(INCLUDE_DIR)/target.mk
 
index fcd7a2377b99d5d1e479b7b5a57b7335d77f2bd7..06605fcfdfc6dd53812ffc2086f05fc54b8a5b88 100644 (file)
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
                        kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
                        kmod-ledtrig-netdev \
                        kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 CS5535_MASK:=0x0b000042
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
index a5ac323f7b314453ac9fd477d3516e59f78c73d3..31dfa5167d02d7d130e06b44f8407b97b02b4d87 100644 (file)
@@ -1,6 +1,6 @@
 BOARDNAME:=Generic
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 define Target/Description
        Build firmware images for x86 based boards
index 143dce41ecb73522027ef2947397bc3d6fae17b7..8b6dd1c500ed20125bd24624162fdbcc43fde04a 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=jffs2 targz ubifs audio broken
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.8
 
 DEVICE_TYPE=other