kernel: bump 4.14 to 4.14.167
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 24 Jan 2020 10:14:21 +0000 (11:14 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 24 Jan 2020 12:17:32 +0000 (13:17 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ar71xx/patches-4.14/910-unaligned_access_hacks.patch
target/linux/ath79/patches-4.14/910-unaligned_access_hacks.patch
target/linux/brcm2708/patches-4.14/950-0037-Add-dwc_otg-driver.patch
target/linux/brcm2708/patches-4.14/950-0454-lan78xx-Debounce-link-events-to-minimize-poll-storm.patch
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch

index c3890d4910bc7cb633b442a3a82d16789f20664b..0992f82c1fdbdd8a5be6693c56eab99f5884e582 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .166
+LINUX_VERSION-4.14 = .167
 
-LINUX_KERNEL_HASH-4.14.166 = 8bb2bf811a2092933a2386a4e679cd0c88de979c10fbb463d8142add4e577c00
+LINUX_KERNEL_HASH-4.14.167 = 2bb78fc7a902faf4f5dad47fdbc2f4bf3df3cf9b41f408e7260f36656659fe43
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index d1dd056f765370726348897e5277626ba02727fd..f2732ebb20bacc82561cce1ee3251eb85087fb9a 100644 (file)
  EXPORT_SYMBOL(xfrm_parse_spi);
 --- a/net/ipv4/tcp_input.c
 +++ b/net/ipv4/tcp_input.c
-@@ -3877,14 +3877,16 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3878,14 +3878,16 @@ static bool tcp_parse_aligned_timestamp(
  {
        const __be32 *ptr = (const __be32 *)(th + 1);
  
index 29455b89077366a3ac3ef3971748c7ad0515cd98..6234ba4703429110cee89553c17a91a8a7b8254b 100644 (file)
  EXPORT_SYMBOL(xfrm_parse_spi);
 --- a/net/ipv4/tcp_input.c
 +++ b/net/ipv4/tcp_input.c
-@@ -3877,14 +3877,16 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3878,14 +3878,16 @@ static bool tcp_parse_aligned_timestamp(
  {
        const __be32 *ptr = (const __be32 *)(th + 1);
  
index 14dae14a12ab68ff2b34eeac816dc9c6a9ffa3c7..afc4311e9bb2833bbaf63587110ca61c8f9fa660 100644 (file)
@@ -841,7 +841,7 @@ Signed-off-by: Malik Olivier Boussejra <malik@boussejra.com>
  }
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -5105,7 +5105,7 @@ static void port_event(struct usb_hub *h
+@@ -5106,7 +5106,7 @@ static void port_event(struct usb_hub *h
        if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
                u16 status = 0, unused;
  
index c3aebefef27b1131763f97c8aa325e080d3d0d85..cacf93868a3ba856ea11314c7cd4392794d1f31e 100644 (file)
@@ -28,7 +28,7 @@ See: https://github.com/raspberrypi/linux/issues/2447
  static int lan78xx_read_reg(struct lan78xx_net *dev, u32 index, u32 *data)
  {
        u32 *buf = kmalloc(sizeof(u32), GFP_KERNEL);
-@@ -3714,7 +3719,12 @@ static int lan78xx_probe(struct usb_inte
+@@ -3715,7 +3720,12 @@ static int lan78xx_probe(struct usb_inte
        dev->pipe_intr = usb_rcvintpipe(dev->udev,
                                        dev->ep_intr->desc.bEndpointAddress &
                                        USB_ENDPOINT_NUMBER_MASK);
index f70cfef7624737d83c392e5a0d1cce9ff4c6d2df..c09a5e47f81894adf31d6d8b759b72660e54730b 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -1975,7 +1975,8 @@ static const struct usb_device_id option
+@@ -1981,7 +1981,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },