mt76: update to the latest version
authorFelix Fietkau <nbd@nbd.name>
Fri, 18 May 2018 16:13:55 +0000 (18:13 +0200)
committerFelix Fietkau <nbd@nbd.name>
Fri, 15 Jun 2018 20:30:17 +0000 (22:30 +0200)
73edb22 mt76: discard early received packets if not running yet
0b8d1dd mt76: fix beacon timer drift
20c0766 mt7603: adjust rx hang watchdog for MT7628
664e321 mt7603: add extra PSE hang check signature for MT7628
f24b56f update MT7628 firmware to the latest version
d87e4b0 mt7603: clear PSE reset bit if PSE reset fails
0ef26ef mt76: only stop tx queues on offchannel, not during the entire scan
f399da3 mt76: prevent tx scheduling during channel change
21c1e1e mt76: move ieee80211_hw allocation to common core
730c292 mt76: wait for pending tx to complete before switching channel
fcbb49e mt76x2: use udelay instead of usleep_range in mt76x2_mac_stop
792dbe0 mt7603: do not hold dev->mutex while flushing dev->mac_work
9090f9c mt76x2: fix threshold for gain adjustment
2cbaa57 mt76x2: fix swapped values for RXO-18 in gain control
a39ab70 mt76x2: adjust AGC control register 26 based on gain for VHT80
4936c0c mt76x2: clear false CCA counters after changing gain settings
1528fe7 mt76x2: fix variable gain adjustment range
f3522e1 mt76x2: add a debugfs file to dump agc calibration information
65e161b mt76x2: fix tracking rssi for dynamic gain adjustment

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/mt76/Makefile

index 7d723b9e66a4c264191365644b492892cb9d6ab6..5b59c8ccfa6714300f0db64d5f3e9bee6267b305 100644 (file)
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/openwrt/mt76
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2018-05-15
-PKG_SOURCE_VERSION:=e87f925667a2c68e6a5a1f55e3a92c9e10570e61
-PKG_MIRROR_HASH:=7f6118d033785b509e25540fafd0166076e98b8f1d9baceab4c532e6f9d537b3
+PKG_SOURCE_DATE:=2018-06-15
+PKG_SOURCE_VERSION:=65e161bec8e0fe97d2934982b5d8e29c0f9c8a7e
+PKG_MIRROR_HASH:=321b0b107b811f5d3696cff54c2482af2e406a6aeb908d8edfa9baea9db2105d
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_BUILD_PARALLEL:=1