batman-adv: upgrade package to latest release 2018.4 427/head
authorSven Eckelmann <sven@narfation.org>
Tue, 6 Nov 2018 09:49:18 +0000 (10:49 +0100)
committerSven Eckelmann <sven@narfation.org>
Wed, 14 Nov 2018 20:50:38 +0000 (21:50 +0100)
* support latest kernels (3.16 - 4.20)
* coding style cleanups and refactoring
* improve tx performance by avoiding unnecessary locking
* add help messages regarding deprecation of debugfs files
* support for debug message tracepoints
* explicit ELP padding to allow TVLVs in the future
* bugs squashed:

  - fix skb_over_panic for merged fragments with small tailroom

Signed-off-by: Sven Eckelmann <sven@narfation.org>
batman-adv/Config.in
batman-adv/Makefile

index 52a688bb78a41e14845e3078c480844b6f3edcae..a6c8ad3b7f9ed65d073add7a4fa58506d3532437 100644 (file)
@@ -71,6 +71,7 @@ config BATMAN_ADV_NC
 config BATMAN_ADV_MCAST
        bool "Multicast optimisation"
        depends on PACKAGE_kmod-batman-adv
+       default y
        help
          This option enables the multicast optimisation which aims to
          reduce the air overhead while improving the reliability of
@@ -95,3 +96,15 @@ config BATMAN_ADV_DEBUG
          say N here. This enables compilation of support for
          outputting debugging information to the kernel log. The
          output is controlled via the module parameter debug.
+
+config BATMAN_ADV_TRACING
+       bool "B.A.T.M.A.N. tracing support"
+       depends on PACKAGE_kmod-batman-adv
+       select KERNEL_FTRACE
+       select KERNEL_ENABLE_DEFAULT_TRACERS
+       help
+         This is an option for use by developers; most people should
+         say N here. Select this option to gather traces like the debug
+         messages using the generic tracing infrastructure of the kernel.
+         BATMAN_ADV_DEBUG must also be selected to get trace events for
+         batadv_dbg.
index 898efe3e1ac8581b55167c81c139e889d0a13aca..dc73feefa6a26c0ae4cf1a3dbdea0e7e59764558 100644 (file)
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=batman-adv
 
-PKG_VERSION:=2018.3
-PKG_RELEASE:=2
-PKG_HASH:=33f3f942203732e0568a6bc0226a0fe8eb147c961f0d0c13b2e6b16237d412ff
+PKG_VERSION:=2018.4
+PKG_RELEASE:=0
+PKG_HASH:=3500b4bc7d41ce1adef0b0684972a439d48b454ba78282e94df13ba90605484d
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
@@ -59,6 +59,7 @@ PKG_EXTRA_KCONFIG:= \
        CONFIG_BATMAN_ADV_MCAST=$(if $(CONFIG_BATMAN_ADV_MCAST),y,n) \
        CONFIG_BATMAN_ADV_NC=$(if $(CONFIG_BATMAN_ADV_NC),y,n) \
        CONFIG_BATMAN_ADV_BATMAN_V=$(if $(CONFIG_BATMAN_ADV_BATMAN_V),y,n) \
+       CONFIG_BATMAN_ADV_TRACING=$(if $(CONFIG_BATMAN_ADV_TRACING),y,n) \
 
 PKG_EXTRA_CFLAGS:= \
        $(patsubst CONFIG_%, -DCONFIG_%=1, $(patsubst %=m,%,$(filter %=m,$(PKG_EXTRA_KCONFIG)))) \