batman-adv: Add openwrt revision to internal version
authorSven Eckelmann <sven@narfation.org>
Sun, 7 Oct 2018 09:10:05 +0000 (11:10 +0200)
committerSven Eckelmann <sven@narfation.org>
Sun, 7 Oct 2018 11:31:01 +0000 (13:31 +0200)
OpenWrt is using a modified version of the software and these modifications
may introduce extra bugs (or behavior changes). It is also patched for
stable releases instead of switching to new releases. The revision should
therefore be added to the version number to make it easier understandable
which modified version the user may have installed.

Signed-off-by: Sven Eckelmann <sven@narfation.org>
batman-adv/Makefile

index b6835d3cfd0abf10d504ac7657a97a060b8ba882..0d9aa772081688c2a4d7924a4d076aba0bb8c48c 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=batman-adv
 
 PKG_VERSION:=2018.3
-PKG_RELEASE:=0
+PKG_RELEASE:=1
 PKG_HASH:=33f3f942203732e0568a6bc0226a0fe8eb147c961f0d0c13b2e6b16237d412ff
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -69,7 +69,8 @@ NOSTDINC_FLAGS = \
        -I$(STAGING_DIR)/usr/include/mac80211/uapi \
        -I$(PKG_BUILD_DIR)/include/ \
        -include backport/backport.h \
-       -include $(PKG_BUILD_DIR)/compat-hacks.h
+       -include $(PKG_BUILD_DIR)/compat-hacks.h \
+       -DBATADV_SOURCE_VERSION=\\\"openwrt-$(PKG_VERSION)-$(PKG_RELEASE)\\\"
 
 COMPAT_SOURCES = \
        $(if $(CONFIG_KMOD_BATMAN_ADV_MCAST),../../compat-sources/net/core/skbuff.o,) \