include: autotools.mk: do not fail in patch-libtool fixup if patch is already applied
[openwrt/openwrt.git] / include / autotools.mk
index 1472b5a781edc5e3a91985185c2aa87b5a666288..1ce25bc9f6f5bc1d3e7ffefc5deafe609ae850f2 100644 (file)
@@ -56,7 +56,7 @@ define patch_libtool
                        lt_version="$$$$($$(STAGING_DIR_HOST)/bin/sed -ne 's,^[[:space:]]*VERSION=\([0-9]\.[0-9]\+\).*,\1,p' $$$$lt)"; \
                        case "$$$$lt_version" in \
                                1.5|2.2|2.4) echo "autotools.mk: Found libtool v$$$$lt_version - applying patch to $$$$lt"; \
-                                       (cd $$$$(dirname $$$$lt) && $$(PATCH) -s -p1 < $$(TOPDIR)/tools/libtool/files/libtool-v$$$$lt_version.patch) ;; \
+                                       (cd $$$$(dirname $$$$lt) && $$(PATCH) -N -s -p1 < $$(TOPDIR)/tools/libtool/files/libtool-v$$$$lt_version.patch || true) ;; \
                                *) echo "autotools.mk: error: Unsupported libtool version v$$$$lt_version - cannot patch $$$$lt"; exit 1 ;; \
                        esac; \
                done; \