wprobe: mask as BROKEN on cris
[openwrt/openwrt.git] / include / image.mk
index efbc76db36a25d6e098463fc397d64f3b11911b8..d75ca3c30f5cd69d6f4a6ec9161a667b988d12ca 100644 (file)
@@ -10,6 +10,7 @@ include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/host.mk
 
+.NOTPARALLEL:
 override MAKEFLAGS=
 override MAKE:=$(SUBMAKE)
 KDIR=$(KERNEL_BUILD_DIR)
@@ -22,19 +23,34 @@ JFFS2OPTS     :=  --pad --big-endian --squash
 SQUASHFS_OPTS :=  -be
 endif
 
+ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_21)$(CONFIG_LINUX_2_6_25)$(CONFIG_LINUX_2_6_28),)
+USE_SQUASHFS3 := y
+endif
+
+ifneq ($(USE_SQUASHFS3),)
+MKSQUASHFS_CMD := $(STAGING_DIR_HOST)/bin/mksquashfs-lzma
+else
+MKSQUASHFS_CMD := $(STAGING_DIR_HOST)/bin/mksquashfs4
+SQUASHFS_OPTS  := -comp lzma -processors 1
+endif
+
 JFFS2_BLOCKSIZE ?= 64k 128k
 
 define add_jffs2_mark
        echo -ne '\xde\xad\xc0\xde' >> $(1)
 endef
 
-# pad to 64k and add jffs2 end-of-filesystem mark
-# do this twice to make sure that this works with 128k blocksize as well
+# pad to 4k, 8k, 64k, 128k and add jffs2 end-of-filesystem mark
 define prepare_generic_squashfs
-       dd if=$(1) of=$(KDIR)/tmpfile.1 bs=64k conv=sync
+       dd if=$(1) of=$(KDIR)/tmpfile.0 bs=4k conv=sync
+       $(call add_jffs2_mark,$(KDIR)/tmpfile.0)
+       dd if=$(KDIR)/tmpfile.0 of=$(KDIR)/tmpfile.1 bs=4k conv=sync
        $(call add_jffs2_mark,$(KDIR)/tmpfile.1)
-       dd of=$(1) if=$(KDIR)/tmpfile.1 bs=64k conv=sync
+       dd if=$(KDIR)/tmpfile.1 of=$(KDIR)/tmpfile.2 bs=64k conv=sync
+       $(call add_jffs2_mark,$(KDIR)/tmpfile.2)
+       dd if=$(KDIR)/tmpfile.2 of=$(1) bs=64k conv=sync
        $(call add_jffs2_mark,$(1))
+       rm -f $(KDIR)/tmpfile.*
 endef
 
 ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
@@ -54,14 +70,14 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
   ifeq ($(CONFIG_TARGET_ROOTFS_SQUASHFS),y)
     define Image/mkfs/squashfs
                @mkdir -p $(TARGET_DIR)/jffs
-               $(STAGING_DIR_HOST)/bin/mksquashfs-lzma $(TARGET_DIR) $(KDIR)/root.squashfs -nopad -noappend -root-owned $(SQUASHFS_OPTS)
+               $(MKSQUASHFS_CMD) $(TARGET_DIR) $(KDIR)/root.squashfs -nopad -noappend -root-owned $(SQUASHFS_OPTS)
                $(call Image/Build,squashfs)
     endef
   endif
 
   ifeq ($(CONFIG_TARGET_ROOTFS_TGZ),y)
     define Image/mkfs/tgz
-               $(TAR) -zcf $(BIN_DIR)/openwrt-$(BOARD)-rootfs.tgz --owner=root --group=root -C $(TARGET_DIR)/ .
+               $(TAR) -zcf $(BIN_DIR)/openwrt-$(BOARD)-rootfs.tgz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
     endef
   endif
 
@@ -77,12 +93,19 @@ else
   endef
 endif
 
+define Image/Checksum
+       ( cd ${BIN_DIR} ; \
+               $(FIND) -maxdepth 1 -type f \! -name 'md5sums'  -printf "%P\n" | xargs \
+               md5sum --binary > md5sums \
+       )
+endef
+
 
 ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
   E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))
 
   define Image/mkfs/ext2
-               $(STAGING_DIR_HOST)/bin/genext2fs -U -b $(E2SIZE) -I $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext2
+               $(STAGING_DIR_HOST)/bin/genext2fs -U -b $(E2SIZE) -N $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext2
                $(call Image/Build,ext2)
   endef
 endif
@@ -95,9 +118,9 @@ endif
 
 
 define Image/mkfs/prepare/default
-       find $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' | $(XARGS) chmod 0644
-       find $(TARGET_DIR) -type f -perm +0100 | $(XARGS) chmod 0755
-       find $(TARGET_DIR) -type d | $(XARGS) chmod 0755
+       find $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' | $(XARGS) chmod 0644
+       find $(TARGET_DIR) -type f -perm +0100 | $(XARGS) chmod 0755
+       find $(TARGET_DIR) -type d | $(XARGS) chmod 0755
        $(INSTALL_DIR) $(TARGET_DIR)/tmp
        chmod 0777 $(TARGET_DIR)/tmp
 endef
@@ -127,6 +150,7 @@ ifneq ($(IB),1)
        $(call Image/mkfs/cpiogz)
        $(call Image/mkfs/ext2)
        $(call Image/mkfs/iso)
+       $(call Image/Checksum)
 else
   install: compile install-targets
        $(call Image/BuildKernel)
@@ -136,6 +160,7 @@ else
        $(call Image/mkfs/cpiogz)
        $(call Image/mkfs/ext2)
        $(call Image/mkfs/iso)
+       $(call Image/Checksum)
 endif
 
 ifneq ($(IB),1)