vti: add empty install rules for vtiv4 & vtiv6
[openwrt/openwrt.git] / include / kernel.mk
index 2721c83d8eddb9750988c7c9c6daf0fff025980a..4e66c0c76fd23845609382bee862ec3e0e178ba4 100644 (file)
@@ -5,8 +5,15 @@
 # See /LICENSE for more information.
 #
 
+ifneq ($(filter check,$(MAKECMDGOALS)),)
+CHECK:=1
+DUMP:=1
+endif
+
 ifeq ($(__target_inc),)
-  include $(INCLUDE_DIR)/target.mk
+  ifndef CHECK
+    include $(INCLUDE_DIR)/target.mk
+  endif
 endif
 
 ifeq ($(DUMP),1)