kernel: fix module dependency checking
[openwrt/openwrt.git] / include / package-ipkg.mk
index eb4c874047e8a9e24a4d77b13f7ba66e1221cbb5..b8f886bcdacca0bc44d03fd9c2b59ccc9b374227 100644 (file)
@@ -5,7 +5,9 @@
 # See /LICENSE for more information.
 #
 
-include $(INCLUDE_DIR)/feeds.mk
+ifndef DUMP
+  include $(INCLUDE_DIR)/feeds.mk
+endif
 
 # invoke ipkg-build with some default options
 IPKG_BUILD:= \
@@ -154,7 +156,7 @@ Package: $(1)
 Version: $(VERSION)
 $$(call addfield,Depends,$$(Package/$(1)/DEPENDS)
 )$$(call addfield,Conflicts,$$(call mergelist,$(CONFLICTS))
-)$$(call addfield,Provides,$(PROVIDES)
+)$$(call addfield,Provides,$$(call mergelist,$(PROVIDES))
 )$$(call addfield,Source,$(SOURCE)
 )$$(call addfield,License,$$(PKG_LICENSE)
 )$$(call addfield,LicenseFiles,$$(PKG_LICENSE_FILES)