ubox: move logd into ubox package
[openwrt/openwrt.git] / include / package.mk
index ff9a5df9e6698512479d4f5add1410b34588afb0..fa5c4e7d5d8d1cf53283a441378caa2ebb0030c4 100644 (file)
@@ -17,7 +17,7 @@ PKG_USE_MIPS16 ?= 1
 PKG_IREMAP ?= 1
 
 ifneq ($(CONFIG_PKG_BUILD_USE_JOBSERVER),)
-  MAKE_J:=$(if $(MAKE_JOBSERVER),$(MAKE_JOBSERVER) -j)
+  MAKE_J:=$(if $(MAKE_JOBSERVER),$(MAKE_JOBSERVER) $(if $(filter 3.% 4.0 4.1,$(MAKE_VERSION)),-j))
 else
   MAKE_J:=-j$(CONFIG_PKG_BUILD_JOBS)
 endif
@@ -167,7 +167,7 @@ define Build/DefaultTargets
        )
 
   $(STAMP_PREPARED) : export PATH=$$(TARGET_PATH_PKG)
-  $(STAMP_PREPARED):
+  $(STAMP_PREPARED): $(STAMP_PREPARED_DEPENDS)
        @-rm -rf $(PKG_BUILD_DIR)
        @mkdir -p $(PKG_BUILD_DIR)
        $(foreach hook,$(Hooks/Prepare/Pre),$(call $(hook))$(sep))
@@ -176,7 +176,7 @@ define Build/DefaultTargets
        touch $$@
 
   $(call Build/Exports,$(STAMP_CONFIGURED))
-  $(STAMP_CONFIGURED): $(STAMP_PREPARED)
+  $(STAMP_CONFIGURED): $(STAMP_PREPARED) $(STAMP_CONFIGURED_DEPENDS)
        $(CleanStaging)
        $(foreach hook,$(Hooks/Configure/Pre),$(call $(hook))$(sep))
        $(Build/Configure)
@@ -185,7 +185,7 @@ define Build/DefaultTargets
        touch $$@
 
   $(call Build/Exports,$(STAMP_BUILT))
-  $(STAMP_BUILT): $(STAMP_CONFIGURED)
+  $(STAMP_BUILT): $(STAMP_CONFIGURED) $(STAMP_BUILT_DEPENDS)
        $(foreach hook,$(Hooks/Compile/Pre),$(call $(hook))$(sep))
        $(Build/Compile)
        $(foreach hook,$(Hooks/Compile/Post),$(call $(hook))$(sep))