uboot-mvebu: add Methode eDPU support
[openwrt/openwrt.git] / package / boot / uboot-mvebu / Makefile
index 9a1b5ed63d18258684ebc8fbd6acfc70d97c92b7..5075dce2ab47632924c978321070e35012beea29 100644 (file)
@@ -8,10 +8,10 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
-PKG_VERSION:=2020.10-rc4
-PKG_RELEASE:=1
+PKG_VERSION:=2022.10
+PKG_RELEASE:=$(AUTORELEASE)
 
-PKG_HASH:=0a7bdd2c7df2c14daf2730fcf3277fd917aadfaae935529e29c7412314bbf260
+PKG_HASH:=50b4482a505bc281ba8470c399a3c26e145e29b23500bc35c50debd7fa46bdf8
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
@@ -36,42 +36,40 @@ define U-Boot/helios4
   UBOOT_IMAGE:=u-boot-spl.kwb
 endef
 
-define U-Boot/espressobin
-  NAME:=Marvell ESPRESSObin
-  BUILD_DEVICES:=globalscale_espressobin globalscale_espressobin-v7
-  BUILD_SUBTARGET:=cortexa53
-  UBOOT_CONFIG:=mvebu_espressobin-88f3720
+define U-Boot/omnia
+  NAME:=Turris Omnia
+  BUILD_DEVICES:=cznic_turris-omnia
+  BUILD_SUBTARGET:=cortexa9
+  UBOOT_CONFIG:=turris_omnia
+  UBOOT_IMAGE:=u-boot-spl.kwb
 endef
 
-define U-Boot/espressobin-emmc
+define U-Boot/espressobin
   NAME:=Marvell ESPRESSObin
-  BUILD_DEVICES:=globalscale_espressobin-emmc globalscale_espressobin-v7-emmc
   BUILD_SUBTARGET:=cortexa53
   UBOOT_CONFIG:=mvebu_espressobin-88f3720
-  UBOOT_MAKE_FLAGS+=DEVICE_TREE=armada-3720-espressobin-emmc
 endef
 
 define U-Boot/uDPU
   NAME:=Methode uDPU
-  BUILD_DEVICES:=methode_udpu
+  BUILD_SUBTARGET:=cortexa53
+endef
+
+define U-Boot/eDPU
+  NAME:=Methode eDPU
   BUILD_SUBTARGET:=cortexa53
 endef
 
 UBOOT_TARGETS:= \
        clearfog \
        helios4 \
+       omnia \
        espressobin \
-       espressobin-emmc \
-       uDPU
-
-Build/Exports:=$(Host/Exports)
-
-define Build/Configure
-       # enable additional options beyond <device>_defconfig
-       echo CONFIG_NET_RANDOM_ETHADDR=y >> $(PKG_BUILD_DIR)/configs/$(UBOOT_CONFIG)_defconfig
-       echo CONFIG_CMD_SETEXPR=y >> $(PKG_BUILD_DIR)/configs/$(UBOOT_CONFIG)_defconfig
+       uDPU \
+       eDPU
 
-       $(call Build/Configure/U-Boot)
+define Package/u-boot/install
+       $(if $(findstring cortexa53,$(BUILD_SUBTARGET)),,$(Package/u-boot/install/default))
 endef
 
 define Build/InstallDev