perf: disable build for ARC, it is currently broken
[openwrt/openwrt.git] / package / devel / perf / Makefile
index 3a36a7b98f7e4b0dcda96c6c3481cecfc91cd387..35f1719d3184dfe0e4fbf585b5702a317decd249 100644 (file)
@@ -14,7 +14,8 @@ PKG_RELEASE:=2
 
 PKG_USE_MIPS16:=0
 PKG_BUILD_PARALLEL:=1
-PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_FLAGS:=nonshared
 
 # Perf's makefile and headers are not relocatable and must be built from the
 # Linux sources directory
@@ -25,7 +26,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/perf
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:= @!USE_UCLIBC +libelf1 +libdw +libpthread +librt +objdump
+  DEPENDS:= +libelf1 +libdw +libpthread +librt +objdump @!LINUX_3_18 @!IN_SDK @!arc
   TITLE:=Linux performance monitoring tool
   VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
   URL:=http://www.kernel.org
@@ -49,6 +50,8 @@ MAKE_FLAGS = \
        NO_LIBNUMA=1 \
        NO_GTK2=1 \
        NO_LIBAUDIT=1 \
+       NO_LIBCRYPTO=1 \
+       NO_LIBUNWIND=1 \
        CROSS_COMPILE="$(TARGET_CROSS)" \
        CC="$(TARGET_CC)" \
        LD="$(TARGET_CROSS)ld" \
@@ -58,8 +61,10 @@ MAKE_FLAGS = \
        WERROR=0 \
        prefix=/usr
 
+ifdef CONFIG_LINUX_4_4
 ifdef CONFIG_USE_MUSL
- MAKE_FLAGS += EXTRA_CFLAGS="-include $(CURDIR)/musl-compat.h -D__UCLIBC__"
+ MAKE_FLAGS += EXTRA_CFLAGS="-I$(CURDIR)/musl-include -include $(CURDIR)/musl-compat.h -D__UCLIBC__"
+endif
 endif
 
 define Build/Compile