kernel: fix kmod-rxrpc with kernel 4.9
[openwrt/openwrt.git] / package / kernel / linux / modules / netsupport.mk
index 3d5e74327aaf9da90fc94ed2baaee66cd8caa42a..b2764e5f6ba080502f8fbc8193c4e31cfedab987 100644 (file)
@@ -45,7 +45,6 @@ $(eval $(call KernelPackage,atmtcp))
 define KernelPackage/appletalk
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=Appletalk protocol support
-  DEPENDS:=+PACKAGE_kmod-llc:kmod-llc
   KCONFIG:= \
        CONFIG_ATALK \
        CONFIG_DEV_APPLETALK \
@@ -80,71 +79,6 @@ endef
 $(eval $(call KernelPackage,bonding))
 
 
-define KernelPackage/bridge
-  SUBMENU:=$(NETWORK_SUPPORT_MENU)
-  TITLE:=Ethernet bridging support
-  DEPENDS:=+kmod-stp
-  KCONFIG:= \
-       CONFIG_BRIDGE \
-       CONFIG_BRIDGE_IGMP_SNOOPING=y
-  FILES:=$(LINUX_DIR)/net/bridge/bridge.ko
-  AUTOLOAD:=$(call AutoLoad,11,bridge)
-endef
-
-define KernelPackage/bridge/description
- Kernel module for Ethernet bridging.
-endef
-
-$(eval $(call KernelPackage,bridge))
-
-define KernelPackage/llc
-  SUBMENU:=$(NETWORK_SUPPORT_MENU)
-  TITLE:=ANSI/IEEE 802.2 LLC support
-  KCONFIG:=CONFIG_LLC
-  FILES:= \
-       $(LINUX_DIR)/net/llc/llc.ko \
-       $(LINUX_DIR)/net/802/p8022.ko \
-       $(LINUX_DIR)/net/802/psnap.ko
-  AUTOLOAD:=$(call AutoLoad,09,llc p8022 psnap)
-endef
-
-define KernelPackage/llc/description
- Kernel module for ANSI/IEEE 802.2 LLC support.
-endef
-
-$(eval $(call KernelPackage,llc))
-
-define KernelPackage/stp
-  SUBMENU:=$(NETWORK_SUPPORT_MENU)
-  TITLE:=Ethernet Spanning Tree Protocol support
-  DEPENDS:=+kmod-llc
-  KCONFIG:=CONFIG_STP
-  FILES:=$(LINUX_DIR)/net/802/stp.ko
-  AUTOLOAD:=$(call AutoLoad,10,stp)
-endef
-
-define KernelPackage/stp/description
- Kernel module for Ethernet Spanning Tree Protocol support.
-endef
-
-$(eval $(call KernelPackage,stp))
-
-define KernelPackage/8021q
-  SUBMENU:=$(NETWORK_SUPPORT_MENU)
-  TITLE:=802.1Q VLAN support
-  KCONFIG:=CONFIG_VLAN_8021Q \
-               CONFIG_VLAN_8021Q_GVRP=n
-  FILES:=$(LINUX_DIR)/net/8021q/8021q.ko
-  AUTOLOAD:=$(call AutoLoad,12,8021q)
-endef
-
-define KernelPackage/8021q/description
- Kernel module for 802.1Q VLAN support
-endef
-
-$(eval $(call KernelPackage,8021q))
-
-
 define KernelPackage/udptunnel4
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=IPv4 UDP tunneling support
@@ -533,7 +467,7 @@ $(eval $(call KernelPackage,gre))
 define KernelPackage/gre6
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=GRE support over IPV6
-  DEPENDS:=@IPV6 +kmod-iptunnel +kmod-ip6-tunnel
+  DEPENDS:=@IPV6 +kmod-iptunnel +kmod-ip6-tunnel +kmod-gre
   KCONFIG:=CONFIG_IPV6_GRE
   FILES:=$(LINUX_DIR)/net/ipv6/ip6_gre.ko
   AUTOLOAD:=$(call AutoLoad,39,ip6_gre)
@@ -990,8 +924,8 @@ define KernelPackage/rxrpc
        CONFIG_AF_RXRPC_DEBUG=n
   FILES:= \
        $(LINUX_DIR)/net/rxrpc/af-rxrpc.ko \
-       $(LINUX_DIR)/net/rxrpc/rxkad.ko
-  AUTOLOAD:=$(call AutoLoad,30,rxkad af-rxrpc)
+       $(LINUX_DIR)/net/rxrpc/rxkad.ko@lt4.7
+  AUTOLOAD:=$(call AutoLoad,30,rxkad@lt4.7 af-rxrpc)
   DEPENDS:= +kmod-crypto-manager +kmod-crypto-pcbc +kmod-crypto-fcrypt
 endef