polarssl: update to version 1.3.17
[openwrt/openwrt.git] / package / libs / polarssl / Makefile
index c7e603623a8679f9e20cdcc5f213ccafa170c294..2f2029f9d8ea61c54e822a430302a346be6bfe3b 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2011-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -7,14 +7,17 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=mbedtls
-PKG_VERSION:=1.3.11
-PKG_RELEASE:=2
+PKG_NAME:=polarssl
+SRC_PKG_NAME:=mbedtls
+PKG_VERSION:=1.3.17
+PKG_RELEASE:=1
 PKG_USE_MIPS16:=0
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
-PKG_SOURCE_URL:=https://polarssl.org/download/
-PKG_MD5SUM:=c02ce2e54862d678604794ee484fb59e
+PKG_SOURCE:=$(SRC_PKG_NAME)-$(PKG_VERSION)-gpl.tgz
+PKG_SOURCE_URL:=https://tls.mbed.org/download/
+PKG_MD5SUM:=f5beb43e850283915e3e0f8d37495eade3bfb5beedfb61e7b8da70d4c68edb82
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(SRC_PKG_NAME)-$(PKG_VERSION)
 
 PKG_BUILD_PARALLEL:=1
 PKG_LICENSE:=GPL-2.0+