update to 2.6.27.13
[openwrt/openwrt.git] / target / linux / adm5120 / Makefile
index 4cc10ef6202739eff1f066ccbed88b85c94f4158..914a5d774a6399d95301860749d33cff324da46a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007,2008 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
-BOARDNAME:=Infineon ADM5120
-LINUX_VERSION:=2.6.24.5
+BOARDNAME:=Infineon/ADMtek ADM5120
+LINUX_VERSION:=2.6.27.13
 SUBTARGETS:=router_le router_be
 INITRAMFS_EXTRA_FILES:=
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += admswconfig
+DEFAULT_PACKAGES += admswconfig hostapd-mini kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug
 
 $(eval $(call BuildTarget))