bcm53xx: make USB packages compatible with kernels 4.13+
[openwrt/openwrt.git] / target / linux / ar7 / Makefile
index f6da81212395dd56c7a3cc1023d339204290f20e..c5a6035b53fc5e7c8b09a2e856e87c0579c71a28 100644 (file)
@@ -1,5 +1,5 @@
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=ar7
 BOARDNAME:=TI AR7
-FEATURES:=squashfs jffs2 atm
-
-LINUX_VERSION:=2.6.25.15
+FEATURES:=squashfs atm low_mem
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+SUBTARGETS:=generic ac49x
 
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=3.18
 
 define Target/Description
-       Build firmware images for TI AR7 based routers
+       Build firmware images for TI AR7 based routers.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES+= swconfig
+
 $(eval $(call BuildTarget))