ar71xx: add profile and build image for the TL-WA701N/ND boards
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / atheros.mk
index 97d503257440db2cb2f6b54d832ae4a39ad8b48b..f26d7a788a7eddbc8c1ae5e38dcc9cd029a707bd 100644 (file)
@@ -5,9 +5,31 @@
 # See /LICENSE for more information.
 #
 
+define Profile/AP121
+       NAME:=Atheros AP121 reference board
+       PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/AP121/Description
+       Package set optimized for the Atheros AP121 reference board.
+endef
+
+$(eval $(call Profile,AP121))
+
+define Profile/AP121MINI
+       NAME:=Atheros AP121-MINI reference board
+       PACKAGES:=
+endef
+
+define Profile/AP121MINI/Description
+       Package set optimized for the Atheros AP121-MINI reference board.
+endef
+
+$(eval $(call Profile,AP121MINI))
+
 define Profile/AP81
        NAME:=Atheros AP81 reference board
-       PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2
+       PACKAGES:=kmod-usb-core kmod-usb2
 endef
 
 define Profile/AP81/Description
@@ -18,7 +40,7 @@ $(eval $(call Profile,AP81))
 
 define Profile/AP83
        NAME:=Atheros AP83 reference board
-       PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2 \
+       PACKAGES:=kmod-usb-core kmod-usb2 \
                  vsc7385-ucode-ap83 vsc7395-ucode-ap83
 endef
 
@@ -30,7 +52,7 @@ $(eval $(call Profile,AP83))
 
 define Profile/AP96
        NAME:=Atheros AP96 reference board
-       PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2
+       PACKAGES:=kmod-usb-core kmod-usb2
 endef
 
 define Profile/AP96/Description
@@ -39,9 +61,20 @@ endef
 
 $(eval $(call Profile,AP96))
 
+define Profile/DB120
+       NAME:=Atheros DB120 reference board
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-usb-storage
+endef
+
+define Profile/DB120/Description
+       Package set optimized for the Atheros DB120 reference board.
+endef
+
+$(eval $(call Profile,DB120))
+
 define Profile/PB42
        NAME:=Atheros PB42 reference board
-       PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb-ohci kmod-usb2
+       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
 endef
 
 define Profile/PB42/Description
@@ -52,7 +85,7 @@ $(eval $(call Profile,PB42))
 
 define Profile/PB44
        NAME:=Atheros PB44 reference board
-       PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb-ohci kmod-usb2 \
+       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 \
                  vsc7385-ucode-pb44 vsc7395-ucode-pb44
 endef
 
@@ -64,7 +97,7 @@ $(eval $(call Profile,PB44))
 
 define Profile/PB92
        NAME:=Atheros PB92 reference board
-       PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2
+       PACKAGES:=kmod-usb-core kmod-usb2
 endef
 
 define Profile/PB92/Description