ar71xx: improve Mikrotik hAP Lite device support
[openwrt/openwrt.git] / target / linux / ar71xx / image / generic.mk
index 1f96a5b960b805d4e964265e728c675514eb25f9..ab64e76d7c65e3d58875de21c081e722ec40934e 100644 (file)
@@ -323,6 +323,17 @@ endef
 
 TARGET_DEVICES += cr5000-nocloud
 
+define Device/pqi-air-pen
+  DEVICE_TITLE := PQI Air Pen
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage
+  BOARDNAME = PQI-AIR-PEN
+  IMAGE_SIZE = 7744k
+  CONSOLE = ttyATH0,115200
+  MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,64k(art)ro,64k(NVRAM)ro,7680k(firmware),64k(CONF)
+endef
+
+TARGET_DEVICES += pqi-air-pen
+
 define Device/antminer-s1
   $(Device/tplink-8mlzma)
   DEVICE_TITLE := Antminer-S1
@@ -755,25 +766,3 @@ define Device/bhr-4grv2
   IMAGE/factory.bin = append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | mkbuffaloimg
 endef
 TARGET_DEVICES += bhr-4grv2
-
-
-# factory image starts with a header of size 60 (0x3c) bytes.  The header is
-# only used for checking integrity of the firmware image without being written
-# to flash chip.  That means it's okay we include jffs2 pads when computing
-# checksums
-define Build/wrt400n-factory
-       cp $(IMAGE_ROOTFS) $(IMAGE_ROOTFS).tmp
-       $(STAGING_DIR_HOST)/bin/padjffs2 $(IMAGE_ROOTFS).tmp $(BLOCKSIZE:%k=%)
-       $(STAGING_DIR_HOST)/bin/wrt400n $(IMAGE_KERNEL) $(IMAGE_ROOTFS).tmp $@
-       rm -f $(IMAGE_ROOTFS).tmp
-endef
-
-define Device/wrt400n
-  DEVICE_TITLE := Linksys WRT400N
-  BOARDNAME := WRT400N
-  CONSOLE := ttyS0,115200
-  IMAGES := sysupgrade.bin factory.bin
-  IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size 0x770000
-  IMAGE/factory.bin = wrt400n-factory | check-size 0x77003c
-endef
-TARGET_DEVICES += wrt400n