at91: Add SAMA5D2 device
[openwrt/openwrt.git] / target / linux / at91 / Makefile
index c9e04c534e0dcaeabf53cf1d449dd5c33318207d..948419a7aa4ccd3d5483a016ec63420a285d47da 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2010 OpenWrt.org
+#
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,17 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=at91
 MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
-BOARDNAME:=Atmel AT91
-FEATURES:=squashfs jffs2 targz ext2 usb
-CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
-SUBTARGETS:=9g20 9260 9263
+BOARDNAME:=Microchip (Atmel AT91)
+FEATURES:=squashfs targz ext2 usb usbgadget ubifs
+SUBTARGETS:=sama5 legacy
 
-LINUX_VERSION:=3.3.5
-DEVICE_TYPE=
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES+= kmod-usb-ohci
-KERNELNAME:="uImage"
+KERNELNAME:=zImage dtbs
+
+DEFAULT_PACKAGES += kmod-usb-ohci kmod-at91-udc kmod-usb-gadget-eth
 
 $(eval $(call BuildTarget))