bcm53xx: make USB packages compatible with kernels 4.13+
[openwrt/openwrt.git] / target / linux / bcm53xx / Makefile
index 7654f1646e10995072c676790a73a393b826d0d0..30730ea47b5de6be3e5e1512a025114e8ce562bf 100644 (file)
@@ -13,17 +13,18 @@ FEATURES:=squashfs nand usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
 
-KERNEL_PATCHVER:=4.4
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=4.9
 
 define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES += swconfig wpad-mini nvram otrx \
+DEFAULT_PACKAGES += swconfig nvram \
+       osafeloader oseama otrx \
        kmod-gpio-button-hotplug \
        kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer