gemini: Generate harddisk image for DNS-313
[openwrt/openwrt.git] / target / linux / gemini / image / Makefile
index ca0cb001e485ff652942de1d58e1b7efa8bee779..7fcac8051f661fd71267a50592682809d54f2804 100644 (file)
@@ -28,6 +28,7 @@ endef
 # the only real content.
 define Build/dns313-images
        mkdir -p $@.tmp/.boot
+       chmod 755 $@.tmp/.boot
 
        echo "dummy" > $@.tmp/dummyfile
 
@@ -38,13 +39,35 @@ define Build/dns313-images
        dns313-header $(IMAGE_KERNEL) \
                $@.tmp/.boot/zImage
 
-       tar --sort=name --owner=0 --group=0 --numeric-owner -czf $@ \
-               -C $@.tmp .boot \
-               $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)")
+       rm $@.tmp/dummyfile
+
+       genext2fs --block-size $(BLOCKSIZE:%k=%Ki) \
+               --size-in-blocks $$((1024 * $(CONFIG_TARGET_KERNEL_PARTSIZE))) \
+               --squash-uids \
+               --root $@.tmp $@.tmp-boot
+
+       # The device firmware needs revision 1 of EXT2
+       tune2fs -O filetype $@.tmp-boot
+       e2fsck -pDf $@.tmp-boot > /dev/null
+
+       ./dns313_gen_hdd_img.sh $@ $@.tmp-boot $(IMAGE_ROOTFS) \
+               $(CONFIG_TARGET_KERNEL_PARTSIZE) \
+               $(CONFIG_TARGET_ROOTFS_PARTSIZE)
 
        rm -rf $@.tmp
 endef
 
+define Build/wiligear-image
+       $(STAGING_DIR_HOST)/bin/mkfwimage2 \
+               -m GEOS -f 0x30000000 -z \
+               -v $(1).v5.00.SL3512.OpenWrt.00000.000000.000000 \
+               -p Kernel:0x020000:0x100000:0:0:$(IMAGE_KERNEL) \
+               -p Ramdisk:0x120000:0x500000:0:0:$@ \
+               -o $@.new
+
+       mv $@.new $@
+endef
+
 # Create the special NAS4220B and Itian Square One SQ201 image
 # format with the squashfs and overlay inside the "rd.gz" file.
 # We pad it out to 6144K which is the size of the initramfs partition.
@@ -60,6 +83,8 @@ define Build/nas4220b-sq201-images
        cp $(IMAGE_KERNEL) $@.tmp/zImage
        cp ./ImageInfo-$(1) $@.tmp/ImageInfo
 
+       sed -i -e "s/DATESTR/`date +%Y%m%d $(if $(SOURCE_DATE_EPOCH),--date "@$(SOURCE_DATE_EPOCH)")`/g" $@.tmp/ImageInfo
+
        (cd $@.tmp; tar --sort=name --owner=0 --group=0 --numeric-owner -czf $@ * \
                $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)"))
 
@@ -80,7 +105,6 @@ endef
 # All DTB files are prefixed with "gemini-"
 define Device/Default
        PROFILES := Default
-       DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
        KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
        KERNEL_NAME := zImage
        KERNEL := kernel-bin | append-dtb
@@ -94,61 +118,75 @@ GEMINI_NAS_PACKAGES:=kmod-md-mod kmod-md-linear kmod-md-multipath \
                kmod-fs-btrfs kmod-fs-cifs kmod-fs-nfs \
                kmod-fs-nfsd kmod-fs-ntfs kmod-fs-reiserfs kmod-fs-vfat \
                kmod-nls-utf8 kmod-usb-storage-extras \
-               samba36-server mdadm cfdisk fdisk e2fsprogs badblocks
+               samba36-server mdadm cfdisk fdisk e2fsprogs badblocks \
+               partx-utils
 
-define Device/dlink-dir-685
+define Device/dlink_dir-685
        DEVICE_TITLE := D-Link DIR-685 Xtreme N Storage Router
+       DEVICE_DTS := gemini-dlink-dir-685
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) \
                        kmod-switch-rtl8366rb swconfig \
-                       rt2800-pci
+                       kmod-rt2800-pci
        IMAGES := factory.bin
        IMAGE/factory.bin := dir685-images
 endef
-TARGET_DEVICES += dlink-dir-685
+TARGET_DEVICES += dlink_dir-685
 
-define Device/dlink-dns-313
+define Device/dlink_dns-313
        DEVICE_TITLE := D-Link DNS-313 1-Bay Network Storage Enclosure
+       DEVICE_DTS := gemini-dlink-dns-313
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
-       IMAGES := factory.bin
-       IMAGE/factory.bin := dns313-images
+       BLOCKSIZE := 1k
+       FILESYSTEMS := ext4
+       IMAGES := factory.bin.gz
+       IMAGE/factory.bin.gz := dns313-images | gzip
 endef
-TARGET_DEVICES += dlink-dns-313
+TARGET_DEVICES += dlink_dns-313
 
-define Device/nas4220b-sq201
+define Device/itian-raidsonic
        IMAGES := factory.bin
-       IMAGE/factory.bin := append-rootfs | pad-to 6144k | nas4220b-sq201-images $(1)
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 6144k | \
+               nas4220b-sq201-images $(1)
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
 endef
 
-define Device/nas4220b
-       $(Device/nas4220b-sq201)
-       DEVICE_TITLE := Raidsonic NAS IB-4220-B
-endef
-TARGET_DEVICES += nas4220b
-
-define Device/rut1xx
-       DEVICE_TITLE := Teltonika RUT1xx
-       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
+define Device/itian_sq201
+       $(Device/itian-raidsonic)
+       DEVICE_TITLE := ITian Square One SQ201
+       DEVICE_DTS := gemini-sq201
+       DEVICE_PACKAGES += kmod-rt61-pci kmod-usb2-pci
 endef
-TARGET_DEVICES += rut1xx
+TARGET_DEVICES += itian_sq201
 
-define Device/sq201
-       $(Device/nas4220b-sq201)
-       DEVICE_TITLE := ITian Square One SQ201
-       DEVICE_PACKAGES += rt61-pci usb2-pci
+define Device/raidsonic_ib-4220-b
+       $(Device/itian-raidsonic)
+       DEVICE_TITLE := Raidsonic NAS IB-4220-B
+       DEVICE_DTS := gemini-nas4220b
 endef
-TARGET_DEVICES += sq201
+TARGET_DEVICES += raidsonic_ib-4220-b
 
-define Device/wbd111
+# The wiliboard images need some changes to be functional and buildable.
+#
+# The dts would need to use the ecoscentric,redboot-fis-partitions partition
+# parser to get the correct partition offsets and size.
+#
+# The mkfwimage2 call need to be adjusted to reflect the real size of kernel
+# and rootfs. It is expected that the OEM firmware adjusts the on flash
+# partition table with the values defined in the image header.
+define Device/wiliboard_wbd111
        DEVICE_TITLE := Wiliboard WBD-111
+       DEVICE_DTS := gemini-wbd111
        KERNEL := kernel-bin | append-dtb | wbd-nops
+       IMAGES := factory.bin
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | wiligear-image "WILI-S.WILIBOARD"
 endef
-TARGET_DEVICES += wbd111
 
-define Device/wbd222
+define Device/wiliboard_wbd222
        DEVICE_TITLE := Wiliboard WBD-222
+       DEVICE_DTS := gemini-wbd222
        KERNEL := kernel-bin | append-dtb | wbd-nops
+       IMAGES := factory.bin
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | wiligear-image "WILI-S.WBD222"
 endef
-TARGET_DEVICES += wbd222
 
 $(eval $(call BuildImage))