gemini: Generate harddisk image for DNS-313
authorLinus Walleij <linus.walleij@linaro.org>
Fri, 15 Feb 2019 16:02:23 +0000 (17:02 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Wed, 20 Feb 2019 17:51:31 +0000 (18:51 +0100)
This makes OpenWrt build an Ext2+Ext4 partitioned image
for the D-Link DNS-313 with two blank partitions, a boot
partition on /dev/sda3 and a rootfs partition on
/dev/sda4.

This uses the methods already used in apm821xx including
the tricks to convert the generated Ext2 filesystem
partition to version 1 so that the firmware bootloader
will properly recognize it.

We patch a bit around the build files to make sure we
get the rootfs size set and that genext2fs is properly
built.

Tested on the D-Link DNS-313.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
[Fixing and tricksing]
Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
target/linux/gemini/Makefile
target/linux/gemini/image/Makefile
target/linux/gemini/image/dns313_gen_hdd_img.sh [new file with mode: 0755]
tools/Makefile

index 7c573c7c6d09fd8bd4214e2f672c36007e7b80bd..304e515980a5181cc5b8ffd708273c7a11ff7ec1 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=gemini
 BOARDNAME:=Cortina Systems CS351x
-FEATURES:=squashfs pci rtc usb dt gpio display
+FEATURES:=squashfs pci rtc usb dt gpio display ext4 rootfs-part boot-part
 CPU_TYPE:=fa526
 MAINTAINER:=Roman Yeryomin <roman@advem.lv>
 
index a612cf706d63ab4e1a206116f758b0a54bf1d381..7fcac8051f661fd71267a50592682809d54f2804 100644 (file)
@@ -28,6 +28,7 @@ endef
 # the only real content.
 define Build/dns313-images
        mkdir -p $@.tmp/.boot
+       chmod 755 $@.tmp/.boot
 
        echo "dummy" > $@.tmp/dummyfile
 
@@ -38,9 +39,20 @@ define Build/dns313-images
        dns313-header $(IMAGE_KERNEL) \
                $@.tmp/.boot/zImage
 
-       tar --sort=name --owner=0 --group=0 --numeric-owner -czf $@ \
-               -C $@.tmp .boot \
-               $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)")
+       rm $@.tmp/dummyfile
+
+       genext2fs --block-size $(BLOCKSIZE:%k=%Ki) \
+               --size-in-blocks $$((1024 * $(CONFIG_TARGET_KERNEL_PARTSIZE))) \
+               --squash-uids \
+               --root $@.tmp $@.tmp-boot
+
+       # The device firmware needs revision 1 of EXT2
+       tune2fs -O filetype $@.tmp-boot
+       e2fsck -pDf $@.tmp-boot > /dev/null
+
+       ./dns313_gen_hdd_img.sh $@ $@.tmp-boot $(IMAGE_ROOTFS) \
+               $(CONFIG_TARGET_KERNEL_PARTSIZE) \
+               $(CONFIG_TARGET_ROOTFS_PARTSIZE)
 
        rm -rf $@.tmp
 endef
@@ -106,7 +118,8 @@ GEMINI_NAS_PACKAGES:=kmod-md-mod kmod-md-linear kmod-md-multipath \
                kmod-fs-btrfs kmod-fs-cifs kmod-fs-nfs \
                kmod-fs-nfsd kmod-fs-ntfs kmod-fs-reiserfs kmod-fs-vfat \
                kmod-nls-utf8 kmod-usb-storage-extras \
-               samba36-server mdadm cfdisk fdisk e2fsprogs badblocks
+               samba36-server mdadm cfdisk fdisk e2fsprogs badblocks \
+               partx-utils
 
 define Device/dlink_dir-685
        DEVICE_TITLE := D-Link DIR-685 Xtreme N Storage Router
@@ -123,8 +136,10 @@ define Device/dlink_dns-313
        DEVICE_TITLE := D-Link DNS-313 1-Bay Network Storage Enclosure
        DEVICE_DTS := gemini-dlink-dns-313
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
-       IMAGES := bootpart.tar.gz
-       IMAGE/bootpart.tar.gz := dns313-images
+       BLOCKSIZE := 1k
+       FILESYSTEMS := ext4
+       IMAGES := factory.bin.gz
+       IMAGE/factory.bin.gz := dns313-images | gzip
 endef
 TARGET_DEVICES += dlink_dns-313
 
diff --git a/target/linux/gemini/image/dns313_gen_hdd_img.sh b/target/linux/gemini/image/dns313_gen_hdd_img.sh
new file mode 100755 (executable)
index 0000000..1eb2c7c
--- /dev/null
@@ -0,0 +1,28 @@
+#!/usr/bin/env bash
+
+set -x
+[ $# -eq 5 ] || {
+       echo "SYNTAX: $0 <file> <bootfs image> <rootfs image> <bootfs size> <rootfs size>"
+       exit 1
+}
+
+OUTPUT="$1"
+BOOTFS="$2"
+ROOTFS="$3"
+BOOTFSSIZE="$4"
+ROOTFSSIZE="$5"
+
+head=4
+sect=63
+
+# Create two empty partitions followed by the boot partition with
+# the ./boot/zImage and then the rootfs partition.
+set `ptgen -o $OUTPUT -h $head -s $sect -t 83 -n -p 0 -p 0 -p ${BOOTFSSIZE}M -p ${ROOTFSSIZE}M`
+
+BOOTOFFSET="$(($1 / 512))"
+BOOTSIZE="$(($2 / 512))"
+ROOTFSOFFSET="$(($3 / 512))"
+ROOTFSSIZE="$(($4 / 512))"
+
+dd bs=512 if="$BOOTFS" of="$OUTPUT" seek="$BOOTOFFSET" conv=notrunc
+dd bs=512 if="$ROOTFS" of="$OUTPUT" seek="$ROOTFSOFFSET" conv=notrunc
index cacba5bcb46715819997e51b117fb1ed13b3649c..0123a759c82600db51202bb1d5aaad7084b66361 100644 (file)
@@ -37,7 +37,7 @@ tools-y += lzma squashfs4 zip
 tools-$(BUILD_B43_TOOLS) += b43-tools
 tools-$(BUILD_ISL) += isl
 tools-$(CONFIG_USE_SPARSE) += sparse
-tools-$(CONFIG_TARGET_apm821xx) += genext2fs
+tools-$(CONFIG_TARGET_apm821xx)$(CONFIG_TARGET_gemini) += genext2fs
 
 # builddir dependencies
 $(curdir)/bison/compile := $(curdir)/flex/compile