kernel: bump 4.14 to 4.14.48 for 18.06
[openwrt/openwrt.git] / target / linux / ipq806x / patches-4.14 / 0063-1-ipq806x-tsens-driver.patch
index b427550cd8cfa28575111191f05fb702ed67b229..685b0c3ce18a581e271c67be8ba622080412cc96 100644 (file)
@@ -39,7 +39,7 @@ Signed-off-by: Rajith Cherian <rajith@codeaurora.org>
   - "qcom,msm8974-tsens" : For 8974 Family of SoCs
   - "qcom,msm8996-tsens" : For 8996 Family of SoCs
 + - "qcom,ipq8064-tsens" : For IPQ8064
-
  - reg: Address range of the thermal registers
  - #thermal-sensor-cells : Should be 1. See ./thermal.txt for a description.
 --- a/drivers/thermal/qcom/Makefile
@@ -606,22 +606,22 @@ Signed-off-by: Rajith Cherian <rajith@codeaurora.org>
 --- a/drivers/thermal/qcom/tsens.c
 +++ b/drivers/thermal/qcom/tsens.c
 @@ -72,6 +72,9 @@ static const struct of_device_id tsens_t
-       }, {
-               .compatible = "qcom,msm8996-tsens",
-               .data = &data_8996,
+       }, {
+               .compatible = "qcom,msm8996-tsens",
+               .data = &data_8996,
 +      }, {
 +              .compatible = "qcom,ipq8064-tsens",
 +              .data = &data_ipq8064,
-       },
-       {}
+       },
+       {}
  };
 --- a/drivers/thermal/qcom/tsens.h
 +++ b/drivers/thermal/qcom/tsens.h
 @@ -89,6 +89,6 @@ void compute_intercept_slope(struct tsen
  int init_common(struct tsens_device *);
  int get_temp_common(struct tsens_device *, int, int *);
-
 -extern const struct tsens_data data_8916, data_8974, data_8960, data_8996;
 +extern const struct tsens_data data_8916, data_8974, data_8960, data_8996, data_ipq8064;
-
  #endif /* __QCOM_TSENS_H__ */