oxnas: reboot target
[openwrt/openwrt.git] / target / linux / oxnas / Makefile
index 0d9d356734094473104302f544dc765228500018..52d57f336a321e882374fb29c92345ee8920ed44 100644 (file)
@@ -1,29 +1,21 @@
-#
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=oxnas
-BOARDNAME:=PLXTECH/Oxford NAS782x/OX82x
+BOARDNAME:=PLXTECH/Oxford NAS782x/OX8xx
+SUBTARGETS:=ox810se ox820
+FEATURES:=gpio ramdisk rtc squashfs
 DEVICE_TYPE:=nas
-FEATURES:=gpio nand pcie usb ramdisk rtc squashfs ubifs
-CPU_TYPE:=mpcore
 
 MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
 
-KERNEL_PATCHVER:=4.4
+KERNEL_PATCHVER:=4.14
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-ata-core kmod-ata-oxnas-sata kmod-button-hotplug \
-       kmod-input-gpio-keys-polled kmod-usb-ledtrig-usbport \
-       kmod-ledtrig-timer kmod-leds-gpio kmod-usb2-oxnas \
-       kmod-usb-storage uboot-envtools uboot-oxnas-ox820
+       kmod-button-hotplug kmod-input-gpio-keys-polled \
+       kmod-ledtrig-timer kmod-leds-gpio uboot-envtools
 
 KERNELNAME:=zImage dtbs